about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2017-09-02 04:15:20 -0500
committerAustin Seipp <aseipp@pobox.com>2017-09-02 04:19:11 -0500
commit54ae0aa1b08efbb82d76dbe5601e06cf7dc7a8b1 (patch)
tree0389c39abd7fd788f00758f2505c158844375551 /pkgs/applications
parent583ebc086c64d6456af8e6d960377d0693ffc8a2 (diff)
downloadnixlib-54ae0aa1b08efbb82d76dbe5601e06cf7dc7a8b1.tar
nixlib-54ae0aa1b08efbb82d76dbe5601e06cf7dc7a8b1.tar.gz
nixlib-54ae0aa1b08efbb82d76dbe5601e06cf7dc7a8b1.tar.bz2
nixlib-54ae0aa1b08efbb82d76dbe5601e06cf7dc7a8b1.tar.lz
nixlib-54ae0aa1b08efbb82d76dbe5601e06cf7dc7a8b1.tar.xz
nixlib-54ae0aa1b08efbb82d76dbe5601e06cf7dc7a8b1.tar.zst
nixlib-54ae0aa1b08efbb82d76dbe5601e06cf7dc7a8b1.zip
z3_opt: remove and replace with z3
Z3 has supported optimization features since the 4.4.x release, so this can be
removed.

Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/logic/z3_opt/default.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/pkgs/applications/science/logic/z3_opt/default.nix b/pkgs/applications/science/logic/z3_opt/default.nix
deleted file mode 100644
index d3d63795d69b..000000000000
--- a/pkgs/applications/science/logic/z3_opt/default.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{ stdenv, fetchFromGitHub, python2 }:
-
-# Copied shamelessly from the normal z3 .nix
-
-let
-  python = python2;
-in stdenv.mkDerivation rec {
-  name = "z3_opt-${version}";
-  version = "4.3.2";
-
-  src = fetchFromGitHub {
-    owner  = "Z3Prover";
-    repo   = "z3";
-    rev    = "9377779e5818b2ca15c4f39921b2ba3a42f948e7";
-    sha256 = "15d6hsb61hrm5vy3l2gnkrfnqr68lvspnznm17vyhm61ld33yaff";
-  };
-
-  buildInputs = [ python ];
-  enableParallelBuilding = true;
-
-  configurePhase = "${python.interpreter} scripts/mk_make.py --prefix=$out && cd build";
-
-  # z3's install phase is stupid because it tries to calculate the
-  # python package store location itself, meaning it'll attempt to
-  # write files into the nix store, and fail.
-  soext = if stdenv.system == "x86_64-darwin" then ".dylib" else ".so";
-  installPhase = ''
-    mkdir -p $out/bin $out/${python.sitePackages} $out/include
-    cp ../src/api/z3*.h       $out/include
-    cp ../src/api/c++/z3*.h   $out/include
-    cp z3                     $out/bin
-    cp libz3${soext}          $out/lib
-    cp libz3${soext}          $out/${python.sitePackages}
-    cp z3*.pyc                $out/${python.sitePackages}
-    cp ../src/api/python/*.py $out/${python.sitePackages}
-  '';
-
-  meta = {
-    description = "A high-performance theorem prover and SMT solver, optimization edition";
-    homepage    = "https://github.com/Z3Prover/z3";
-    license     = stdenv.lib.licenses.mit;
-    platforms   = stdenv.lib.platforms.unix;
-    maintainers = with stdenv.lib.maintainers; [ thoughtpolice sheganinans ];
-  };
-}
-