about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2008-05-26 20:18:45 +0000
committerLudovic Courtès <ludo@gnu.org>2008-05-26 20:18:45 +0000
commit53be6f7ba47a10a24e2b10a78f6e8ebe62eb4474 (patch)
tree627f9f102c85580a1948637d5c9ff627402c3d99 /pkgs/applications
parent2d15d345ecb9096b2a133588624dff0395c91875 (diff)
downloadnixlib-53be6f7ba47a10a24e2b10a78f6e8ebe62eb4474.tar
nixlib-53be6f7ba47a10a24e2b10a78f6e8ebe62eb4474.tar.gz
nixlib-53be6f7ba47a10a24e2b10a78f6e8ebe62eb4474.tar.bz2
nixlib-53be6f7ba47a10a24e2b10a78f6e8ebe62eb4474.tar.lz
nixlib-53be6f7ba47a10a24e2b10a78f6e8ebe62eb4474.tar.xz
nixlib-53be6f7ba47a10a24e2b10a78f6e8ebe62eb4474.tar.zst
nixlib-53be6f7ba47a10a24e2b10a78f6e8ebe62eb4474.zip
Add cd-discid, a utility to retrieve a CD's CDDB ID.
svn path=/nixpkgs/trunk/; revision=11903
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/cd-discid/default.nix31
-rw-r--r--pkgs/applications/audio/cd-discid/install.patch14
2 files changed, 45 insertions, 0 deletions
diff --git a/pkgs/applications/audio/cd-discid/default.nix b/pkgs/applications/audio/cd-discid/default.nix
new file mode 100644
index 000000000000..24e0be5eac06
--- /dev/null
+++ b/pkgs/applications/audio/cd-discid/default.nix
@@ -0,0 +1,31 @@
+{ fetchurl, stdenv }:
+
+let version = "0.9";
+in
+  stdenv.mkDerivation {
+    name = "cd-discid-${version}";
+    src = fetchurl {
+      url = "mirror://debian/pool/main/c/cd-discid/cd-discid_${version}.orig.tar.gz";
+      sha256 = "1fx2ky1pb07l1r0bldpw16wdsfzw7a0093ib9v66kmilwy2sq5s9";
+    };
+
+    patches = [ ./install.patch ];
+
+    configurePhase = ''
+      sed -i "s|^[[:blank:]]*prefix *=.*$|prefix = $out|g ;
+	      s|^[[:blank:]]*INSTALL *=.*$|INSTALL = install -c|g"  \
+	  "Makefile";
+    '';
+
+    meta = {
+      homepage = http://lly.org/~rcw/cd-discid/;
+      licence = "GPLv2+";
+      description = "cd-discid, a command-line utility to retrieve a disc's CDDB ID";
+
+      longDescription = ''
+        cd-discid is a backend utility to get CDDB discid information
+        from a CD-ROM disc.  It was originally designed for cdgrab (now
+        abcde), but can be used for any purpose requiring CDDB data.
+      '';
+    };
+  }
\ No newline at end of file
diff --git a/pkgs/applications/audio/cd-discid/install.patch b/pkgs/applications/audio/cd-discid/install.patch
new file mode 100644
index 000000000000..4f0256813ff1
--- /dev/null
+++ b/pkgs/applications/audio/cd-discid/install.patch
@@ -0,0 +1,14 @@
+--- cd-discid-0.9/Makefile	2003-01-05 21:18:07.000000000 +0100
++++ cd-discid-0.9/Makefile	2008-05-26 22:14:56.000000000 +0200
+@@ -32,9 +32,9 @@ clean:
+ 
+ install: cd-discid
+ 	$(INSTALL) -d -m 755 $(bindir)
+-	$(INSTALL) -s -m 755 -o 0 cd-discid $(bindir)
++	$(INSTALL) -s -m 755 cd-discid $(bindir)
+ 	$(INSTALL) -d -m 755 $(mandir)
+-	$(INSTALL) -m 644 -o 0 cd-discid.1 $(mandir)
++	$(INSTALL) -m 644 cd-discid.1 $(mandir)
+ 
+ tarball:
+ 	@cd .. && tar czvf cd-discid_$(VERSION).orig.tar.gz \