about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-09-03 08:58:57 +0200
committerVladimír Čunát <vcunat@gmail.com>2017-09-03 09:57:20 +0200
commit53998f5036f98a2f4928eb328c1678966fa8bea4 (patch)
treebcbf9883e49674d4fef0b05035b39e48c51af2b7 /pkgs/applications
parentca12bd7a3f50296bffa052040afb3e7a65474687 (diff)
downloadnixlib-53998f5036f98a2f4928eb328c1678966fa8bea4.tar
nixlib-53998f5036f98a2f4928eb328c1678966fa8bea4.tar.gz
nixlib-53998f5036f98a2f4928eb328c1678966fa8bea4.tar.bz2
nixlib-53998f5036f98a2f4928eb328c1678966fa8bea4.tar.lz
nixlib-53998f5036f98a2f4928eb328c1678966fa8bea4.tar.xz
nixlib-53998f5036f98a2f4928eb328c1678966fa8bea4.tar.zst
nixlib-53998f5036f98a2f4928eb328c1678966fa8bea4.zip
treewide: purge explicit usage of gcc6
It's now the default. /cc #19456
This makes a real build simplification, because in our current
bootstrapping+aliases, `gcc6` attribute is not the default compiler
but a derivation *built by* the default compiler.

nix-exec didn't build before this commit already
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/freepv/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/applications/graphics/freepv/default.nix b/pkgs/applications/graphics/freepv/default.nix
index 6d82db4bac1a..e6d8a06a5193 100644
--- a/pkgs/applications/graphics/freepv/default.nix
+++ b/pkgs/applications/graphics/freepv/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, libjpeg, mesa, freeglut, zlib, cmake, libX11, libxml2, libpng,
-  libXxf86vm, gcc6 }:
+  libXxf86vm }:
 
 stdenv.mkDerivation {
   name = "freepv-0.3.0";
@@ -10,7 +10,7 @@ stdenv.mkDerivation {
   };
 
   buildInputs = [ libjpeg mesa freeglut zlib cmake libX11 libxml2 libpng
-    libXxf86vm gcc6 ];
+    libXxf86vm ];
 
   postPatch = ''
     sed -i -e '/GECKO/d' CMakeLists.txt