about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJens Binkert <jensbin+git@pm.me>2018-04-27 20:20:21 +0200
committerJens Binkert <jensbin+git@pm.me>2018-04-27 20:20:21 +0200
commit53722f25adeaf41c4af5d4b7ddab6f13cc0b435e (patch)
tree645a3b97938c8735bd8845c92a981ee3141f7620 /pkgs/applications
parent0963abfb41e48d60315e73223d390c1b4df3ff12 (diff)
downloadnixlib-53722f25adeaf41c4af5d4b7ddab6f13cc0b435e.tar
nixlib-53722f25adeaf41c4af5d4b7ddab6f13cc0b435e.tar.gz
nixlib-53722f25adeaf41c4af5d4b7ddab6f13cc0b435e.tar.bz2
nixlib-53722f25adeaf41c4af5d4b7ddab6f13cc0b435e.tar.lz
nixlib-53722f25adeaf41c4af5d4b7ddab6f13cc0b435e.tar.xz
nixlib-53722f25adeaf41c4af5d4b7ddab6f13cc0b435e.tar.zst
nixlib-53722f25adeaf41c4af5d4b7ddab6f13cc0b435e.zip
terraform-provider-ibm: init at 0.8.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/cluster/terraform-provider-ibm/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/applications/networking/cluster/terraform-provider-ibm/default.nix b/pkgs/applications/networking/cluster/terraform-provider-ibm/default.nix
new file mode 100644
index 000000000000..9764e029d277
--- /dev/null
+++ b/pkgs/applications/networking/cluster/terraform-provider-ibm/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, lib, buildGoPackage, fetchFromGitHub }:
+
+#
+# USAGE:
+# install the following package globally or in nix-shell:
+#
+#   (terraform.withPlugins ( plugins: [ terraform-provider-ibm ]))
+#
+# examples:
+# https://github.com/IBM-Cloud/terraform-provider-ibm/tree/master/examples
+#
+
+buildGoPackage rec {
+  name = "terraform-provider-ibm-${version}";
+  version = "0.8.0";
+
+  goPackagePath = "github.com/terraform-providers/terraform-provider-ibm";
+  subPackages = [ "./" ];
+
+  src = fetchFromGitHub {
+    owner = "IBM-Cloud";
+    repo = "terraform-provider-ibm";
+    sha256 = "1jc1g2jadh02z4lfqnvgqk5cqrzk8pnn3cj3cwsm3ksa8pccf6w4";
+    rev = "v${version}";
+  };
+
+  # Terraform allow checking the provider versions, but this breaks
+  # if the versions are not provided via file paths.
+  postBuild = "mv go/bin/terraform-provider-ibm{,_v${version}}";
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/IBM-Cloud/terraform-provider-ibm;
+    description = "Terraform provider is used to manage IBM Cloud resources.";
+    platforms = platforms.all;
+    license = licenses.mpl20;
+    maintainers = with maintainers; [ jensbin ];
+  };
+}