about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2020-06-11 10:43:37 +0100
committerJörg Thalheim <joerg@thalheim.io>2020-06-16 08:24:08 +0100
commit5360dec935e26d5b76eb53c42e4c45f6608f05e5 (patch)
treeb39ccc64b95cacd91aa360fbe1004e70ff2c1563 /pkgs/applications
parent4378ec4805ea6cb501d566692ddb3c5638d94b74 (diff)
downloadnixlib-5360dec935e26d5b76eb53c42e4c45f6608f05e5.tar
nixlib-5360dec935e26d5b76eb53c42e4c45f6608f05e5.tar.gz
nixlib-5360dec935e26d5b76eb53c42e4c45f6608f05e5.tar.bz2
nixlib-5360dec935e26d5b76eb53c42e4c45f6608f05e5.tar.lz
nixlib-5360dec935e26d5b76eb53c42e4c45f6608f05e5.tar.xz
nixlib-5360dec935e26d5b76eb53c42e4c45f6608f05e5.tar.zst
nixlib-5360dec935e26d5b76eb53c42e4c45f6608f05e5.zip
i3pystatus: fix desktop notifications
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/window-managers/i3/pystatus.nix34
1 files changed, 21 insertions, 13 deletions
diff --git a/pkgs/applications/window-managers/i3/pystatus.nix b/pkgs/applications/window-managers/i3/pystatus.nix
index 1a6d3d591e1d..beefdaf891c6 100644
--- a/pkgs/applications/window-managers/i3/pystatus.nix
+++ b/pkgs/applications/window-managers/i3/pystatus.nix
@@ -1,8 +1,13 @@
-{ stdenv, fetchFromGitHub, libpulseaudio, python3Packages, extraLibs ? [] }:
-
-let
-  ldWrapperSuffix = "--suffix LD_LIBRARY_PATH : \"${stdenv.lib.makeLibraryPath [ libpulseaudio ]}\"";
-in python3Packages.buildPythonApplication rec {
+{ stdenv
+, fetchFromGitHub
+, libpulseaudio
+, libnotify
+, gobject-introspection
+, python3Packages
+, wrapGAppsHook
+, extraLibs ? [] }:
+
+python3Packages.buildPythonApplication rec {
   # i3pystatus moved to rolling release:
   # https://github.com/enkore/i3pystatus/issues/584
   version = "unstable-2020-06-12";
@@ -15,23 +20,26 @@ in python3Packages.buildPythonApplication rec {
     sha256 = "18ygvkl92yr69kxsym57k1mc90asdxpz4b943i61qr0s4fc5n4mq";
   };
 
-  propagatedBuildInputs = with python3Packages; [ keyring colour netifaces psutil basiciw ] ++
-    [ libpulseaudio ] ++ extraLibs;
+  buildInputs = [ libpulseaudio libnotify gobject-introspection ];
+
+  propagatedBuildInputs = with python3Packages; [
+    keyring colour netifaces psutil basiciw pygobject3
+  ] ++ extraLibs;
 
-  # LC_TIME != C results in locale.Error: unsupported locale setting
   makeWrapperArgs = [
+    # LC_TIME != C results in locale.Error: unsupported locale setting
     "--set" "LC_TIME" "C"
-    ldWrapperSuffix
-  ]; # libpulseaudio.so is loaded manually
+    "--suffix" "LD_LIBRARY_PATH" ":" "${stdenv.lib.makeLibraryPath [ libpulseaudio ]}"
+  ];
 
-  postConfigure = ''
-    makeWrapperArgs+=("--set" "GI_TYPELIB_PATH" "$GI_TYPELIB_PATH")
+  postPatch = ''
+    makeWrapperArgs+=(--set GI_TYPELIB_PATH "$GI_TYPELIB_PATH")
   '';
 
   postInstall = ''
     makeWrapper ${python3Packages.python.interpreter} $out/bin/${pname}-python-interpreter \
       --prefix PYTHONPATH : "$PYTHONPATH" \
-      ${ldWrapperSuffix}
+      ''${makeWrapperArgs[@]}
   '';
 
   # no tests in tarball