about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJoe Hermaszewski <git@monoid.al>2017-07-05 13:02:20 +0100
committerJörg Thalheim <joerg@thalheim.io>2017-08-09 07:32:21 +0100
commit531a5b1afeb10ca4c347f2c7d8386e1187b456bf (patch)
tree26ec73a4c0baf186733726d9f257183068986873 /pkgs/applications
parent3bda92175a7d466facdad03869d33139cabbadd0 (diff)
downloadnixlib-531a5b1afeb10ca4c347f2c7d8386e1187b456bf.tar
nixlib-531a5b1afeb10ca4c347f2c7d8386e1187b456bf.tar.gz
nixlib-531a5b1afeb10ca4c347f2c7d8386e1187b456bf.tar.bz2
nixlib-531a5b1afeb10ca4c347f2c7d8386e1187b456bf.tar.lz
nixlib-531a5b1afeb10ca4c347f2c7d8386e1187b456bf.tar.xz
nixlib-531a5b1afeb10ca4c347f2c7d8386e1187b456bf.tar.zst
nixlib-531a5b1afeb10ca4c347f2c7d8386e1187b456bf.zip
git-fame: init at 2.5.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/git-and-tools/default.nix2
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-fame/Gemfile4
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-fame/Gemfile.lock26
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-fame/default.nix19
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-fame/gemset.nix60
5 files changed, 111 insertions, 0 deletions
diff --git a/pkgs/applications/version-management/git-and-tools/default.nix b/pkgs/applications/version-management/git-and-tools/default.nix
index 081bfd5918b8..82846a564cd9 100644
--- a/pkgs/applications/version-management/git-and-tools/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/default.nix
@@ -34,6 +34,8 @@ rec {
 
   git = appendToName "minimal" gitBase;
 
+  git-fame = callPackage ./git-fame {};
+
   # The full-featured Git.
   gitFull = gitBase.override {
     svnSupport = true;
diff --git a/pkgs/applications/version-management/git-and-tools/git-fame/Gemfile b/pkgs/applications/version-management/git-and-tools/git-fame/Gemfile
new file mode 100644
index 000000000000..17373f02b44d
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/git-fame/Gemfile
@@ -0,0 +1,4 @@
+source 'https://rubygems.org'
+
+# Specify your gem's dependencies in git_fame.gemspec
+gem "git_fame"
diff --git a/pkgs/applications/version-management/git-and-tools/git-fame/Gemfile.lock b/pkgs/applications/version-management/git-and-tools/git-fame/Gemfile.lock
new file mode 100644
index 000000000000..0ac7907fe55d
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/git-fame/Gemfile.lock
@@ -0,0 +1,26 @@
+GEM
+  remote: https://rubygems.org/
+  specs:
+    git_fame (2.5.2)
+      hirb (~> 0.7.3)
+      memoist (~> 0.14.0)
+      method_profiler (~> 2.0.1)
+      progressbar (~> 0.21.0)
+      scrub_rb (~> 1.0.1)
+      trollop (~> 2.1.2)
+    hirb (0.7.3)
+    memoist (0.14.0)
+    method_profiler (2.0.1)
+      hirb (>= 0.6.0)
+    progressbar (0.21.0)
+    scrub_rb (1.0.1)
+    trollop (2.1.2)
+
+PLATFORMS
+  ruby
+
+DEPENDENCIES
+  git_fame
+
+BUNDLED WITH
+   1.14.6
diff --git a/pkgs/applications/version-management/git-and-tools/git-fame/default.nix b/pkgs/applications/version-management/git-and-tools/git-fame/default.nix
new file mode 100644
index 000000000000..8b77efd1be23
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/git-fame/default.nix
@@ -0,0 +1,19 @@
+{ stdenv, bundlerEnv, ruby, fetchFromGitHub, makeWrapper, bundler }:
+
+bundlerEnv rec {
+  inherit ruby;
+
+  pname = "git_fame";
+
+  gemdir = ./.;
+
+  meta = with stdenv.lib; {
+    description = ''
+      A command-line tool that helps you summarize and pretty-print collaborators based on contributions
+      '';
+    homepage    = http://oleander.io/git-fame-rb;
+    license     = licenses.mit;
+    maintainers = with maintainers; [ expipiplus1 ];
+    platforms   = platforms.unix;
+  };
+}
diff --git a/pkgs/applications/version-management/git-and-tools/git-fame/gemset.nix b/pkgs/applications/version-management/git-and-tools/git-fame/gemset.nix
new file mode 100644
index 000000000000..49b4af4ef6d3
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/git-fame/gemset.nix
@@ -0,0 +1,60 @@
+{
+  git_fame = {
+    dependencies = ["hirb" "memoist" "method_profiler" "progressbar" "scrub_rb" "trollop"];
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "02k5ls5zyif8skdbnym6zw9y76whlnksw2m94jsh2n1ygk98izdd";
+      type = "gem";
+    };
+    version = "2.5.2";
+  };
+  hirb = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "0mzch3c2lvmf8gskgzlx6j53d10j42ir6ik2dkrl27sblhy76cji";
+      type = "gem";
+    };
+    version = "0.7.3";
+  };
+  memoist = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "03d3h6kp16bf0crqg1cxdgp1d2iyzn53d3phbmjh4pjybqls0gcm";
+      type = "gem";
+    };
+    version = "0.14.0";
+  };
+  method_profiler = {
+    dependencies = ["hirb"];
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "1ax04qrrv7fqp5ayxaxhn72660pybdkpkvmgiwbg7bs7x5ijjzd8";
+      type = "gem";
+    };
+    version = "2.0.1";
+  };
+  progressbar = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "17haw9c6c9q6imsn83pii32jnihpg76jgd09x7y4hjqq45n3qcdh";
+      type = "gem";
+    };
+    version = "0.21.0";
+  };
+  scrub_rb = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "0dwg33w83w17aiij9kcbi7irj7lh045nh9prjgkzjya3f1j60d3x";
+      type = "gem";
+    };
+    version = "1.0.1";
+  };
+  trollop = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "0415y63df86sqj43c0l82and65ia5h64if7n0znkbrmi6y0jwhl8";
+      type = "gem";
+    };
+    version = "2.1.2";
+  };
+}
\ No newline at end of file