about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2023-11-21 08:40:04 +0100
committerJörg Thalheim <Mic92@users.noreply.github.com>2023-12-01 15:59:25 +0100
commit4f403bc3aa0fb38a7e0bae8f22087d92a68d655e (patch)
tree05d7bd9e1ffb3f796d7bd12d0b6adcc499531884 /pkgs/applications
parent475653dc2fa7d8c40df5c86a994811f4d877d5e4 (diff)
downloadnixlib-4f403bc3aa0fb38a7e0bae8f22087d92a68d655e.tar
nixlib-4f403bc3aa0fb38a7e0bae8f22087d92a68d655e.tar.gz
nixlib-4f403bc3aa0fb38a7e0bae8f22087d92a68d655e.tar.bz2
nixlib-4f403bc3aa0fb38a7e0bae8f22087d92a68d655e.tar.lz
nixlib-4f403bc3aa0fb38a7e0bae8f22087d92a68d655e.tar.xz
nixlib-4f403bc3aa0fb38a7e0bae8f22087d92a68d655e.tar.zst
nixlib-4f403bc3aa0fb38a7e0bae8f22087d92a68d655e.zip
grantletheme: fix loading in kmail/kontact
This fixes a 5 year old bug (old enough to go to school) where kmail was
not able show emails (also appeared in kontact).

fixes https://github.com/NixOS/nixpkgs/issues/160599

The solution is not pretty but effective and involves
working around the broken search path of kde related libraries.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/kde/grantleetheme/default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkgs/applications/kde/grantleetheme/default.nix b/pkgs/applications/kde/grantleetheme/default.nix
index 2cc532d25104..14f4b26290c8 100644
--- a/pkgs/applications/kde/grantleetheme/default.nix
+++ b/pkgs/applications/kde/grantleetheme/default.nix
@@ -19,5 +19,12 @@ mkDerivation {
   postInstall = ''
     # added as an include directory by cmake files and fails to compile if it's missing
     mkdir -p "$dev/include/KF5"
+
+    # This is a really disgusting hack, no idea how search paths work for kde,
+    # but apparently kde is looking in $out/$out rather than $out for this library.
+    # Having this symlink fixes kmail finding it and makes my html work (Yay!).
+    mkdir -p $out/$out/lib/grantlee/
+    libpath=$(echo $out/lib/grantlee/*)
+    ln -s $libpath $out/$out/lib/grantlee/$(basename $libpath)
   '';
 }