about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2019-09-18 13:57:20 -0400
committerMatthew Bauer <mjbauer95@gmail.com>2019-09-18 13:57:20 -0400
commit4c85abae94b0a55ff76387c1f1793370a170dda8 (patch)
tree8bf2eac091b19a5b1ddc4b811ee4ed6523ad5870 /pkgs/applications
parent2c32f91bfc3d50175dd1f1eb87bf34626b7e8ab5 (diff)
downloadnixlib-4c85abae94b0a55ff76387c1f1793370a170dda8.tar
nixlib-4c85abae94b0a55ff76387c1f1793370a170dda8.tar.gz
nixlib-4c85abae94b0a55ff76387c1f1793370a170dda8.tar.bz2
nixlib-4c85abae94b0a55ff76387c1f1793370a170dda8.tar.lz
nixlib-4c85abae94b0a55ff76387c1f1793370a170dda8.tar.xz
nixlib-4c85abae94b0a55ff76387c1f1793370a170dda8.tar.zst
nixlib-4c85abae94b0a55ff76387c1f1793370a170dda8.zip
treewide: use libtinfo.so.5 where needed
This was originally added in

https://github.com/NixOS/nixpkgs/pull/21350

best to use this name for clarity.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/jetbrains/default.nix4
-rw-r--r--pkgs/applications/radio/tlf/default.nix8
-rw-r--r--pkgs/applications/science/logic/saw-tools/default.nix3
-rw-r--r--pkgs/applications/science/programming/fdr/default.nix7
4 files changed, 9 insertions, 13 deletions
diff --git a/pkgs/applications/editors/jetbrains/default.nix b/pkgs/applications/editors/jetbrains/default.nix
index a33b9531730f..a302be304e57 100644
--- a/pkgs/applications/editors/jetbrains/default.nix
+++ b/pkgs/applications/editors/jetbrains/default.nix
@@ -1,6 +1,6 @@
 { lib, stdenv, callPackage, fetchurl
 , python
-, jdk, cmake, libxml2, zlib, python3, ncurses
+, jdk, cmake, libxml2, zlib, python3, ncurses5
 }:
 
 with stdenv.lib;
@@ -34,7 +34,7 @@ let
 
           lldbLibPath=$out/clion-${version}/bin/lldb/linux/lib
           interp="$(cat $NIX_CC/nix-support/dynamic-linker)"
-          ln -s ${ncurses.out}/lib/libncurses.so $lldbLibPath/libtinfo.so.5
+          ln -s ${ncurses5.out}/lib/libtinfo.so.5 $lldbLibPath/libtinfo.so.5
 
           patchelf --set-interpreter $interp \
             --set-rpath "${lib.makeLibraryPath [ libxml2 zlib stdenv.cc.cc.lib ]}:$lldbLibPath" \
diff --git a/pkgs/applications/radio/tlf/default.nix b/pkgs/applications/radio/tlf/default.nix
index 92183306038b..f45e695486d8 100644
--- a/pkgs/applications/radio/tlf/default.nix
+++ b/pkgs/applications/radio/tlf/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub, autoreconfHook, autoconf, automake, pkgconfig, glib
-, perl, ncurses, hamlib, xmlrpc_c }:
+, perl, ncurses5, hamlib, xmlrpc_c }:
 
 stdenv.mkDerivation rec {
   pname = "tlf";
@@ -13,15 +13,13 @@ stdenv.mkDerivation rec {
   };
 
   nativeBuildInputs = [ autoreconfHook autoconf automake pkgconfig perl ];
-  buildInputs = [ glib ncurses hamlib xmlrpc_c ];
+  buildInputs = [ glib ncurses5 hamlib xmlrpc_c ];
 
   configureFlags = [ "--enable-hamlib" "--enable-fldigi-xmlrpc" ];
 
   postInstall = ''
     mkdir -p $out/lib
-
-    # Hack around lack of libtinfo in NixOS
-    ln -s ${ncurses.out}/lib/libncursesw.so.6 $out/lib/libtinfo.so.5
+    ln -s ${ncurses5.out}/lib/libtinfo.so.5 $out/lib/libtinfo.so.5
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/applications/science/logic/saw-tools/default.nix b/pkgs/applications/science/logic/saw-tools/default.nix
index d357bef2c7a0..c4041281054f 100644
--- a/pkgs/applications/science/logic/saw-tools/default.nix
+++ b/pkgs/applications/science/logic/saw-tools/default.nix
@@ -34,8 +34,7 @@ stdenv.mkDerivation {
     mv bin $out/bin
     mv doc $out/share
 
-    # Hack around lack of libtinfo in NixOS
-    ln -s ${ncurses.out}/lib/libncursesw.so.5       $out/lib/libtinfo.so.5
+    ln -s ${ncurses.out}/lib/libtinfo.so.5       $out/lib/libtinfo.so.5
     ln -s ${stdenv.cc.libc}/lib/libpthread.so.0 $out/lib/libpthread.so.0
 
     # Add a clang symlink for easy building with a suitable compiler.
diff --git a/pkgs/applications/science/programming/fdr/default.nix b/pkgs/applications/science/programming/fdr/default.nix
index 3bfb70f5ce8e..2c0bb84c801f 100644
--- a/pkgs/applications/science/programming/fdr/default.nix
+++ b/pkgs/applications/science/programming/fdr/default.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl, qtbase, qtx11extras, ncurses, xorg, zlib, python27Packages}:
+{stdenv, fetchurl, qtbase, qtx11extras, ncurses5, xorg, zlib, python27Packages}:
 stdenv.mkDerivation {
   name = "fdr-4.2.3";
   src = fetchurl {
@@ -11,7 +11,7 @@ stdenv.mkDerivation {
     python27Packages.python
     qtbase
     qtx11extras
-    ncurses
+    ncurses5
     xorg.libX11
     xorg.libXft
     zlib
@@ -26,8 +26,7 @@ stdenv.mkDerivation {
     rm -r lib/qt_plugins
 
     cp -r * "$out"
-    # Hack around lack of libtinfo in NixOS
-    ln -s ${ncurses.out}/lib/libncursesw.so.6 $out/lib/libtinfo.so.5
+    ln -s ${ncurses5.out}/lib/libtinfo.so.5 $out/lib/libtinfo.so.5
     ln -s ${qtbase.bin}/${qtbase.qtPluginPrefix} $out/lib/qt_plugins
     ln -s ${zlib.out}/lib/libz.so.1 $out/lib/libz.so.1