about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorThiago Kenji Okada <thiagokokada@gmail.com>2023-09-27 22:49:35 +0100
committerGitHub <noreply@github.com>2023-09-27 22:49:35 +0100
commit4ab8a3de296914f3b631121e9ce3884f1d34e1e5 (patch)
tree8947fed6cde9ff40f328244481bac284c300adc9 /pkgs/applications
parent95e66809debf42dbe1e4935fd31c8c275914d2eb (diff)
parentc9fc96a159d9fc039cb848b1f247c5c41859473d (diff)
downloadnixlib-4ab8a3de296914f3b631121e9ce3884f1d34e1e5.tar
nixlib-4ab8a3de296914f3b631121e9ce3884f1d34e1e5.tar.gz
nixlib-4ab8a3de296914f3b631121e9ce3884f1d34e1e5.tar.bz2
nixlib-4ab8a3de296914f3b631121e9ce3884f1d34e1e5.tar.lz
nixlib-4ab8a3de296914f3b631121e9ce3884f1d34e1e5.tar.xz
nixlib-4ab8a3de296914f3b631121e9ce3884f1d34e1e5.tar.zst
nixlib-4ab8a3de296914f3b631121e9ce3884f1d34e1e5.zip
Merge pull request #257342 from thiagokokada/retroarch-cleanup
beetle-pce: init at unstable-2023-09-24; libretro.mame: fix build
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/emulators/retroarch/cores.nix26
-rw-r--r--pkgs/applications/emulators/retroarch/hashes.json6
-rwxr-xr-xpkgs/applications/emulators/retroarch/update_cores.py1
3 files changed, 25 insertions, 8 deletions
diff --git a/pkgs/applications/emulators/retroarch/cores.nix b/pkgs/applications/emulators/retroarch/cores.nix
index 216d9c14df20..d67ae6b5318e 100644
--- a/pkgs/applications/emulators/retroarch/cores.nix
+++ b/pkgs/applications/emulators/retroarch/cores.nix
@@ -100,12 +100,22 @@ in
     };
   };
 
+  beetle-pce = mkLibretroCore {
+    core = "mednafen-pce";
+    src = getCoreSrc "beetle-pce";
+    makefile = "Makefile";
+    meta = {
+      description = "Port of Mednafen's PC Engine core to libretro";
+      license = lib.licenses.gpl2Only;
+    };
+  };
+
   beetle-pce-fast = mkLibretroCore {
     core = "mednafen-pce-fast";
     src = getCoreSrc "beetle-pce-fast";
     makefile = "Makefile";
     meta = {
-      description = "Port of Mednafen's PC Engine core to libretro";
+      description = "Port of Mednafen's PC Engine fast core to libretro";
       license = lib.licenses.gpl2Only;
     };
   };
@@ -291,7 +301,11 @@ in
     core = "citra";
     extraBuildInputs = [ libGLU libGL boost ffmpeg nasm ];
     makefile = "Makefile";
-    makeFlags = [ "HAVE_FFMPEG_STATIC=0" ];
+    makeFlags = [
+      "HAVE_FFMPEG_STATIC=0"
+      # https://github.com/libretro/citra/blob/1a66174355b5ed948de48ef13c0ed508b6d6169f/Makefile#L90
+      "BUILD_DATE=01/01/1970_00:00"
+    ];
     meta = {
       description = "Port of Citra to libretro";
       license = lib.licenses.gpl2Plus;
@@ -506,15 +520,11 @@ in
     core = "mame";
     extraNativeBuildInputs = [ python3 ];
     extraBuildInputs = [ alsa-lib libGLU libGL ];
+    # Setting this is breaking compilation of src/3rdparty/genie for some reason
+    makeFlags = [ "ARCH=" ];
     meta = {
       description = "Port of MAME to libretro";
       license = with lib.licenses; [ bsd3 gpl2Plus ];
-      # Build fail with errors:
-      # gcc: warning: <arch>: linker input file unused because linking not done
-      # gcc: error: <arch>: linker input file not found: No such file or directory
-      # Removing it from platforms instead of marking as broken to allow
-      # retroarchFull to be built
-      platforms = [ ];
     };
   };
 
diff --git a/pkgs/applications/emulators/retroarch/hashes.json b/pkgs/applications/emulators/retroarch/hashes.json
index 0ee7ff4d7931..f1099967fe78 100644
--- a/pkgs/applications/emulators/retroarch/hashes.json
+++ b/pkgs/applications/emulators/retroarch/hashes.json
@@ -29,6 +29,12 @@
         "rev": "65460e3a9ad529f6901caf669abbda11f437ab55",
         "hash": "sha256-+xfD1ZMKtbv5Lp12+5RM7Vl3eEF38kykKW8wj/2EN5w="
     },
+    "beetle-pce": {
+        "owner": "libretro",
+        "repo": "beetle-pce-libretro",
+        "rev": "541463bd937dad175aec09c2a0c8d6a52d175386",
+        "hash": "sha256-wWS9reb6aN71Q7OlGst+32T8XX1yMCSOHUKHkXht3hg="
+    },
     "beetle-pce-fast": {
         "owner": "libretro",
         "repo": "beetle-pce-fast-libretro",
diff --git a/pkgs/applications/emulators/retroarch/update_cores.py b/pkgs/applications/emulators/retroarch/update_cores.py
index 8e45b7f4fdf3..5348092c5247 100755
--- a/pkgs/applications/emulators/retroarch/update_cores.py
+++ b/pkgs/applications/emulators/retroarch/update_cores.py
@@ -17,6 +17,7 @@ CORES = {
     "beetle-gba": {"repo": "beetle-gba-libretro"},
     "beetle-lynx": {"repo": "beetle-lynx-libretro"},
     "beetle-ngp": {"repo": "beetle-ngp-libretro"},
+    "beetle-pce": {"repo": "beetle-pce-libretro"},
     "beetle-pce-fast": {"repo": "beetle-pce-fast-libretro"},
     "beetle-pcfx": {"repo": "beetle-pcfx-libretro"},
     "beetle-psx": {"repo": "beetle-psx-libretro"},