about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-01-18 15:53:12 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-01-18 15:53:12 +0000
commit48ee2523dad1cb9cb586ac65557f60c6ec821031 (patch)
treef28a81f3363e2533b3cc00ffc79260893884ce5a /pkgs/applications
parentc7a1f309a7cc7b8b42138e52ae6172631d465b51 (diff)
parent87441a72be54bb21a4319d44bfd7543f900a3e0e (diff)
downloadnixlib-48ee2523dad1cb9cb586ac65557f60c6ec821031.tar
nixlib-48ee2523dad1cb9cb586ac65557f60c6ec821031.tar.gz
nixlib-48ee2523dad1cb9cb586ac65557f60c6ec821031.tar.bz2
nixlib-48ee2523dad1cb9cb586ac65557f60c6ec821031.tar.lz
nixlib-48ee2523dad1cb9cb586ac65557f60c6ec821031.tar.xz
nixlib-48ee2523dad1cb9cb586ac65557f60c6ec821031.tar.zst
nixlib-48ee2523dad1cb9cb586ac65557f60c6ec821031.zip
* Sync with the trunk.
svn path=/nixpkgs/branches/stdenv-updates/; revision=31633
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/jedit/default.nix53
-rw-r--r--pkgs/applications/networking/instant-messengers/vacuum/default.nix16
-rw-r--r--pkgs/applications/networking/mailreaders/thunderbird/9.x.nix115
-rw-r--r--pkgs/applications/networking/remote/freerdp/default.nix14
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-annex/default.nix6
-rw-r--r--pkgs/applications/version-management/gource/default.nix35
6 files changed, 209 insertions, 30 deletions
diff --git a/pkgs/applications/editors/jedit/default.nix b/pkgs/applications/editors/jedit/default.nix
index f49919b70bb4..5349f10c0c36 100644
--- a/pkgs/applications/editors/jedit/default.nix
+++ b/pkgs/applications/editors/jedit/default.nix
@@ -1,28 +1,53 @@
-{ stdenv, fetchurl, ant }:
+{ stdenv, fetchurl, ant, jre }:
 
 stdenv.mkDerivation {
-  name = "jedit-4.2";
+  name = "jedit-4.4.2";
 
   src = fetchurl {
-    url = mirror://sf/jedit/jedit42source.tar.gz;
-    sha256 = "1ckqghsw2r30kfkqfgjl4k47gdwpz8c1h85haw0y0ymq4rqh798j";
+    url = mirror://sf/jedit/jedit4.4.2source.tar.bz2;
+    sha256 = "5e9ad9c32871b77ef0b9fe46dcfcea57ec52558d36113b7280194a33430b8ceb";
   };
 
-  phases = "unpackPhase buildPhase";
+  setSourceRoot = ''
+    sourceRoot=jEdit
+  '';
 
-  buildPhase = "
-     sed -i 's/\\<SplashScreen\\>/org.gjt.sp.jedit.gui.SplashScreen/g' org/gjt/sp/jedit/GUIUtilities.java
-    ant dist
-    ensureDir $out/lib
-    cp jedit.jar $out/lib
-    ensureDir \$out/lib/modes
-    cp modes/catalog \$out/lib/modes
-  ";
+  buildPhase = ''
+     ant build
+  '';
+
+  installPhase = ''
+    ensureDir $out/share/jEdit
+    cp build/jedit.jar $out/share/jEdit
+    ensureDir $out/share/jEdit/modes
+    cp -r modes/* $out/share/jEdit/modes
+    ensureDir $out/share/jEdit/icons
+    cp -r icons/* $out/share/jEdit/icons
+    ensureDir $out/share/jEdit/macros
+    cp -r macros/* $out/share/jEdit/macros
+    ensureDir $out/share/jEdit/doc
+    cp -r doc/* $out/share/jEdit/doc
+    
+    sed -i "s|Icon=.*|Icon=$out/share/jEdit/icons/jedit-icon48.png|g" package-files/linux/deb/jedit.desktop
+    ensureDir $out/share/applications
+    mv package-files/linux/deb/jedit.desktop $out/share/applications/jedit.desktop
+
+    patch package-files/linux/jedit << EOF
+    5a6,8
+    > # specify the correct JAVA_HOME
+    > JAVA_HOME=${jre}
+    > 
+    EOF
+    sed -i "s|/usr/share/jEdit/@jar.filename@|$out/share/jEdit/jedit.jar|g" package-files/linux/jedit
+    ensureDir $out/bin
+    cp package-files/linux/jedit $out/bin/jedit
+    chmod +x $out/bin/jedit
+  '';
 
   buildInputs = [ ant ];
 
   meta = { 
-    description = "really nice programmers editor written in Java. Give it a try";
+    description = "Mature programmer's text editor (Java based)";
     homepage = http://www.jedit.org;
     license = "GPL";
   };
diff --git a/pkgs/applications/networking/instant-messengers/vacuum/default.nix b/pkgs/applications/networking/instant-messengers/vacuum/default.nix
index 6b8b7a9419d5..bddedce7183d 100644
--- a/pkgs/applications/networking/instant-messengers/vacuum/default.nix
+++ b/pkgs/applications/networking/instant-messengers/vacuum/default.nix
@@ -12,11 +12,11 @@ let
   buildInputs = map (n: builtins.getAttr n x)
     (builtins.attrNames (builtins.removeAttrs x helperArgNames));
   sourceInfo = rec {
-    version="1.1.1";
+    version="1.1.2";
     baseName="vacuum-im";
     name="${baseName}-${version}";
-    url="http://vacuum-im.googlecode.com/files/${name}.tar.xz";
-    hash="b4b3472bf83173f6be1bbe69520bf6cab97e24cf9fd8a7b60e4ffdc1cb43b1dc";
+    url="http://vacuum-im.googlecode.com/files/vacuum-${version}.tar.xz";
+    hash="451dde9b3587503b035fa1ddd2c99f2052a0b17a603491c59e8c47a8bcd4746d";
   };
 in
 rec {
@@ -29,12 +29,7 @@ rec {
   inherit buildInputs;
 
   /* doConfigure should be removed if not needed */
-  phaseNames = ["addInputs" "preBuild" "doQMake" "doMakeInstall"];
-
-  preBuild = a.fullDepEntry (''
-    echo "Fixing a name collision with a function added in Qt 4.7"
-    sed -re 's/qHash[(][a-z ]*QUrl/vacuum_obsolete_&/' -i src/plugins/dataforms/dataforms.cpp
-  '') ["minInit" "doUnpack"];
+  phaseNames = ["addInputs" "doQMake" "doMakeInstall"];
 
   doQMake = a.fullDepEntry (''
     qmake INSTALL_PREFIX=$out -recursive vacuum.pro
@@ -48,6 +43,9 @@ rec {
     ];
     platforms = with a.lib.platforms;
       linux;
+    license = with a.lib.licenses;
+      gpl3;
+    homepage = "http://code.google.com/p/vacuum-im/";
   };
   passthru = {
     updateInfo = {
diff --git a/pkgs/applications/networking/mailreaders/thunderbird/9.x.nix b/pkgs/applications/networking/mailreaders/thunderbird/9.x.nix
new file mode 100644
index 000000000000..62b4d91de587
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/thunderbird/9.x.nix
@@ -0,0 +1,115 @@
+{ stdenv, fetchurl, pkgconfig, gtk, perl, python, zip, unzip
+, libIDL, dbus_glib, bzip2, alsaLib, nspr, yasm, mesa, nss
+, libnotify, cairo, pixman, fontconfig
+, libjpeg
+
+, # If you want the resulting program to call itself "Thunderbird"
+  # instead of "Shredder", enable this option.  However, those
+  # binaries may not be distributed without permission from the
+  # Mozilla Foundation, see
+  # http://www.mozilla.org/foundation/trademarks/.
+  enableOfficialBranding ? false
+
+}:
+
+let version = "9.0.1";
+
+    # This patch may become necessary when we use a more recent version of libpng
+    # for now, it's actually not needed
+    # pngPatch = fetchurl {
+    #   url = http://www.linuxfromscratch.org/patches/blfs/svn/thunderbird-9.0.1-libpng-1.5-1.patch;
+    #   sha256 = "8454bdde3be8dc37c9f5e6f597914f0a585ff4b357d3fc86c6c9f80208b6068d";
+    # };
+in
+
+stdenv.mkDerivation {
+  name = "thunderbird-${version}";
+
+  src = fetchurl {
+    url = "http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${version}/source/thunderbird-${version}.source.tar.bz2";
+    sha256 = "4fc392915e22b81ef0bd08e6e2d8d0348e66f0930f35bf8ac47eb49f64453e2d";
+  };
+
+  enableParallelBuilding = true;
+
+  buildInputs =
+    [ pkgconfig perl python zip unzip bzip2 gtk dbus_glib alsaLib libIDL nspr
+      libnotify cairo pixman fontconfig yasm mesa /* nss */
+      libjpeg
+    ];
+
+  # fix some paths in pngPatch
+  # prePatch = ''
+  #   substitute ${pngPatch} png.patch --replace "mozilla-release/modules/" "comm-release/mozilla/modules/"
+  #   '';
+
+  patches = [
+    # "png.patch" # produced by postUnpack
+
+    # Fix weird dependencies such as a so file which depends on "-lpthread".
+    # ./thunderbird-build-deps.patch
+  ];
+
+  configureFlags =
+    [ "--enable-application=mail"
+      "--enable-optimize"
+      "--with-pthreads"
+      "--disable-debug"
+      "--enable-strip"
+      "--with-pthreads"
+      "--with-system-jpeg"
+      # "--with-system-png"  # png 1.5.x not merged in nixpkgs yet
+      "--with-system-zlib"
+      "--with-system-bz2"
+      "--with-system-nspr"
+      "--enable-system-cairo"
+      "--disable-crashreporter"
+      "--disable-necko-wifi"
+      "--disable-webm"
+      "--disable-tests"
+      "--enable-calendar"
+    ]
+    ++ stdenv.lib.optional enableOfficialBranding "--enable-official-branding";
+
+  # The Thunderbird Makefiles refer to the variables LIBXUL_DIST,
+  # prefix, and PREFIX in some places where they are not set.  In
+  # particular, there are some linker flags like
+  # `-rpath-link=$(LIBXUL_DIST)/bin'.  Since this expands to
+  # `-rpath-link=/bin', the build fails due to the purity checks in
+  # the ld wrapper.  So disable the purity check for now.
+  preBuild = "NIX_ENFORCE_PURITY=0";
+
+  # This doesn't work:
+  #makeFlags = "LIBXUL_DIST=$(out) prefix=$(out) PREFIX=$(out)";
+
+  postInstall =
+    ''
+      # Fix some references to /bin paths in the Xulrunner shell script.
+      substituteInPlace $out/lib/thunderbird-*/thunderbird \
+          --replace /bin/pwd "$(type -tP pwd)" \
+          --replace /bin/ls "$(type -tP ls)"
+
+      # Create a desktop item.
+      ensureDir $out/share/applications
+      cat > $out/share/applications/thunderbird.desktop <<EOF
+      [Desktop Entry]
+      Type=Application
+      Exec=$out/bin/thunderbird
+      Icon=$out/lib/thunderbird-${version}/chrome/icons/default/default256.png
+      Name=Thunderbird
+      GenericName=Mail Reader
+      Categories=Application;Network;
+      EOF
+    '';
+
+  meta = with stdenv.lib; {
+    description = "Mozilla Thunderbird, a full-featured email client";
+    homepage = http://www.mozilla.org/thunderbird/;
+    license =
+      # Official branding implies thunderbird name and logo cannot be reuse,
+      # see http://www.mozilla.org/foundation/licensing.html
+      if enableOfficialBranding then licenses.proprietary else licenses.mpl11;
+    maintainers = with maintainers; [ pierron ];
+    platforms = with platforms; linux;
+  };
+}
diff --git a/pkgs/applications/networking/remote/freerdp/default.nix b/pkgs/applications/networking/remote/freerdp/default.nix
index 8d80630f316d..3aeeb8dd0ee0 100644
--- a/pkgs/applications/networking/remote/freerdp/default.nix
+++ b/pkgs/applications/networking/remote/freerdp/default.nix
@@ -1,29 +1,36 @@
 { stdenv
 , fetchurl
+, cmake
 , openssl
 , printerSupport ? true, cups
 , pkgconfig
 , zlib
 , libX11
 , libXcursor
+, libXdamage
+, libXext
 , alsaLib
 }:
 
 assert printerSupport -> cups != null;
 stdenv.mkDerivation rec {
-  name = "freerdp-0.8.2";
+  name = "freerdp-${version}";
+  version = "1.0.0";
 
   src = fetchurl {
-    url = "mirror://sourceforge/freerdp/${name}.tar.gz";
-    sha256 = "1q9hhwyc4hk49hsmd2kghrfsawxcc7gy7vcmhdf91l8v95xp16iq";
+    url = "https://github.com/downloads/FreeRDP/FreeRDP/FreeRDP-${version}.tar.gz";
+    sha256 = "1h7b2ykgsp1b04p67syb3p2xgpsb45i6zl1jvm09h0dr5an85awd";
   };
 
   buildInputs = [
+    cmake
     openssl
     pkgconfig
     zlib
     libX11
     libXcursor
+    libXdamage
+    libXext
     alsaLib
   ] ++ stdenv.lib.optional printerSupport cups;
 
@@ -46,4 +53,3 @@ stdenv.mkDerivation rec {
     maintainers = [ stdenv.lib.maintainers.shlevy ];
   };
 }
-
diff --git a/pkgs/applications/version-management/git-and-tools/git-annex/default.nix b/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
index 32b30bc32420..870c80f6020d 100644
--- a/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
@@ -4,14 +4,14 @@
 }:
 
 let
-  version = "3.20120106";
+  version = "3.20120113";
 in
 stdenv.mkDerivation {
   name = "git-annex-${version}";
 
   src = fetchurl {
     url = "http://ftp.de.debian.org/debian/pool/main/g/git-annex/git-annex_${version}.tar.gz";
-    sha256 = "60735d8b036aa8ac44e1838724d9b4da1fceb2f1547ce7f39b2069a8c3605438";
+    sha256 = "060s96d5a6vx5alwkfgzsvwx1k9m81l6hbx4rnak9iy5iy28zd0z";
   };
 
   buildInputs = [
@@ -32,7 +32,7 @@ stdenv.mkDerivation {
   meta = {
     homepage = "http://git-annex.branchable.com/";
     description = "Manage files with git without checking them into git";
-    license = "GPLv3+";
+    license = stdenv.lib.licenses.gpl3Plus;
 
     longDescription = ''
       Git-annex allows managing files with git, without checking the
diff --git a/pkgs/applications/version-management/gource/default.nix b/pkgs/applications/version-management/gource/default.nix
new file mode 100644
index 000000000000..886ed9a71999
--- /dev/null
+++ b/pkgs/applications/version-management/gource/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, fetchurl, SDL, ftgl, pkgconfig, libpng, libjpeg, pcre, SDL_image, glew, mesa }:
+
+let
+  name = "gource-0.37";
+in
+stdenv.mkDerivation {
+  inherit name;
+
+  src = fetchurl {
+    url = "http://gource.googlecode.com/files/${name}.tar.gz";
+    sha256 = "03kd9nn65cl1p2jgn6pvpxmvnfscz3c8jqds90fsc0z37ij2iiyn";
+  };
+
+  buildInputs = [glew SDL ftgl pkgconfig libpng libjpeg pcre SDL_image mesa];
+
+  meta = {
+    homepage = "http://code.google.com/p/gource/";
+    description = "software version control visualization tool";
+    license = stdenv.lib.licenses.gpl3Plus;
+
+    longDescription = ''
+      Software projects are displayed by Gource as an animated tree with
+      the root directory of the project at its centre. Directories
+      appear as branches with files as leaves. Developers can be seen
+      working on the tree at the times they contributed to the project.
+
+      Currently Gource includes built-in log generation support for Git,
+      Mercurial and Bazaar and SVN. Gource can also parse logs produced
+      by several third party tools for CVS repositories.
+    '';
+
+    platforms = stdenv.lib.platforms.gnu;
+    maintainers = [ stdenv.lib.maintainers.simons ];
+  };
+}