about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2023-08-05 09:42:45 -0500
committerGitHub <noreply@github.com>2023-08-05 09:42:45 -0500
commit475b64282152b9700fe2fbde44ba87143aa8d1f9 (patch)
tree5fbb7f724ce0bfe55443dbb4e02a890401150916 /pkgs/applications
parentfd11bfcb19c887b9d1a410e40319f3dd12a166f1 (diff)
parent0494e7c9abac71beca39a8a48528bfee432f29a0 (diff)
downloadnixlib-475b64282152b9700fe2fbde44ba87143aa8d1f9.tar
nixlib-475b64282152b9700fe2fbde44ba87143aa8d1f9.tar.gz
nixlib-475b64282152b9700fe2fbde44ba87143aa8d1f9.tar.bz2
nixlib-475b64282152b9700fe2fbde44ba87143aa8d1f9.tar.lz
nixlib-475b64282152b9700fe2fbde44ba87143aa8d1f9.tar.xz
nixlib-475b64282152b9700fe2fbde44ba87143aa8d1f9.tar.zst
nixlib-475b64282152b9700fe2fbde44ba87143aa8d1f9.zip
Merge pull request #246979 from tjni/gitoxide
gitoxide: 0.27.0 -> 0.28.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/gitoxide/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/pkgs/applications/version-management/gitoxide/default.nix b/pkgs/applications/version-management/gitoxide/default.nix
index bf04b2424f05..3863962fc51d 100644
--- a/pkgs/applications/version-management/gitoxide/default.nix
+++ b/pkgs/applications/version-management/gitoxide/default.nix
@@ -13,24 +13,25 @@
 
 rustPlatform.buildRustPackage rec {
   pname = "gitoxide";
-  version = "0.27.0";
+  version = "0.28.0";
 
   src = fetchFromGitHub {
     owner = "Byron";
     repo = "gitoxide";
     rev = "v${version}";
-    sha256 = "sha256-L5x27rJ9Y3K886OlTvCXV2LY+6L/f6vokCbgrWPCiHY=";
+    hash = "sha256-7iJx7kE606jeaokROmOSoh0egCQUgYwvg8BAA3y1BGs=";
   };
 
-  cargoHash = "sha256-YEHHu9PJ5aJvWUaTXCNKEaV/Rd8lP6Wub/CFJCBykHU=";
+  cargoHash = "sha256-zChqIA/KuS1aBs/g1tlymGvvJeljKMMCODijPhQYy40=";
 
   nativeBuildInputs = [ cmake pkg-config ];
+
   buildInputs = [ curl ] ++ (if stdenv.isDarwin
     then [ libiconv Security SystemConfiguration ]
     else [ openssl ]);
 
   # Needed to get openssl-sys to use pkg-config.
-  OPENSSL_NO_VENDOR = 1;
+  env.OPENSSL_NO_VENDOR = 1;
 
   meta = with lib; {
     description = "A command-line application for interacting with git repositories";