about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJustin Humm <justin.humm@posteo.de>2019-09-20 19:01:13 +0000
committerJustin Humm <justin.humm@posteo.de>2020-05-05 14:48:56 +0200
commit4752e21de0c607034e16994691581327d40f2d34 (patch)
tree5aef7bbfc1228cbf70dc41f9be069f8bb15fa279 /pkgs/applications
parentbc6bad222e6d52491a2c4c8c95c598bf73e7949e (diff)
downloadnixlib-4752e21de0c607034e16994691581327d40f2d34.tar
nixlib-4752e21de0c607034e16994691581327d40f2d34.tar.gz
nixlib-4752e21de0c607034e16994691581327d40f2d34.tar.bz2
nixlib-4752e21de0c607034e16994691581327d40f2d34.tar.lz
nixlib-4752e21de0c607034e16994691581327d40f2d34.tar.xz
nixlib-4752e21de0c607034e16994691581327d40f2d34.tar.zst
nixlib-4752e21de0c607034e16994691581327d40f2d34.zip
meli: init at alpha-0.5.1
Co-authored-by: 0x4A6F <0x4A6F@users.noreply.github.com>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/mailreaders/meli/default.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/pkgs/applications/networking/mailreaders/meli/default.nix b/pkgs/applications/networking/mailreaders/meli/default.nix
new file mode 100644
index 000000000000..719965455f9c
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/meli/default.nix
@@ -0,0 +1,50 @@
+{ stdenv
+, lib
+, fetchgit
+, rustPlatform
+, pkgconfig
+, openssl
+, dbus
+, sqlite
+, file
+, gzip
+, notmuch
+  # Build with support for notmuch backend
+, withNotmuch ? true
+}:
+
+rustPlatform.buildRustPackage rec {
+  pname = "meli";
+  version = "alpha-0.5.1";
+
+  src = fetchgit {
+    url = "https://git.meli.delivery/meli/meli.git";
+    rev = version;
+    sha256 = "1y5567hdm1s2s272drxvmp6x4y1jpyl7423iz58hgqcsjm9085zv";
+  };
+
+  cargoSha256 = "040dfr09bg5z5pn68dy323hcppd599d3f6k7zxqw5f8n4whnlc9y";
+
+  cargoBuildFlags = lib.optional withNotmuch "--features=notmuch";
+
+  nativeBuildInputs = [ pkgconfig gzip ];
+
+  buildInputs = [ openssl dbus sqlite ] ++ lib.optional withNotmuch notmuch;
+
+  checkInputs = [ file ];
+
+  postInstall = ''
+    mkdir -p $out/share/man/man1
+    gzip < meli.1 > $out/share/man/man1/meli.1.gz
+    mkdir -p $out/share/man/man5
+    gzip < meli.conf.5 > $out/share/man/man5/meli.conf.5.gz
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Experimental terminal mail client aiming for configurability and extensibility with sane defaults";
+    homepage = "https://meli.delivery";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ maintainers."0x4A6F" matthiasbeyer erictapen ];
+    platforms = platforms.linux;
+  };
+}