about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2016-02-21 16:31:42 +0100
committerFranz Pletz <fpletz@fnordicwalking.de>2016-02-21 16:31:42 +0100
commit45c97925ddb7bf24c8bf2a6c0043a6c7d985e4f4 (patch)
treed782beb8d610d0f712507c62afb970484247e280 /pkgs/applications
parentbc1e1c56985811d5f64032c78305b8e5492b4e8c (diff)
parent4046d3ce8dbecb74fc9da8f03d7fcd651ca94f35 (diff)
downloadnixlib-45c97925ddb7bf24c8bf2a6c0043a6c7d985e4f4.tar
nixlib-45c97925ddb7bf24c8bf2a6c0043a6c7d985e4f4.tar.gz
nixlib-45c97925ddb7bf24c8bf2a6c0043a6c7d985e4f4.tar.bz2
nixlib-45c97925ddb7bf24c8bf2a6c0043a6c7d985e4f4.tar.lz
nixlib-45c97925ddb7bf24c8bf2a6c0043a6c7d985e4f4.tar.xz
nixlib-45c97925ddb7bf24c8bf2a6c0043a6c7d985e4f4.tar.zst
nixlib-45c97925ddb7bf24c8bf2a6c0043a6c7d985e4f4.zip
Merge pull request #13122 from adevress/neuron
Add new package neuron. Neuron network simulation framework
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/biology/neuron/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/applications/science/biology/neuron/default.nix b/pkgs/applications/science/biology/neuron/default.nix
new file mode 100644
index 000000000000..33f6d50d8ad8
--- /dev/null
+++ b/pkgs/applications/science/biology/neuron/default.nix
@@ -0,0 +1,38 @@
+{ stdenv 
+, fetchurl 
+, pkgconfig 
+, ncurses 
+, mpi ? null
+}:
+
+stdenv.mkDerivation rec {
+  name = "neuron-7.4";
+  buildInputs = [ stdenv pkgconfig ncurses mpi ];
+
+  src = fetchurl {
+    url = "http://www.neuron.yale.edu/ftp/neuron/versions/v7.4/nrn-7.4.tar.gz";
+    sha256 = "1rid8cmv5mca0vqkgwahm0prkwkbdvchgw2bdwvx4adkn8bbl0ql";
+  };
+
+
+  enableParallelBuilding = true;
+
+  configureFlags = [ "--without-x"
+		     "${if mpi != null then "--with-mpi" else "--without-mpi"}" ];
+
+  meta = with stdenv.lib; {
+    description = "Simulation environment for empirically-based simulations of neurons and networks of neurons";
+
+    longDescription = "NEURON is a simulation environment for developing and exercising models of 
+		neurons and networks of neurons. It is particularly well-suited to problems where 
+		cable properties of cells play an important role, possibly including extracellular 
+		potential close to the membrane), and where cell membrane properties are complex, 
+		involving many ion-specific channels, ion accumulation, and second messengers";
+
+    license     = licenses.bsd3;
+    homepage    = http://www.neuron.yale.edu/neuron;
+    maintainers = [ maintainers.adev ];
+    platforms   = platforms.all;
+  };  
+}
+