about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2018-02-20 20:31:39 +0100
committerVladimír Čunát <vcunat@gmail.com>2018-02-20 20:31:39 +0100
commit43a88e3d8a68a008abea0bca0b17805aa4910764 (patch)
treedfedec7c941b61fdd748bdf9806344d24c5f29f2 /pkgs/applications
parenta34b0274ef111f02299c7b3435b4502eeb4deb3e (diff)
parentfbe38c7c442e21b9eaa9a145c0e2bfe134f7f367 (diff)
downloadnixlib-43a88e3d8a68a008abea0bca0b17805aa4910764.tar
nixlib-43a88e3d8a68a008abea0bca0b17805aa4910764.tar.gz
nixlib-43a88e3d8a68a008abea0bca0b17805aa4910764.tar.bz2
nixlib-43a88e3d8a68a008abea0bca0b17805aa4910764.tar.lz
nixlib-43a88e3d8a68a008abea0bca0b17805aa4910764.tar.xz
nixlib-43a88e3d8a68a008abea0bca0b17805aa4910764.tar.zst
nixlib-43a88e3d8a68a008abea0bca0b17805aa4910764.zip
Merge branch 'gcc-7' into staging
Close #27794.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/leo-editor/default.nix21
-rw-r--r--pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix4
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/default.nix4
-rw-r--r--pkgs/applications/virtualization/qemu/statfs-flags.patch31
4 files changed, 33 insertions, 27 deletions
diff --git a/pkgs/applications/editors/leo-editor/default.nix b/pkgs/applications/editors/leo-editor/default.nix
index b05bbd053c1f..2084a047a086 100644
--- a/pkgs/applications/editors/leo-editor/default.nix
+++ b/pkgs/applications/editors/leo-editor/default.nix
@@ -1,20 +1,29 @@
-{ stdenv, python3Packages, fetchFromGitHub, makeWrapper, makeDesktopItem }:
+{ stdenv, python3, libsForQt56, fetchFromGitHub, makeWrapper, makeDesktopItem }:
 
+let
+  packageOverrides = self: super: {
+    pyqt56 = libsForQt56.callPackage ../../../development/python-modules/pyqt/5.x.nix {
+      pythonPackages = self;
+    };
+  };
+
+  pythonPackages = (python3.override { inherit packageOverrides; }).pkgs;
+in
 stdenv.mkDerivation rec {
   name = "leo-editor-${version}";
-  version = "5.5";
+  version = "5.6";
 
   src = fetchFromGitHub {
     owner = "leo-editor";
     repo = "leo-editor";
     rev = version;
-    sha256 = "0crzljirzfiy9xn02ydd23clmd8bzdjxkyxdqsvdkgfy9j41b8hr";
+    sha256 = "1k6q3gvaf05bi0mzkmmb1p6wrgxwri7ivn38p6f0m0wfd3f70x2j";
   };
 
   dontBuild = true;
 
-  nativeBuildInputs = [ makeWrapper python3Packages.python ];
-  propagatedBuildInputs = with python3Packages; [ pyqt5 ];
+  nativeBuildInputs = [ makeWrapper python3 ];
+  propagatedBuildInputs = with pythonPackages; [ pyqt56 docutils ];
 
   desktopItem = makeDesktopItem rec {
     name = "leo-editor";
@@ -50,7 +59,7 @@ stdenv.mkDerivation rec {
     mkdir -p $out/share/leo-editor
     mv * $out/share/leo-editor
 
-    makeWrapper ${python3Packages.python.interpreter} $out/bin/leo \
+    makeWrapper ${python3.interpreter} $out/bin/leo \
       --set PYTHONPATH "$PYTHONPATH:$out/share/leo-editor" \
       --add-flags "-O $out/share/leo-editor/launchLeo.py"
   '';
diff --git a/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix b/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
index c4158d280e2b..34f0d16a7b43 100644
--- a/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
+++ b/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
@@ -1,5 +1,5 @@
 { mkDerivation, lib, fetchgit, fetchpatch
-, pkgconfig, gyp, cmake, gcc7, makeWrapper
+, pkgconfig, gyp, cmake, makeWrapper
 , qtbase, qtimageformats, gtk3, libappindicator-gtk3
 , dee, ffmpeg, openalSoft, minizip, libopus, alsaLib, libpulseaudio, range-v3
 }:
@@ -31,7 +31,7 @@ mkDerivation rec {
     })
   ];
 
-  nativeBuildInputs = [ pkgconfig gyp cmake gcc7 makeWrapper ];
+  nativeBuildInputs = [ pkgconfig gyp cmake makeWrapper ];
 
   buildInputs = [
     qtbase qtimageformats gtk3 libappindicator-gtk3
diff --git a/pkgs/applications/version-management/git-and-tools/git/default.nix b/pkgs/applications/version-management/git-and-tools/git/default.nix
index afb3716f04ce..e545cb33befe 100644
--- a/pkgs/applications/version-management/git-and-tools/git/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git/default.nix
@@ -13,7 +13,7 @@
 }:
 
 let
-  version = "2.16.1";
+  version = "2.16.2";
   svn = subversionClient.override { perlBindings = true; };
 in
 
@@ -22,7 +22,7 @@ stdenv.mkDerivation {
 
   src = fetchurl {
     url = "https://www.kernel.org/pub/software/scm/git/git-${version}.tar.xz";
-    sha256 = "06gay8k29glg4giwphjalcc1fknxw4bmxkmbr3ic3gzxy8vl7bfg";
+    sha256 = "05y7480f2p7fkncbhf08zz56jbykcp0ia5gl6y3djs0lsa5mfq2m";
   };
 
   hardeningDisable = [ "format" ];
diff --git a/pkgs/applications/virtualization/qemu/statfs-flags.patch b/pkgs/applications/virtualization/qemu/statfs-flags.patch
index c0f0162aacc9..52a470a2869a 100644
--- a/pkgs/applications/virtualization/qemu/statfs-flags.patch
+++ b/pkgs/applications/virtualization/qemu/statfs-flags.patch
@@ -1,4 +1,4 @@
-commit d3282d2512774dc5027c98930a3852b2b6e8407a
+commit 909fe47c7009aa9a75fe9470c5f8d3dd5b50917a
 Author: Shea Levy <shea@shealevy.com>
 Date:   Sun Feb 18 13:50:11 2018 -0500
 
@@ -59,7 +59,7 @@ index 82b35a6bdf..77481eca2c 100644
              unlock_user_struct(target_stfs, arg2, 1);
          }
 diff --git a/linux-user/syscall_defs.h b/linux-user/syscall_defs.h
-index a35c52a60a..9f90451caf 100644
+index a35c52a60a..64aa49d3c5 100644
 --- a/linux-user/syscall_defs.h
 +++ b/linux-user/syscall_defs.h
 @@ -362,7 +362,14 @@ struct kernel_statfs {
@@ -77,49 +77,46 @@ index a35c52a60a..9f90451caf 100644
  };
  
  struct target_dirent {
-@@ -2223,7 +2230,13 @@ struct target_statfs {
+@@ -2223,7 +2230,12 @@ struct target_statfs {
  	/* Linux specials */
  	target_fsid_t		f_fsid;
  	int32_t			f_namelen;
 +#ifdef HAVE_STATFS_FLAGS
-+	int32_t			f_frsize;
 +	int32_t			f_flags;
-+	int32_t			f_spare[4];
++	int32_t			f_spare[5];
 +#else
  	int32_t			f_spare[6];
 +#endif
  };
  #else
  struct target_statfs {
-@@ -2239,7 +2252,13 @@ struct target_statfs {
+@@ -2239,7 +2251,12 @@ struct target_statfs {
  	/* Linux specials */
  	target_fsid_t		f_fsid;
  	abi_long		f_namelen;
 +#ifdef HAVE_STATFS_FLAGS
-+	abi_long		f_frsize;
 +	abi_long		f_flags;
-+	abi_long		f_spare[4];
++	abi_long		f_spare[5];
 +#else
  	abi_long		f_spare[6];
 +#endif
  };
  #endif
  
-@@ -2255,7 +2274,13 @@ struct target_statfs64 {
+@@ -2255,7 +2272,12 @@ struct target_statfs64 {
  	uint64_t	f_bavail;
  	target_fsid_t	f_fsid;
  	uint32_t	f_namelen;
 +#ifdef HAVE_STATFS_FLAGS
-+	uint32_t	f_frsize;
 +	uint32_t	f_flags;
-+	uint32_t	f_spare[4];
++	uint32_t	f_spare[5];
 +#else
  	uint32_t	f_spare[6];
 +#endif
  };
  #elif (defined(TARGET_PPC64) || defined(TARGET_X86_64) || \
         defined(TARGET_SPARC64) || defined(TARGET_AARCH64)) && \
-@@ -2271,7 +2296,12 @@ struct target_statfs {
+@@ -2271,7 +2293,12 @@ struct target_statfs {
  	target_fsid_t f_fsid;
  	abi_long f_namelen;
  	abi_long f_frsize;
@@ -132,7 +129,7 @@ index a35c52a60a..9f90451caf 100644
  };
  
  struct target_statfs64 {
-@@ -2285,7 +2315,12 @@ struct target_statfs64 {
+@@ -2285,7 +2312,12 @@ struct target_statfs64 {
  	target_fsid_t f_fsid;
  	abi_long f_namelen;
  	abi_long f_frsize;
@@ -145,7 +142,7 @@ index a35c52a60a..9f90451caf 100644
  };
  #elif defined(TARGET_S390X)
  struct target_statfs {
-@@ -2299,7 +2334,13 @@ struct target_statfs {
+@@ -2299,7 +2331,13 @@ struct target_statfs {
      kernel_fsid_t f_fsid;
      int32_t  f_namelen;
      int32_t  f_frsize;
@@ -159,7 +156,7 @@ index a35c52a60a..9f90451caf 100644
  };
  
  struct target_statfs64 {
-@@ -2313,7 +2354,12 @@ struct target_statfs64 {
+@@ -2313,7 +2351,12 @@ struct target_statfs64 {
      kernel_fsid_t f_fsid;
      int32_t  f_namelen;
      int32_t  f_frsize;
@@ -172,7 +169,7 @@ index a35c52a60a..9f90451caf 100644
  };
  #else
  struct target_statfs {
-@@ -2327,7 +2373,12 @@ struct target_statfs {
+@@ -2327,7 +2370,12 @@ struct target_statfs {
  	target_fsid_t f_fsid;
  	uint32_t f_namelen;
  	uint32_t f_frsize;
@@ -185,7 +182,7 @@ index a35c52a60a..9f90451caf 100644
  };
  
  struct target_statfs64 {
-@@ -2341,7 +2392,12 @@ struct target_statfs64 {
+@@ -2341,7 +2389,12 @@ struct target_statfs64 {
  	target_fsid_t f_fsid;
          uint32_t f_namelen;
  	uint32_t f_frsize;