about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2009-10-02 11:49:21 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2009-10-02 11:49:21 +0000
commit4041f93fbfe0eb6eed0b02f9045e286aed9451ca (patch)
tree7528d944a26f79fdd0a342c7be0d47cb322dedb0 /pkgs/applications
parentd68835524d21e774c76685d84f9b6b54b8b385b9 (diff)
downloadnixlib-4041f93fbfe0eb6eed0b02f9045e286aed9451ca.tar
nixlib-4041f93fbfe0eb6eed0b02f9045e286aed9451ca.tar.gz
nixlib-4041f93fbfe0eb6eed0b02f9045e286aed9451ca.tar.bz2
nixlib-4041f93fbfe0eb6eed0b02f9045e286aed9451ca.tar.lz
nixlib-4041f93fbfe0eb6eed0b02f9045e286aed9451ca.tar.xz
nixlib-4041f93fbfe0eb6eed0b02f9045e286aed9451ca.tar.zst
nixlib-4041f93fbfe0eb6eed0b02f9045e286aed9451ca.zip
* SWIG apparently doesn't need Perl/Python/Guile/JDK/20 other
  languages at build time.  It seems they're only used in "make
  check".
* Subversion: updated to 1.6.5.

svn path=/nixpkgs/trunk/; revision=17594
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/subversion/1.5.nix78
-rw-r--r--pkgs/applications/version-management/subversion/1.6.nix18
2 files changed, 9 insertions, 87 deletions
diff --git a/pkgs/applications/version-management/subversion/1.5.nix b/pkgs/applications/version-management/subversion/1.5.nix
deleted file mode 100644
index c892ac8652b6..000000000000
--- a/pkgs/applications/version-management/subversion/1.5.nix
+++ /dev/null
@@ -1,78 +0,0 @@
-{ bdbSupport ? false # build support for Berkeley DB repositories
-, httpServer ? false # build Apache DAV module
-, httpSupport ? false # client must support http
-, sslSupport ? false # client must support https
-, compressionSupport ? false # client must support http compression
-, pythonBindings ? false
-, perlBindings ? false
-, javahlBindings ? false
-, stdenv, fetchurl, apr, aprutil, neon, zlib
-, httpd ? null, expat, swig ? null, jdk ? null
-, static ? false
-}:
-
-assert bdbSupport -> aprutil.bdbSupport;
-assert httpServer -> httpd != null;
-assert pythonBindings -> swig != null && swig.pythonSupport;
-assert javahlBindings -> jdk != null;
-assert sslSupport -> neon.sslSupport;
-assert compressionSupport -> neon.compressionSupport;
-
-stdenv.mkDerivation rec {
-
-  version = "1.5.6";
-
-  name = "subversion-${version}";
-
-  src = fetchurl {
-    url = "http://subversion.tigris.org/downloads/${name}.tar.bz2";
-    sha256 = "1hj69zvg6wk6gryaaa1gi896j53633560wkirypdjhyczrszw0gp";
-  };
-
-  buildInputs = [zlib apr aprutil]
-    ++ stdenv.lib.optional httpSupport neon
-    ++ stdenv.lib.optional pythonBindings swig.python
-    ++ stdenv.lib.optional perlBindings swig.perl
-    ;
-
-  configureFlags = ''
-    --disable-keychain
-    ${if static then "--disable-shared --enable-all-static" else ""}
-    ${if bdbSupport then "--with-berkeley-db" else "--without-berkeley-db"}
-    ${if httpServer then "--with-apxs=${httpd}/bin/apxs" else "--without-apxs"}
-    ${if pythonBindings || perlBindings then "--with-swig=${swig}" else "--without-swig"}
-    ${if javahlBindings then "--enable-javahl --with-jdk=${jdk}" else ""}
-    --disable-neon-version-check
-  '';
-
-  preBuild = ''
-    makeFlagsArray=(APACHE_LIBEXECDIR=$out/modules)
-  '';
-
-  postInstall = ''
-    ensureDir $out/share/emacs/site-lisp
-    cp contrib/client-side/emacs/*.el $out/share/emacs/site-lisp/
-
-    if test "$pythonBindings"; then
-        make swig-py swig_pydir=$(toPythonPath $out)/libsvn swig_pydir_extra=$(toPythonPath $out)/svn
-        make install-swig-py swig_pydir=$(toPythonPath $out)/libsvn swig_pydir_extra=$(toPythonPath $out)/svn
-    fi
-
-    if test "$perlBindings"; then
-        make swig-pl-lib
-        make install-swig-pl-lib
-        cd subversion/bindings/swig/perl/native
-        perl Makefile.PL PREFIX=$out
-        make install
-        cd -
-    fi
-  ''; # */
-
-  inherit perlBindings pythonBindings;
-
-  meta = {
-    description = "A version control system intended to be a compelling replacement for CVS in the open source community";
-    homepage = http://subversion.tigris.org/;
-  };
-}
-
diff --git a/pkgs/applications/version-management/subversion/1.6.nix b/pkgs/applications/version-management/subversion/1.6.nix
index 37557123d659..87008ae922d4 100644
--- a/pkgs/applications/version-management/subversion/1.6.nix
+++ b/pkgs/applications/version-management/subversion/1.6.nix
@@ -7,32 +7,32 @@
 , perlBindings ? false
 , javahlBindings ? false
 , stdenv, fetchurl, apr, aprutil, neon, zlib, sqlite
-, httpd ? null, expat, swig ? null, jdk ? null
+, httpd ? null, expat, swig ? null, jdk ? null, python ? null, perl ? null
 , static ? false
 }:
 
 assert bdbSupport -> aprutil.bdbSupport;
 assert httpServer -> httpd != null;
-assert pythonBindings -> swig != null && swig.pythonSupport;
-assert javahlBindings -> jdk != null;
+assert pythonBindings -> swig != null && python != null;
+assert javahlBindings -> jdk != null && perl != null;
 assert sslSupport -> neon.sslSupport;
 assert compressionSupport -> neon.compressionSupport;
 
 stdenv.mkDerivation rec {
 
-  version = "1.6.4";
+  version = "1.6.5";
 
   name = "subversion-${version}";
 
   src = fetchurl {
     url = "http://subversion.tigris.org/downloads/${name}.tar.bz2";
-    sha256 = "0lhfmz0bnvwka3w8j8hpfimcyqz1w6khqv100wvzx13wfgkgd6vw";
+    sha256 = "1badvnx1305dm79g31l1536z78nsi7n9wi4v6s6lp64y8pd1ncv4";
   };
 
   buildInputs = [zlib apr aprutil sqlite]
     ++ stdenv.lib.optional httpSupport neon
-    ++ stdenv.lib.optional pythonBindings swig.python
-    ++ stdenv.lib.optional perlBindings swig.perl
+    ++ stdenv.lib.optional pythonBindings python
+    ++ stdenv.lib.optional perlBindings perl
     ;
 
   configureFlags = ''
@@ -55,12 +55,12 @@ stdenv.mkDerivation rec {
     ensureDir $out/share/emacs/site-lisp
     cp contrib/client-side/emacs/*.el $out/share/emacs/site-lisp/
 
-    if test "$pythonBindings"; then
+    if test -n "$pythonBindings"; then
         make swig-py swig_pydir=$(toPythonPath $out)/libsvn swig_pydir_extra=$(toPythonPath $out)/svn
         make install-swig-py swig_pydir=$(toPythonPath $out)/libsvn swig_pydir_extra=$(toPythonPath $out)/svn
     fi
 
-    if test "$perlBindings"; then
+    if test -n "$perlBindings"; then
         make swig-pl-lib
         make install-swig-pl-lib
         cd subversion/bindings/swig/perl/native