about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-02-20 22:27:33 +0000
committerRobin Gloster <mail@glob.in>2016-02-20 22:27:33 +0000
commit4036e9ba8cd8aa450e27541daa31d490a4e79d38 (patch)
treecdfaf300d05204afb4b51bcd58dc4350d2b42d5a /pkgs/applications
parent8641b9dec4d6d66c7414f4c64f38e70be89b2af7 (diff)
parent3e7e8e88078b6e73b7b72aa64efd87bf4feedc2c (diff)
downloadnixlib-4036e9ba8cd8aa450e27541daa31d490a4e79d38.tar
nixlib-4036e9ba8cd8aa450e27541daa31d490a4e79d38.tar.gz
nixlib-4036e9ba8cd8aa450e27541daa31d490a4e79d38.tar.bz2
nixlib-4036e9ba8cd8aa450e27541daa31d490a4e79d38.tar.lz
nixlib-4036e9ba8cd8aa450e27541daa31d490a4e79d38.tar.xz
nixlib-4036e9ba8cd8aa450e27541daa31d490a4e79d38.tar.zst
nixlib-4036e9ba8cd8aa450e27541daa31d490a4e79d38.zip
Merge branch 'up' into hardened-stdenv
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/spotify/default.nix4
-rw-r--r--pkgs/applications/misc/pcmanx-gtk2/default.nix23
-rw-r--r--pkgs/applications/networking/ftp/filezilla/default.nix8
-rw-r--r--pkgs/applications/networking/irc/weechat/default.nix48
-rw-r--r--pkgs/applications/networking/remote/teamviewer/default.nix2
-rw-r--r--pkgs/applications/version-management/pijul/default.nix28
-rw-r--r--pkgs/applications/version-management/pijul/pijul.org.context92
-rw-r--r--pkgs/applications/video/mpv/default.nix4
8 files changed, 181 insertions, 28 deletions
diff --git a/pkgs/applications/audio/spotify/default.nix b/pkgs/applications/audio/spotify/default.nix
index f345e9710d2f..bf06761bc533 100644
--- a/pkgs/applications/audio/spotify/default.nix
+++ b/pkgs/applications/audio/spotify/default.nix
@@ -5,7 +5,7 @@
 assert stdenv.system == "x86_64-linux";
 
 let
-  version = "1.0.19.106.gb8a7150f";
+  version = "1.0.23.93.gd6cfae15-30";
 
   deps = [
     alsaLib
@@ -50,7 +50,7 @@ stdenv.mkDerivation {
   src =
     fetchurl {
       url = "http://repository-origin.spotify.com/pool/non-free/s/spotify-client/spotify-client_${version}_amd64.deb";
-      sha256 = "be6b99329bb2fccdc9d77bc949dd463576fdb40db7f56195b4284bd348c470be";
+      sha256 = "0n6vz51jv6s20dp4zlqkk52bpmpyfm1qn5bfm4lfq09x1g6ir5lr";
     };
 
   buildInputs = [ dpkg makeWrapper ];
diff --git a/pkgs/applications/misc/pcmanx-gtk2/default.nix b/pkgs/applications/misc/pcmanx-gtk2/default.nix
new file mode 100644
index 000000000000..fb655ceba5dc
--- /dev/null
+++ b/pkgs/applications/misc/pcmanx-gtk2/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchurl, gtk2, libXft, intltool, automake115x, autoconf, libtool, pkgconfig }:
+
+stdenv.mkDerivation {
+  name = "pcmanx-gtk2-1.3";
+  src = fetchurl {
+    url = "https://github.com/pcman-bbs/pcmanx/archive/1.3.tar.gz";
+    sha256 = "2e5c59f6b568036f2ad6ac67ca2a41dfeeafa185451e507f9fb987d4ed9c4302";
+  };
+
+  buildInputs = [ gtk2 libXft intltool automake115x autoconf libtool pkgconfig ];
+
+  preConfigurePhases = ''
+    ./autogen.sh
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://pcman.ptt.cc";
+    license = licenses.gpl2;
+    description = "Telnet BBS browser with GTK+ interface";
+    maintainers = [ maintainers.mingchuan ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/applications/networking/ftp/filezilla/default.nix b/pkgs/applications/networking/ftp/filezilla/default.nix
index 6c8df2fcd65b..8f53102d5f53 100644
--- a/pkgs/applications/networking/ftp/filezilla/default.nix
+++ b/pkgs/applications/networking/ftp/filezilla/default.nix
@@ -1,13 +1,13 @@
 { stdenv, fetchurl, dbus, gnutls, wxGTK30, libidn, tinyxml, gettext
-, pkgconfig, xdg_utils, gtk2, sqlite, pugixml }:
+, pkgconfig, xdg_utils, gtk2, sqlite, pugixml, libfilezilla }:
 
-let version = "3.14.1"; in
+let version = "3.15.0.2"; in
 stdenv.mkDerivation {
   name = "filezilla-${version}";
 
   src = fetchurl {
     url = "mirror://sourceforge/project/filezilla/FileZilla_Client/${version}/FileZilla_${version}_src.tar.bz2";
-    sha256 = "0v6lb7miy6jbnswii816na8818xqxlvs1vadnii21xfmrsv7225i";
+    sha256 = "0kvwkz01v73qi8y6n8wlidglwh0vg7pajsjm8xq7gch6jmq4cg1k";
   };
 
   configureFlags = [
@@ -16,7 +16,7 @@ stdenv.mkDerivation {
 
   buildInputs = [
     dbus gnutls wxGTK30 libidn tinyxml gettext pkgconfig xdg_utils gtk2 sqlite
-    pugixml ];
+    pugixml libfilezilla ];
 
   meta = with stdenv.lib; {
     homepage = http://filezilla-project.org/;
diff --git a/pkgs/applications/networking/irc/weechat/default.nix b/pkgs/applications/networking/irc/weechat/default.nix
index a781a8ceb353..54bba77b182b 100644
--- a/pkgs/applications/networking/irc/weechat/default.nix
+++ b/pkgs/applications/networking/irc/weechat/default.nix
@@ -1,8 +1,24 @@
-{ stdenv, fetchurl, ncurses, openssl, perl, python, aspell, gnutls
-, zlib, curl , pkgconfig, libgcrypt, ruby, lua5, tcl, guile
-, pythonPackages, cmake, makeWrapper, libobjc, libiconv
+{ stdenv, fetchurl, ncurses, openssl, aspell, gnutls
+, zlib, curl , pkgconfig, libgcrypt
+, cmake, makeWrapper, libobjc, libiconv
+, guileSupport ? true, guile
+, luaSupport ? true, lua5
+, perlSupport ? true, perl
+, pythonPackages
+, rubySupport ? true, ruby
+, tclSupport ? true, tcl
 , extraBuildInputs ? [] }:
 
+assert guileSupport -> guile != null;
+assert luaSupport -> lua5 != null;
+assert perlSupport -> perl != null;
+assert rubySupport -> ruby != null;
+assert tclSupport -> tcl != null;
+
+let
+  inherit (pythonPackages) python pycrypto pync;
+in
+
 stdenv.mkDerivation rec {
   version = "1.4";
   name = "weechat-${version}";
@@ -12,14 +28,26 @@ stdenv.mkDerivation rec {
     sha256 = "1m6xq6izcac5186xvvmm8znfjzrg9hq42p69jabdvv7cri4rjvg0";
   };
 
-  cmakeFlags = stdenv.lib.optional stdenv.isDarwin
-    "-DICONV_LIBRARY=${libiconv}/lib/libiconv.dylib";
+  cmakeFlags = with stdenv.lib; []
+    ++ optional stdenv.isDarwin "-DICONV_LIBRARY=${libiconv}/lib/libiconv.dylib"
+    ++ optional (!guileSupport) "-DENABLE_GUILE=OFF"
+    ++ optional (!luaSupport)   "-DENABLE_LUA=OFF"
+    ++ optional (!perlSupport)  "-DENABLE_PERL=OFF"
+    ++ optional (!rubySupport)  "-DENABLE_RUBY=OFF"
+    ++ optional (!tclSupport)   "-DENABLE_TCL=OFF"
+    ;
 
-  buildInputs = 
-    [ ncurses perl python openssl aspell gnutls zlib curl pkgconfig
-      libgcrypt ruby lua5 tcl guile pythonPackages.pycrypto makeWrapper
-      cmake ]
-    ++ stdenv.lib.optionals stdenv.isDarwin [ pythonPackages.pync libobjc ]
+  buildInputs = with stdenv.lib; [
+      ncurses python openssl aspell gnutls zlib curl pkgconfig
+      libgcrypt pycrypto makeWrapper
+      cmake
+    ]
+    ++ optionals stdenv.isDarwin [ pync libobjc ]
+    ++ optional  guileSupport    guile
+    ++ optional  luaSupport      lua5
+    ++ optional  perlSupport     perl
+    ++ optional  rubySupport     ruby
+    ++ optional  tclSupport      tcl
     ++ extraBuildInputs;
 
   NIX_CFLAGS_COMPILE = "-I${python}/include/${python.libPrefix} -DCA_FILE=/etc/ssl/certs/ca-certificates.crt";
diff --git a/pkgs/applications/networking/remote/teamviewer/default.nix b/pkgs/applications/networking/remote/teamviewer/default.nix
index dd947d86daf8..1abedc890f46 100644
--- a/pkgs/applications/networking/remote/teamviewer/default.nix
+++ b/pkgs/applications/networking/remote/teamviewer/default.nix
@@ -52,7 +52,7 @@ stdenv.mkDerivation {
     ${if stdenv.system == "x86_64-linux" then ''
       sed -i "s,TV_LD64_PATH=.*,TV_LD64_PATH=$(cat ${ld64})," script/tvw_config
     '' else ''
-      sed -i ",TV_LD64_PATH=.*,d" script/tvw_config
+      sed -i "/TV_LD64_PATH=.*/d" script/tvw_config
     ''}
 
     sed -i "s,/opt/teamviewer,$out/share/teamviewer,g" desktop/teamviewer-*.desktop
diff --git a/pkgs/applications/version-management/pijul/default.nix b/pkgs/applications/version-management/pijul/default.nix
index f00e22bb385c..399e4cf30244 100644
--- a/pkgs/applications/version-management/pijul/default.nix
+++ b/pkgs/applications/version-management/pijul/default.nix
@@ -1,22 +1,32 @@
-{ stdenv, fetchdarcs, ocaml, findlib, cryptokit, yojson, lmdb, zlib }:
+{ stdenv, fetchdarcs, rustUnstable, openssl, libssh }:
 
-stdenv.mkDerivation rec {
+with rustUnstable;
+
+buildRustPackage rec {
   name = "pijul-${version}";
-  version = "0.1";
+  version = "0.2-6ab9ba";
 
   src = fetchdarcs {
     url = "http://pijul.org/";
-    rev = version;
-    sha256 = "0r189xx900w4smq6nyy1wnrjf9sgqrqw5as0l7k6gq0ra36szzff";
+    context = ./pijul.org.context;
+    sha256 = "1cgkcr5wdkwj7s0rda90bfchbwmchgi60w5d637894w20hkplsr4";
   };
 
-  buildInputs = [ ocaml findlib cryptokit yojson lmdb zlib ];
+  sourceRoot = "fetchdarcs/pijul";
+
+  depsSha256 = "110bj2lava1xs75z6k34aip7zb7rcmnxk5hmiyi32i9hs0ddsdrz";
 
-  installPhase = ''
-    mkdir -p $out/bin
-    cp pijul $out/bin/
+  cargoUpdateHook = ''
+    cp -r ../libpijul src/
   '';
 
+  setSourceRoot = ''
+    chmod -R u+w "$sourceRoot"
+    cp -r "$sourceRoot"/../libpijul "$sourceRoot"/src/
+  '';
+
+  buildInputs = [ openssl libssh ];
+
   meta = with stdenv.lib; {
     homepage = https://pijul.org/;
     description = "Fast DVCS based on a categorical theory of patches";
diff --git a/pkgs/applications/version-management/pijul/pijul.org.context b/pkgs/applications/version-management/pijul/pijul.org.context
new file mode 100644
index 000000000000..03a3f0f9a7c1
--- /dev/null
+++ b/pkgs/applications/version-management/pijul/pijul.org.context
@@ -0,0 +1,92 @@
+
+Context:
+
+[+libpijul/Cargo.lock
+pe@pijul.org**20160212063509
+ Ignore-this: e5a696b13850b36668a41aedb7bd1b74
+] 
+
+[+pijul/Cargo.lock
+pe@pijul.org**20160212063451
+ Ignore-this: a621a502d1701cb63e6b5c8fd0afbde8
+] 
+
+[Error detection, gnupg messages
+pe@pijul.org**20160210101417
+ Ignore-this: 3c517e122c1eca1df9520aed8fd3b0ea
+] 
+
+[Login command
+pe@pijul.org**20160210055826
+ Ignore-this: 7be5618dc418554a82c5f8a68cc8f515
+] 
+
+[Extra functions for the nest
+pe@pijul.org**20160208205519
+ Ignore-this: 39c8cbed5517b31bc846493e6ffefc76
+] 
+
+[Timestamp in RFC3339
+pe@pijul.org**20160208145551
+ Ignore-this: dd114fe418052570572d73e443683d85
+] 
+
+[Combined external_hash and contents in libpijul (makes it easier to print patches)
+pe@pijul.org**20160208145450
+ Ignore-this: 69f588e1bab551bffd719fa05ad7080a
+] 
+
+[disentangle output in libpijul
+florent.becker@ens-lyon.org**20160208094544
+ Ignore-this: 2dc35255cf48d77eb0c4ba2dde6d4f98
+] 
+
+[Disentangle libpijul::Repository::local_diff
+florent.becker@ens-lyon.org**20160207104631
+ Ignore-this: 65b119358afa95eb013e84c0d7a250d9
+] 
+
+[remove redundant import
+florent.becker@ens-lyon.org**20160207104613
+ Ignore-this: e3f7873ec678f62f4129be61238c2c0d
+] 
+
+[Disentangle add_lines and delete_lines in diff
+florent.becker@ens-lyon.org**20160207102456
+ Ignore-this: 5e89908adf7a519bbe2b2ab399cf0a2
+] 
+
+[Disentangle libpijul::rec_delete
+florent.becker@ens-lyon.org**20160206214730
+ Ignore-this: fb6a70c298a38724665c3d6452577649
+] 
+
+[Make InternalKey type be an array rather than a reference
+florent.becker@ens-lyon.org**20160205195638
+ Ignore-this: f9b5d15049358b2d8e93322d25a50e58
+] 
+
+[Ask ssh known_hosts, and new file format
+pe@pijul.org**20160207120834
+ Ignore-this: f7a7f2ae672a3f6f40a2ac85139d6e10
+] 
+
+[Handling HTTP errors (when cloning from HTTP)
+pe@pijul.org**20160204182444
+ Ignore-this: 1805ae8d3b8a4ca49da06e18dd37b151
+] 
+
+[Small debugging assertions
+pe@pijul.org**20160203143007
+ Ignore-this: e3d3dddc72511166d606e1751b19411b
+] 
+
+[Two unused functions back (used in the nest)
+pe@pijul.org**20160202075743
+ Ignore-this: 8c6904b122c8a78bfa0b9cc5416c943
+] 
+
+[TAG 0.2
+pe@pijul.org**20160202073939
+ Ignore-this: 1e9d04d5ffe231ffaccaf9c4ccb684d3
+] 
diff --git a/pkgs/applications/video/mpv/default.nix b/pkgs/applications/video/mpv/default.nix
index 38efe61a7df5..5bc2eee24145 100644
--- a/pkgs/applications/video/mpv/default.nix
+++ b/pkgs/applications/video/mpv/default.nix
@@ -61,7 +61,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://github.com/mpv-player/mpv/archive/v${meta.version}.tar.gz";
-    sha256 = "0cqjwl0xyg0sv1jflipfkvqjg32y0kqfh4gc3lyhqgv0hgs3fa84";
+    sha256 = "1p0b83048g66icpz5n66v3k4ldr1z0rmg5d2rr7kcbspm1xj2cbx";
   };
 
   patchPhase = ''
@@ -125,7 +125,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with stdenv.lib; {
-    version = "0.14.0";
+    version = "0.15.0";
     description = "A media player that supports many video formats (MPlayer and mplayer2 fork)";
     homepage = http://mpv.io;
     license = licenses.gpl2Plus;