about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorChristoph Heiss <christoph@c8h4.io>2024-02-07 10:12:39 +0100
committerChristoph Heiss <christoph@c8h4.io>2024-02-07 14:47:18 +0100
commit3f35705fae430ee2aed28c31d1838e0f71a41122 (patch)
treea458145fe9b24d171d7fa92af558ae4d864f6034 /pkgs/applications
parent16c4501f965f1d0abc128dbc2885239a19d0ed5b (diff)
downloadnixlib-3f35705fae430ee2aed28c31d1838e0f71a41122.tar
nixlib-3f35705fae430ee2aed28c31d1838e0f71a41122.tar.gz
nixlib-3f35705fae430ee2aed28c31d1838e0f71a41122.tar.bz2
nixlib-3f35705fae430ee2aed28c31d1838e0f71a41122.tar.lz
nixlib-3f35705fae430ee2aed28c31d1838e0f71a41122.tar.xz
nixlib-3f35705fae430ee2aed28c31d1838e0f71a41122.tar.zst
nixlib-3f35705fae430ee2aed28c31d1838e0f71a41122.zip
sourcehut.todosrht: 0.74.6 -> 0.75.6
Also refactor it to the same common structure as all other sourcehut
packages, thus opening the possibility to even further simplify this in
the future.

Signed-off-by: Christoph Heiss <christoph@c8h4.io>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/sourcehut/todo.nix32
1 files changed, 18 insertions, 14 deletions
diff --git a/pkgs/applications/version-management/sourcehut/todo.nix b/pkgs/applications/version-management/sourcehut/todo.nix
index 2fc9c4485fd7..cb446bde9d65 100644
--- a/pkgs/applications/version-management/sourcehut/todo.nix
+++ b/pkgs/applications/version-management/sourcehut/todo.nix
@@ -12,31 +12,35 @@
 , setuptools
 }:
 
-buildPythonPackage rec {
-  pname = "todosrht";
-  version = "0.74.6";
-  pyproject = true;
-
-  disabled = pythonOlder "3.7";
+let
+  version = "0.75.6";
+  gqlgen = import ./fix-gqlgen-trimpath.nix { inherit unzip; gqlgenVersion = "0.17.36"; };
 
   src = fetchFromSourcehut {
     owner = "~sircmpwn";
     repo = "todo.sr.ht";
     rev = version;
-    sha256 = "sha256-j12pCGfKf6+9R8NOBIrH2V4OuSMuncU6S1AMWFVoHts=";
+    hash = "sha256-BPJ1M9dX+xNIw++VZ0Si/rjnfI9BY95TE2o+u7JRVAU=";
   };
 
-  postPatch = ''
-    substituteInPlace Makefile \
-      --replace "all: api" ""
-  '';
-
   todosrht-api = buildGoModule ({
     inherit src version;
     pname = "todosrht-api";
     modRoot = "api";
-    vendorHash = "sha256-rvfG5F6ez8UM0dYVhKfzwtb7ZEJlaKMBAfKDbo3Aofc=";
-  } // import ./fix-gqlgen-trimpath.nix { inherit unzip; });
+    vendorHash = "sha256-vTKIJFE8AFR2eZFwG9ba6FWPW02og3ZVcrsqUnOkJIQ=";
+  } // gqlgen);
+in
+buildPythonPackage rec {
+  inherit src version;
+  pname = "todosrht";
+  pyproject = true;
+
+  disabled = pythonOlder "3.7";
+
+  postPatch = ''
+    substituteInPlace Makefile \
+      --replace "all: api" ""
+  '';
 
   nativeBuildInputs = [
     setuptools