about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2012-01-15 11:44:02 +0000
committerPeter Simons <simons@cryp.to>2012-01-15 11:44:02 +0000
commit3c8a798411b6929f27517832356bfa316913b589 (patch)
treee32a358b05abe6cdf3f8fbf2e89bddafd28f0199 /pkgs/applications
parent97e815a9af9d71903d1bee3349c907039d3336eb (diff)
downloadnixlib-3c8a798411b6929f27517832356bfa316913b589.tar
nixlib-3c8a798411b6929f27517832356bfa316913b589.tar.gz
nixlib-3c8a798411b6929f27517832356bfa316913b589.tar.bz2
nixlib-3c8a798411b6929f27517832356bfa316913b589.tar.lz
nixlib-3c8a798411b6929f27517832356bfa316913b589.tar.xz
nixlib-3c8a798411b6929f27517832356bfa316913b589.tar.zst
nixlib-3c8a798411b6929f27517832356bfa316913b589.zip
gource: added meta information and moved the package into version-management category
svn path=/nixpkgs/trunk/; revision=31570
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/gource/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/applications/version-management/gource/default.nix b/pkgs/applications/version-management/gource/default.nix
new file mode 100644
index 000000000000..a8c6cb91af5e
--- /dev/null
+++ b/pkgs/applications/version-management/gource/default.nix
@@ -0,0 +1,35 @@
+{stdenv, fetchurl, SDL, ftgl, pkgconfig, libpng, libjpeg, pcre, SDL_image, glew, mesa}:
+
+let
+  name = "gource-0.37";
+in
+stdenv.mkDerivation {
+  inherit name;
+
+  src = fetchurl {
+    url = "http://gource.googlecode.com/files/${name}.tar.gz";
+    sha256 = "03kd9nn65cl1p2jgn6pvpxmvnfscz3c8jqds90fsc0z37ij2iiyn";
+  };
+
+  buildInputs = [glew SDL ftgl pkgconfig libpng libjpeg pcre SDL_image mesa];
+
+  meta = {
+    homepage = "http://code.google.com/p/gource/";
+    description = "software version control visualization tool";
+    license = stdenv.lib.licenses.gpl3Plus;
+
+    longDescription = ''
+      Software projects are displayed by Gource as an animated tree with
+      the root directory of the project at its centre. Directories
+      appear as branches with files as leaves. Developers can be seen
+      working on the tree at the times they contributed to the project.
+
+      Currently Gource includes built-in log generation support for Git,
+      Mercurial and Bazaar and SVN. Gource can also parse logs produced
+      by several third party tools for CVS repositories.
+    '';
+
+    platforms = stdenv.lib.platforms.gnu;
+    maintainers = [ stdenv.lib.maintainers.simons ];
+  };
+}