about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-12-10 06:00:56 +0000
committerGitHub <noreply@github.com>2023-12-10 06:00:56 +0000
commit39d4e1cb18bdb43229e53d4fd950c3ce77210a02 (patch)
treef0496c617a774c94297f66b53780f7a2934ac484 /pkgs/applications
parentb5ff56aec743b9c83609fc0e26a6c439ee27f0df (diff)
parent584463c7449a116f095eb456116f728c2b31497b (diff)
downloadnixlib-39d4e1cb18bdb43229e53d4fd950c3ce77210a02.tar
nixlib-39d4e1cb18bdb43229e53d4fd950c3ce77210a02.tar.gz
nixlib-39d4e1cb18bdb43229e53d4fd950c3ce77210a02.tar.bz2
nixlib-39d4e1cb18bdb43229e53d4fd950c3ce77210a02.tar.lz
nixlib-39d4e1cb18bdb43229e53d4fd950c3ce77210a02.tar.xz
nixlib-39d4e1cb18bdb43229e53d4fd950c3ce77210a02.tar.zst
nixlib-39d4e1cb18bdb43229e53d4fd950c3ce77210a02.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/lapce/default.nix3
-rw-r--r--pkgs/applications/graphics/grafx2/default.nix48
-rw-r--r--pkgs/applications/misc/gosmore/default.nix36
-rw-r--r--pkgs/applications/misc/gosmore/pointer_int_comparison.patch11
-rw-r--r--pkgs/applications/science/logic/eprover/default.nix4
-rw-r--r--pkgs/applications/science/logic/z3/default.nix2
-rw-r--r--pkgs/applications/science/misc/root/default.nix4
7 files changed, 46 insertions, 62 deletions
diff --git a/pkgs/applications/editors/lapce/default.nix b/pkgs/applications/editors/lapce/default.nix
index 6b955bdb180b..e65d557fac83 100644
--- a/pkgs/applications/editors/lapce/default.nix
+++ b/pkgs/applications/editors/lapce/default.nix
@@ -97,6 +97,9 @@ rustPlatform.buildRustPackage rec {
   # Get openssl-sys to use pkg-config
   OPENSSL_NO_VENDOR = 1;
 
+  # This variable is read by build script, so that Lapce editor knows its version
+  env.RELEASE_TAG_NAME = "v${version}";
+
   buildInputs = [
     glib
     gtk3
diff --git a/pkgs/applications/graphics/grafx2/default.nix b/pkgs/applications/graphics/grafx2/default.nix
index 26454897ddab..cd2d89d0e99c 100644
--- a/pkgs/applications/graphics/grafx2/default.nix
+++ b/pkgs/applications/graphics/grafx2/default.nix
@@ -4,6 +4,7 @@
 , SDL
 , SDL_image
 , SDL_ttf
+, installShellFiles
 , fontconfig
 , libpng
 , libtiff
@@ -12,17 +13,28 @@
 , zlib
 }:
 
-stdenv.mkDerivation rec {
-  version = "2.8.3091";
+stdenv.mkDerivation (finalAttrs: {
   pname = "grafx2";
+  version = "2.8.3091";
+
+  outputs = [ "out" "man" ];
 
   src = fetchurl {
+    name = "grafx2-${finalAttrs.version}.tar.gz";
     url = "https://pulkomandy.tk/projects/GrafX2/downloads/65";
-    name = "${pname}-${version}.tar.gz";
     hash = "sha256-KdY7GUhQp/Q7t/ktLPGxI66ZHy2gDAffn2yB5pmcJCM=";
   };
 
-  nativeBuildInputs = [ pkg-config ];
+  postPatch = ''
+    substituteInPlace misc/unix/grafx2.desktop \
+      --replace "Exec=grafx2" "Exec=grafx2-sdl"
+  '';
+
+  nativeBuildInputs = [
+    installShellFiles
+    pkg-config
+  ];
+
   buildInputs = [
     SDL
     SDL_image
@@ -34,15 +46,31 @@ stdenv.mkDerivation rec {
     zlib
   ];
 
+  strictDeps = false; # Why??
+
   makeFlags = [ "-C src" ];
   installFlags = [ "-C src" "PREFIX=$(out)" ];
 
+  postInstall = ''
+    installManPage misc/unix/grafx2.1
+  '';
+
   meta = {
-    description = "Bitmap paint program inspired by the Amiga programs Deluxe Paint and Brilliance";
-    homepage = "http://pulkomandy.tk/projects/GrafX2";
-    license = lib.licenses.gpl2;
-    platforms = [ "x86_64-linux" "i686-linux" ];
-    maintainers = [];
+    homepage = "http://grafx2.eu/";
+    description = "The ultimate 256-color painting program";
+    longDescription = ''
+      GrafX2 is a bitmap paint program inspired by the Amiga programs ​Deluxe
+      Paint and Brilliance. Specialized in 256-color drawing, it includes a very
+      large number of tools and effects that make it particularly suitable for
+      pixel art, game graphics, and generally any detailed graphics painted with
+      a mouse.
+
+      The program is mostly developed on Haiku, Linux and Windows, but is also
+      portable on many other platforms.
+    '';
+    license = with lib.licenses; [ gpl2Plus ];
     mainProgram = "grafx2-sdl";
+    maintainers = with lib.maintainers; [ AndersonTorres ];
+    platforms = lib.platforms.unix;
   };
-}
+})
diff --git a/pkgs/applications/misc/gosmore/default.nix b/pkgs/applications/misc/gosmore/default.nix
deleted file mode 100644
index bd87e7b4aeb6..000000000000
--- a/pkgs/applications/misc/gosmore/default.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ lib, stdenv, fetchsvn, libxml2, gtk2, curl, pkg-config } :
-
-stdenv.mkDerivation rec {
-  pname = "gosmore";
-  version = "31801";
-  # the gosmore svn repository does not lock revision numbers of its externals
-  # so we explicitly disable them to avoid breaking the hash
-  # especially as the externals appear to be unused
-  src = fetchsvn {
-    url = "http://svn.openstreetmap.org/applications/rendering/gosmore";
-    sha256 = "0qsckpqx7i7f8gkqhkzdamr65250afk1rpnh3nbman35kdv3dsxi";
-    rev = version;
-    ignoreExternals = true;
-  };
-
-  buildInputs = [ libxml2 gtk2 curl ];
-
-  nativeBuildInputs = [ pkg-config ];
-
-  prePatch = ''
-    sed -e '/curl.types.h/d' -i *.{c,h,hpp,cpp}
-  '';
-
-  patches = [ ./pointer_int_comparison.patch ];
-  patchFlags = [ "-p1" "--binary" ]; # patch has dos style eol
-
-  meta = with lib; {
-    description = "Open Street Map viewer";
-    homepage = "https://sourceforge.net/projects/gosmore/";
-    maintainers = with maintainers; [
-      raskin
-    ];
-    platforms = platforms.linux;
-    license = licenses.bsd2;
-  };
-}
diff --git a/pkgs/applications/misc/gosmore/pointer_int_comparison.patch b/pkgs/applications/misc/gosmore/pointer_int_comparison.patch
deleted file mode 100644
index 4a715b6d8591..000000000000
--- a/pkgs/applications/misc/gosmore/pointer_int_comparison.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- blah_/jni/gosmore.cpp	1970-01-01 01:00:01.000000000 +0100

-+++ /dev/stdin	2018-03-18 00:21:08.474217132 +0100

-@@ -1273,7 +1273,7 @@

-       if (deg[i] < -180 || deg[i] > 180) break;

-       if (i == 0 && (strncasecmp (t, "lat", 3) == 0 ||

-                      strncasecmp (t, "lon", 3) == 0)) { // lat=-25.7 lon=28.2

--        for (t += 3; t != '\0' && !isalnum (*t); t++) {}

-+        for (t += 3; *t != '\0' && !isalnum (*t); t++) {}

-       }

-       if (i == 1) { // Success !

-         //printf ("%lf %lf %u\n", deg[lonFirst ? 1 : 0], deg[lonFirst ? 0 : 1],

diff --git a/pkgs/applications/science/logic/eprover/default.nix b/pkgs/applications/science/logic/eprover/default.nix
index ec1fc6b11d25..d4a8b7a6b2e8 100644
--- a/pkgs/applications/science/logic/eprover/default.nix
+++ b/pkgs/applications/science/logic/eprover/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   pname = "eprover";
-  version = "3.0";
+  version = "3.0.03";
 
   src = fetchurl {
     url = "https://wwwlehre.dhbw-stuttgart.de/~sschulz/WORK/E_DOWNLOAD/V_${version}/E.tgz";
-    hash = "sha256-gBgDC+GH948JMsjzo/SOpWDzJXu0g58YX1VW28PeorI=";
+    hash = "sha256-cS5zUe2N9Kd9uzbNpeBtvLbgUN0c3N3tGcYczK3KsdQ=";
   };
 
   buildInputs = [ which ];
diff --git a/pkgs/applications/science/logic/z3/default.nix b/pkgs/applications/science/logic/z3/default.nix
index 6165cfe8bd22..26848e1397aa 100644
--- a/pkgs/applications/science/logic/z3/default.nix
+++ b/pkgs/applications/science/logic/z3/default.nix
@@ -24,7 +24,7 @@ let common = { version, sha256, patches ? [ ], tag ? "z3" }:
     inherit version sha256 patches;
     src = fetchFromGitHub {
       owner = "Z3Prover";
-      repo = pname;
+      repo = "z3";
       rev = "${tag}-${version}";
       sha256 = sha256;
     };
diff --git a/pkgs/applications/science/misc/root/default.nix b/pkgs/applications/science/misc/root/default.nix
index 3f3b64069bb1..24844eb621ec 100644
--- a/pkgs/applications/science/misc/root/default.nix
+++ b/pkgs/applications/science/misc/root/default.nix
@@ -58,7 +58,7 @@
 
 stdenv.mkDerivation rec {
   pname = "root";
-  version = "6.28.08";
+  version = "6.28.10";
 
   passthru = {
     tests = import ./tests { inherit callPackage; };
@@ -66,7 +66,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://root.cern.ch/download/root_v${version}.source.tar.gz";
-    hash = "sha256-o+ZLTAH4fNm75X5h75a0FibkmwRGCVBw1B2b+6NSaGI=";
+    hash = "sha256-adb962B+ayC9AsdX+mIXAkwLYTLB6bHf9Nhdmiu35R4=";
   };
 
   nativeBuildInputs = [ makeWrapper cmake pkg-config git ];