about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2015-07-29 00:13:00 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2015-08-10 23:12:03 +0200
commit35eade30ffb915f1c190fc129f0869edf774715e (patch)
treed2664921e5f1270d0be372b39528caaf2376b022 /pkgs/applications
parent89dd33190662ed5af266535a78e4f2ddca7d920d (diff)
downloadnixlib-35eade30ffb915f1c190fc129f0869edf774715e.tar
nixlib-35eade30ffb915f1c190fc129f0869edf774715e.tar.gz
nixlib-35eade30ffb915f1c190fc129f0869edf774715e.tar.bz2
nixlib-35eade30ffb915f1c190fc129f0869edf774715e.tar.lz
nixlib-35eade30ffb915f1c190fc129f0869edf774715e.tar.xz
nixlib-35eade30ffb915f1c190fc129f0869edf774715e.tar.zst
nixlib-35eade30ffb915f1c190fc129f0869edf774715e.zip
eclipse-scala: init at 4.1.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/eclipse/plugins.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/applications/editors/eclipse/plugins.nix b/pkgs/applications/editors/eclipse/plugins.nix
index 872815395de6..cba556074a1b 100644
--- a/pkgs/applications/editors/eclipse/plugins.nix
+++ b/pkgs/applications/editors/eclipse/plugins.nix
@@ -207,6 +207,24 @@ in {
     };
   };
 
+  scala = buildEclipseUpdateSite rec {
+    name = "scala-${version}";
+    version = "4.1.0";
+
+    src = fetchzip {
+      url = "http://download.scala-ide.org/sdk/lithium/e44/scala211/stable/update-site.zip";
+      sha256 = "1z3pl88kw9qyhhsi8sqwz30c12l7zg8jiz6bz1js7jzpjbs8v70f";
+    };
+
+    meta = with stdenv.lib; {
+      homepage = "http://scala-ide.org/";
+      description = "The Scala IDE for Eclipse";
+      license = licenses.bsd3;
+      platforms = platforms.all;
+      maintainers = [ maintainers.rycee ];
+    };
+  };
+
   testng = buildEclipsePlugin rec {
     name = "testng-${version}";
     version = "6.9.5.201506120235";