about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2018-09-01 17:02:05 +0200
committerVladimír Čunát <vcunat@gmail.com>2018-09-01 17:02:15 +0200
commit342d3db703bed61a576a42a57b97c71d123371de (patch)
treeea15a504b66abc9dfc1999ed853da87c4836cded /pkgs/applications
parentcdb244a3d4355a2d8c08d1f3f9b3cef031ecc9bb (diff)
parent355f19653c367a2be81657c4b3839db3106b3562 (diff)
downloadnixlib-342d3db703bed61a576a42a57b97c71d123371de.tar
nixlib-342d3db703bed61a576a42a57b97c71d123371de.tar.gz
nixlib-342d3db703bed61a576a42a57b97c71d123371de.tar.bz2
nixlib-342d3db703bed61a576a42a57b97c71d123371de.tar.lz
nixlib-342d3db703bed61a576a42a57b97c71d123371de.tar.xz
nixlib-342d3db703bed61a576a42a57b97c71d123371de.tar.zst
nixlib-342d3db703bed61a576a42a57b97c71d123371de.zip
Merge branch 'staging-next'
The failure diff seems good-enough on Hydra now.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/octoprint/default.nix8
-rw-r--r--pkgs/applications/networking/newsreaders/pan/default.nix8
-rw-r--r--pkgs/applications/science/math/sage/default.nix10
-rw-r--r--pkgs/applications/science/math/sage/openblas-pc.nix17
-rw-r--r--pkgs/applications/science/math/sage/sage-env.nix6
-rw-r--r--pkgs/applications/science/math/sage/sage-with-env.nix6
-rw-r--r--pkgs/applications/science/math/sage/sagelib.nix7
-rw-r--r--pkgs/applications/science/molecular-dynamics/lammps/default.nix45
8 files changed, 51 insertions, 56 deletions
diff --git a/pkgs/applications/misc/octoprint/default.nix b/pkgs/applications/misc/octoprint/default.nix
index 99d23b0eb7cf..41bc94a51300 100644
--- a/pkgs/applications/misc/octoprint/default.nix
+++ b/pkgs/applications/misc/octoprint/default.nix
@@ -62,6 +62,14 @@ let
         # No tests included
         doCheck = false;
       };
+
+      pylru = super.pylru.overridePythonAttrs (oldAttrs: rec {
+        version = "1.0.9";
+        src = oldAttrs.src.override {
+          inherit version;
+          sha256 = "71376192671f0ad1690b2a7427d39a29b1df994c8469a9b46b03ed7e28c0172c";
+        };
+      });
     };
   };
 
diff --git a/pkgs/applications/networking/newsreaders/pan/default.nix b/pkgs/applications/networking/newsreaders/pan/default.nix
index 4a1940ae6545..9d51a76f5360 100644
--- a/pkgs/applications/networking/newsreaders/pan/default.nix
+++ b/pkgs/applications/networking/newsreaders/pan/default.nix
@@ -2,7 +2,7 @@
 , stdenv, fetchurl, pkgconfig, gtk3, gtkspell3 ? null
 , perl, gmime2, gettext, intltool, itstool, libxml2, dbus-glib, libnotify, gnutls
 , makeWrapper, gnupg
-, gnomeSupport ? true, libgnome-keyring3
+, gnomeSupport ? true, gnome3, libsecret
 }:
 
 assert spellChecking -> gtkspell3 != null;
@@ -17,10 +17,10 @@ stdenv.mkDerivation {
     sha256 = "1b4wamv33hprghcjk903bpvnd233yxyrm18qnh13alc8h1553nk8";
   };
 
-  nativeBuildInputs = [ pkgconfig makeWrapper ];
-  buildInputs = [ gtk3 perl gmime2 gettext intltool itstool libxml2 dbus-glib libnotify gnutls ]
+  nativeBuildInputs = [ pkgconfig gettext intltool itstool libxml2 makeWrapper ];
+  buildInputs = [ gtk3 gmime2 libnotify gnutls ]
     ++ stdenv.lib.optional spellChecking gtkspell3
-    ++ stdenv.lib.optional gnomeSupport libgnome-keyring3;
+    ++ stdenv.lib.optionals gnomeSupport [ libsecret gnome3.gcr ];
 
   configureFlags = [
     "--with-dbus"
diff --git a/pkgs/applications/science/math/sage/default.nix b/pkgs/applications/science/math/sage/default.nix
index 7e62f0cf75ee..08e3a752b8b6 100644
--- a/pkgs/applications/science/math/sage/default.nix
+++ b/pkgs/applications/science/math/sage/default.nix
@@ -21,7 +21,7 @@ let
 
       sagelib = self.callPackage ./sagelib.nix {
         inherit flint ecl arb;
-        inherit sage-src openblas-blas-pc openblas-cblas-pc openblas-lapack-pc pynac singular;
+        inherit sage-src pynac singular;
         linbox = nixpkgs.linbox.override { withSage = true; };
       };
 
@@ -41,13 +41,13 @@ let
       };
 
       sage-env = self.callPackage ./sage-env.nix {
-        inherit sage-src python rWrapper openblas-cblas-pc ecl singular palp flint pynac pythonEnv;
+        inherit sage-src python rWrapper ecl singular palp flint pynac pythonEnv;
         pkg-config = nixpkgs.pkgconfig; # not to confuse with pythonPackages.pkgconfig
       };
 
       sage-with-env = self.callPackage ./sage-with-env.nix {
         inherit pythonEnv;
-        inherit sage-src openblas-blas-pc openblas-cblas-pc openblas-lapack-pc pynac singular;
+        inherit sage-src pynac singular;
         pkg-config = nixpkgs.pkgconfig; # not to confuse with pythonPackages.pkgconfig
         three = nodePackages_8_x.three;
       };
@@ -60,10 +60,6 @@ let
     };
   };
 
-  openblas-blas-pc = callPackage ./openblas-pc.nix { name = "blas"; };
-  openblas-cblas-pc = callPackage ./openblas-pc.nix { name = "cblas"; };
-  openblas-lapack-pc = callPackage ./openblas-pc.nix { name = "lapack"; };
-
   sage-src = callPackage ./sage-src.nix {};
 
   pythonRuntimeDeps = with python.pkgs; [
diff --git a/pkgs/applications/science/math/sage/openblas-pc.nix b/pkgs/applications/science/math/sage/openblas-pc.nix
deleted file mode 100644
index f4669a6557e9..000000000000
--- a/pkgs/applications/science/math/sage/openblas-pc.nix
+++ /dev/null
@@ -1,17 +0,0 @@
-{ openblasCompat
-, writeTextFile
-, name
-}:
-
-writeTextFile {
-  name = "openblas-${name}-pc-${openblasCompat.version}";
-  destination = "/lib/pkgconfig/${name}.pc";
-  text = ''
-    Name: ${name}
-    Version: ${openblasCompat.version}
-
-    Description: ${name} for SageMath, provided by the OpenBLAS package.
-    Cflags: -I${openblasCompat}/include
-    Libs: -L${openblasCompat}/lib -lopenblas
-  '';
-}
diff --git a/pkgs/applications/science/math/sage/sage-env.nix b/pkgs/applications/science/math/sage/sage-env.nix
index 317eb6e16c49..74c2e0aa0360 100644
--- a/pkgs/applications/science/math/sage/sage-env.nix
+++ b/pkgs/applications/science/math/sage/sage-env.nix
@@ -37,7 +37,7 @@
 , lcalc
 , rubiks
 , flintqs
-, openblas-cblas-pc
+, openblasCompat
 , flint
 , gmp
 , mpfr
@@ -98,9 +98,9 @@ writeTextFile rec {
     export PKG_CONFIG_PATH='${lib.concatStringsSep ":" (map (pkg: "${pkg}/lib/pkgconfig") [
         # This is only needed in the src/sage/misc/cython.py test and I'm not sure if there's really a use-case
         # for it outside of the tests. However since singular and openblas are runtime dependencies anyways
-        # and openblas-cblas-pc is tiny, it doesn't really hurt to include.
+        # it doesn't really hurt to include.
         singular
-        openblas-cblas-pc
+        openblasCompat
       ])
     }'
     export SAGE_ROOT='${sage-src}'
diff --git a/pkgs/applications/science/math/sage/sage-with-env.nix b/pkgs/applications/science/math/sage/sage-with-env.nix
index 63b9772b8231..8ccf8b5a4938 100644
--- a/pkgs/applications/science/math/sage/sage-with-env.nix
+++ b/pkgs/applications/science/math/sage/sage-with-env.nix
@@ -4,9 +4,6 @@
 , sage-env
 , sage-src
 , openblasCompat
-, openblas-blas-pc
-, openblas-cblas-pc
-, openblas-lapack-pc
 , pkg-config
 , three
 , singular
@@ -32,9 +29,6 @@ let
     makeWrapper
     pkg-config
     openblasCompat # lots of segfaults with regular (64 bit) openblas
-    openblas-blas-pc
-    openblas-cblas-pc
-    openblas-lapack-pc
     singular
     three
     pynac
diff --git a/pkgs/applications/science/math/sage/sagelib.nix b/pkgs/applications/science/math/sage/sagelib.nix
index abcefba5e260..c1dbcf38304e 100644
--- a/pkgs/applications/science/math/sage/sagelib.nix
+++ b/pkgs/applications/science/math/sage/sagelib.nix
@@ -3,9 +3,6 @@
 , buildPythonPackage
 , arb
 , openblasCompat
-, openblas-blas-pc
-, openblas-cblas-pc
-, openblas-lapack-pc
 , brial
 , cliquer
 , cypari2
@@ -59,9 +56,7 @@ buildPythonPackage rec {
   nativeBuildInputs = [
     iml
     perl
-    openblas-blas-pc
-    openblas-cblas-pc
-    openblas-lapack-pc
+    openblasCompat
     jupyter_core
   ];
 
diff --git a/pkgs/applications/science/molecular-dynamics/lammps/default.nix b/pkgs/applications/science/molecular-dynamics/lammps/default.nix
index 9a89b88d7a52..03e37ad9d935 100644
--- a/pkgs/applications/science/molecular-dynamics/lammps/default.nix
+++ b/pkgs/applications/science/molecular-dynamics/lammps/default.nix
@@ -1,25 +1,37 @@
-{ stdenv, writeText, fetchurl,
-  libpng, fftw,
-  mpiSupport ? false, mpi ? null
+{ lib
+, bash
+, stdenv
+, writeText
+, fetchFromGitHub
+, libpng
+, gzip
+, fftw
+, openblas
+, mpiSupport ? false, mpi ? null
 }:
 
 assert mpiSupport -> mpi != null;
 
 stdenv.mkDerivation rec {
   # LAMMPS has weird versioning converted to ISO 8601 format
-  version = "2016-02-16";
+  version = "patch_2Aug2018";
   name = "lammps-${version}";
 
-  src = fetchurl {
-    url = "mirror://sourceforge/lammps/lammps-16Feb16.tar.gz";
-    sha256 = "1yzfbkxma3xa1288rnn66h4w0smbmjkwq1fx1y60pjiw0prmk105";
+  lammps_packages = "asphere body class2 colloid compress coreshell dipole granular kspace manybody mc misc molecule opt peri qeq replica rigid shock snap srd user-reaxc";
+  lammps_includes = "-DLAMMPS_EXCEPTIONS -DLAMMPS_GZIP -DLAMMPS_MEMALIGN=64";
+
+  src = fetchFromGitHub {
+    owner = "lammps";
+    repo = "lammps";
+    rev = "${version}";
+    sha256 = "1ph9pr7s11wgmspmnhxa55bh1pq2cyl8iimfi62lbpbpl9pr1ilc";
   };
 
   passthru = {
     inherit mpi;
   };
 
-  buildInputs = [ fftw libpng ]
+  buildInputs = [ fftw libpng openblas gzip bash ]
   ++ (stdenv.lib.optionals mpiSupport [ mpi ]);
 
   # Must do manual build due to LAMMPS requiring a seperate build for
@@ -27,13 +39,19 @@ stdenv.mkDerivation rec {
   builder = writeText "builder.sh" ''
     source $stdenv/setup
 
-    tar xzf $src
-    cd lammps-*/src
-    make mode=exe ${if mpiSupport then "mpi" else "serial"} SHELL=$SHELL LMP_INC="-DLAMMPS_GZIP -DLAMMPS_PNG" FFT_PATH=-DFFT_FFTW3 FFT_LIB=-lfftw3 JPG_LIB=-lpng
-    make mode=shlib ${if mpiSupport then "mpi" else "serial"} SHELL=$SHELL LMP_INC="-DLAMMPS_GZIP -DLAMMPS_PNG" FFT_PATH=-DFFT_FFTW3 FFT_LIB=-lfftw3 JPG_LIB=-lpng
+    mkdir lammps
+    cp -r $src/lib $src/src lammps
+    chmod -R 755 lammps/src/
+    cd lammps/src
+    for pack in ${lammps_packages}; do make "yes-$pack" SHELL=$SHELL; done
+    make mode=exe ${if mpiSupport then "mpi" else "serial"} SHELL=$SHELL LMP_INC="${lammps_includes}" FFT_PATH=-DFFT_FFTW3 FFT_LIB=-lfftw3 JPG_LIB=-lpng
+    make mode=shlib ${if mpiSupport then "mpi" else "serial"} SHELL=$SHELL LMP_INC="${lammps_includes}" FFT_PATH=-DFFT_FFTW3 FFT_LIB=-lfftw3 JPG_LIB=-lpng
 
     mkdir -p $out/bin
-    cp -v lmp_* $out/bin/lammps
+    cp -v lmp_* $out/bin/
+
+    mkdir -p $out/include
+    cp -v *.h $out/include/
 
     mkdir -p $out/lib
     cp -v liblammps* $out/lib/
@@ -51,5 +69,6 @@ stdenv.mkDerivation rec {
     homepage = http://lammps.sandia.gov;
     license = stdenv.lib.licenses.gpl2;
     platforms = stdenv.lib.platforms.linux;
+    maintainers = with lib.maintainers; [ costrouc ];
   };
 }