about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
author_1126 <mail@elfsechsundzwanzig.de>2014-07-17 13:47:37 +0200
committer_1126 <mail@elfsechsundzwanzig.de>2014-07-17 13:47:37 +0200
commit33e9f3192d2c0307018c13a7f79d6e413ba7c50e (patch)
tree3d7f5f33141353ef1bf4f3c48a24056c1e7de3fd /pkgs/applications
parent3fee3c05b183a500f307cf359a29ea772be7b016 (diff)
parentb4c971b14a7e46a7e96cd42e4fe790b2531a2d65 (diff)
downloadnixlib-33e9f3192d2c0307018c13a7f79d6e413ba7c50e.tar
nixlib-33e9f3192d2c0307018c13a7f79d6e413ba7c50e.tar.gz
nixlib-33e9f3192d2c0307018c13a7f79d6e413ba7c50e.tar.bz2
nixlib-33e9f3192d2c0307018c13a7f79d6e413ba7c50e.tar.lz
nixlib-33e9f3192d2c0307018c13a7f79d6e413ba7c50e.tar.xz
nixlib-33e9f3192d2c0307018c13a7f79d6e413ba7c50e.tar.zst
nixlib-33e9f3192d2c0307018c13a7f79d6e413ba7c50e.zip
Merge remote-tracking branch 'upstream/master'
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-modes/org/default.nix4
-rw-r--r--pkgs/applications/editors/lighttable/default.nix58
-rw-r--r--pkgs/applications/editors/vim/configurable.nix46
-rw-r--r--pkgs/applications/editors/vim/default.nix6
-rw-r--r--pkgs/applications/editors/vim/wrapper.nix32
-rw-r--r--pkgs/applications/editors/yi/yi-contrib.nix2
-rw-r--r--pkgs/applications/graphics/hoodle/default.nix7
-rw-r--r--pkgs/applications/misc/arbtt/default.nix2
-rw-r--r--pkgs/applications/misc/blender/default.nix25
-rw-r--r--pkgs/applications/misc/finalterm/default.nix60
-rw-r--r--pkgs/applications/misc/nc-indicators/default.nix2
-rw-r--r--pkgs/applications/misc/taffybar/default.nix2
-rw-r--r--pkgs/applications/misc/xmobar/default.nix2
-rw-r--r--pkgs/applications/misc/yeganesh/default.nix2
-rw-r--r--pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-11/default.nix6
-rw-r--r--pkgs/applications/office/hledger-interest/default.nix2
-rw-r--r--pkgs/applications/office/hledger-irr/default.nix2
-rw-r--r--pkgs/applications/science/math/sloane/default.nix2
-rw-r--r--pkgs/applications/version-management/darcs/default.nix8
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-annex/default.nix18
-rw-r--r--pkgs/applications/version-management/git-and-tools/github-backup/default.nix11
-rw-r--r--pkgs/applications/window-managers/xmonad/default.nix4
-rw-r--r--pkgs/applications/window-managers/xmonad/xmonad-contrib.nix2
-rw-r--r--pkgs/applications/window-managers/xmonad/xmonad-extras.nix2
24 files changed, 231 insertions, 76 deletions
diff --git a/pkgs/applications/editors/emacs-modes/org/default.nix b/pkgs/applications/editors/emacs-modes/org/default.nix
index e52011547c7a..ba2437f1a2b8 100644
--- a/pkgs/applications/editors/emacs-modes/org/default.nix
+++ b/pkgs/applications/editors/emacs-modes/org/default.nix
@@ -2,11 +2,11 @@
 , texLiveAggregationFun }:
 
 stdenv.mkDerivation rec {
-  name = "org-8.2.7";
+  name = "org-8.2.7b";
 
   src = fetchurl {
     url = "http://orgmode.org/${name}.tar.gz";
-    sha256 = "1n864hnjvx5n2gfi7n0xbwvb1k8l5rdh4a3vpbhw23hy8rx3bvaw";
+    sha256 = "07hq2q126d967nj7xq46q4mkca5r2rw61bn8d6nzkhksghp8b2v1";
   };
 
   buildInputs = [ emacs ];
diff --git a/pkgs/applications/editors/lighttable/default.nix b/pkgs/applications/editors/lighttable/default.nix
new file mode 100644
index 000000000000..b5ab1950e2b6
--- /dev/null
+++ b/pkgs/applications/editors/lighttable/default.nix
@@ -0,0 +1,58 @@
+{ stdenv, fetchurl, buildEnv, makeDesktopItem, makeWrapper, zlib, glib, alsaLib
+, dbus, gtk, atk, pango, freetype, fontconfig, libgnome_keyring3, gdk_pixbuf
+, cairo, cups, expat, libgpgerror, nspr, gnome3, nss, xlibs, udev
+}:
+
+let
+  libPath = stdenv.lib.makeLibraryPath [
+      stdenv.gcc.gcc zlib glib dbus gtk atk pango freetype libgnome_keyring3 nss
+      fontconfig gdk_pixbuf cairo cups expat libgpgerror alsaLib nspr gnome3.gconf
+      xlibs.libXrender xlibs.libX11 xlibs.libXext xlibs.libXdamage xlibs.libXtst
+      xlibs.libXcomposite xlibs.libXi xlibs.libXfixes
+];
+in
+assert stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux";
+
+stdenv.mkDerivation rec {
+  name = "LightTable-${version}";
+  version = "0.6.7";
+
+  src = 
+    if stdenv.system == "i686-linux" then
+      fetchurl {
+        name = "LightTableLinux.tar.gz";
+        url = https://d35ac8ww5dfjyg.cloudfront.net/playground/bins/0.6.7/LightTableLinux.tar.gz;
+        sha256 = "3b09f9665ed1b4abb7c1ca16286ac7222caf6dc124059be6db4cb9f5fd041e73";
+      }
+    else
+      fetchurl {
+        name = "LightTableLinux64.tar.gz";
+        url = https://d35ac8ww5dfjyg.cloudfront.net/playground/bins/0.6.7/LightTableLinux64.tar.gz;
+        sha256 = "710d670ccc30aadba521ccb723388679ee6404aac662297a005432c811d59e82";
+      };
+
+  buildInputs = [ makeWrapper ];
+  phases = [ "installPhase" ];
+
+  installPhase = ''
+    tar xvf ${src}
+    mkdir -p $out/bin
+    mv LightTable $out/
+
+    patchelf \
+      --interpreter "$(cat $NIX_GCC/nix-support/dynamic-linker)" \
+      --set-rpath ${libPath}:${stdenv.gcc.gcc}/lib${stdenv.lib.optionalString stdenv.is64bit "64"} \
+      $out/LightTable/ltbin
+
+    ln -s ${udev}/lib/libudev.so.1 $out/LightTable/libudev.so.0
+
+    makeWrapper $out/LightTable/ltbin $out/bin/lighttable \
+      --prefix "LD_LIBRARY_PATH" : $out/LightTable
+  '';
+
+  meta = with stdenv.lib; {
+    description = "the next generation code editor";
+    homepage = http://www.lighttable.com/;
+    license = [ licenses.gpl3 ];
+  };
+}
diff --git a/pkgs/applications/editors/vim/configurable.nix b/pkgs/applications/editors/vim/configurable.nix
index e0d8de157b09..710ceb7d31f1 100644
--- a/pkgs/applications/editors/vim/configurable.nix
+++ b/pkgs/applications/editors/vim/configurable.nix
@@ -1,9 +1,35 @@
 # TODO tidy up eg The patchelf code is patching gvim even if you don't build it..
 # but I have gvim with python support now :) - Marc
-args@{source ? "default", ...}: with args;
-
-
-let inherit (args.composableDerivation) composableDerivation edf; in
+args@{pkgs, source ? "default", ...}: with args;
+
+
+let inherit (args.composableDerivation) composableDerivation edf;
+  nixosRuntimepath = pkgs.writeText "nixos-vimrc" ''
+    set nocompatible
+    syntax on
+
+    function! NixosPluginPath()
+      let seen = {}
+      for p in reverse(split($NIX_PROFILES))
+        for d in split(glob(p . '/share/vim-plugins/*'))
+          let pluginname = substitute(d, ".*/", "", "")
+          if !has_key(seen, pluginname)
+            exec 'set runtimepath^='.d
+            let seen[pluginname] = 1
+          endif
+        endfor
+      endfor
+    endfunction
+
+    execute NixosPluginPath()
+
+    if filereadable("/etc/vimrc")
+      source /etc/vimrc
+    elseif filereadable("/etc/vim/vimrc")
+      source /etc/vim/vimrc
+    endif
+  '';
+in
 composableDerivation {
   # use gccApple to compile on darwin
   mkDerivation = ( if stdenv.isDarwin
@@ -11,18 +37,18 @@ composableDerivation {
                    else stdenv ).mkDerivation;
 } (fix: {
 
-    name = "vim_configurable-7.4.316";
+    name = "vim_configurable-7.4.335";
 
     enableParallelBuilding = true; # test this
 
-    src = 
+    src =
       builtins.getAttr source {
       "default" =
         # latest release
       args.fetchhg {
             url = "https://vim.googlecode.com/hg/";
-            rev = "v7-4-316";
-            sha256 = "0scxx33p1ky0wihk04xqpd6rygp1crm0hx446zbjwbsjj6xxn7sx";
+            rev = "v7-4-335";
+            sha256 = "0qnpzfcbi6fhz82pj68l4vrnigca1akq2ksrxz6krwlfhns6jhhj";
       };
 
       "vim-nox" =
@@ -39,7 +65,7 @@ composableDerivation {
 
     # if darwin support is enabled, we want to make sure we're not building with
     # OS-installed python framework
-    patches = stdenv.lib.optionals 
+    patches = stdenv.lib.optionals
       (stdenv.isDarwin && (config.vim.darwin or true))
       [ ./python_framework.patch ];
 
@@ -145,6 +171,8 @@ composableDerivation {
     echo $nativeBuildInputs
     echo $rpath
     patchelf --set-rpath $rpath $out/bin/{vim,gvim}
+
+    ln -sfn ${nixosRuntimepath} $out/share/vim/vimrc
   '';
 
   dontStrip = 1;
diff --git a/pkgs/applications/editors/vim/default.nix b/pkgs/applications/editors/vim/default.nix
index bf9472801731..95f654eb8cac 100644
--- a/pkgs/applications/editors/vim/default.nix
+++ b/pkgs/applications/editors/vim/default.nix
@@ -3,12 +3,12 @@
 stdenv.mkDerivation rec {
   name = "vim-${version}";
 
-  version = "7.4.316";
+  version = "7.4.335";
 
   src = fetchhg {
     url = "https://vim.googlecode.com/hg/";
-    rev = "v7-4-316";
-    sha256 = "0scxx33p1ky0wihk04xqpd6rygp1crm0hx446zbjwbsjj6xxn7sx";
+    rev = "v7-4-335";
+    sha256 = "0qnpzfcbi6fhz82pj68l4vrnigca1akq2ksrxz6krwlfhns6jhhj";
   };
 
   enableParallelBuilding = true;
diff --git a/pkgs/applications/editors/vim/wrapper.nix b/pkgs/applications/editors/vim/wrapper.nix
deleted file mode 100644
index 72e868050537..000000000000
--- a/pkgs/applications/editors/vim/wrapper.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ stdenv, makeWrapper, writeText, vim, vimrc }:
-
-let
-
-  vimrcfile = writeText "vimrc" vimrc;
-
-  p = builtins.parseDrvName vim.name;
-
-in stdenv.mkDerivation rec {
-  name = "${p.name}-with-vimrc-${p.version}";
-
-  buildInputs = [ makeWrapper vim vimrcfile ];
-
-  phases = [ "installPhase" ];
-
-  installPhase = ''
-    mkdir -p $out
-    cp -r ${vim}/* $out/
-
-    chmod u+w $out/bin
-    chmod u+w $out/share/vim
-
-    ln -s ${vimrcfile} $out/share/vim/vimrc
-    wrapProgram $out/bin/vim --set VIM "$out/share/vim"
-  '';
-
-  meta = with stdenv.lib; {
-    description = "The most popular clone of the VI editor";
-    homepage    = http://www.vim.org;
-    platforms   = platforms.unix;
-  };
-}
diff --git a/pkgs/applications/editors/yi/yi-contrib.nix b/pkgs/applications/editors/yi/yi-contrib.nix
index c7d3f0940164..14231e03582e 100644
--- a/pkgs/applications/editors/yi/yi-contrib.nix
+++ b/pkgs/applications/editors/yi/yi-contrib.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, filepath, lens, mtl, split, time, transformersBase, yi }:
 
 cabal.mkDerivation (self: {
diff --git a/pkgs/applications/graphics/hoodle/default.nix b/pkgs/applications/graphics/hoodle/default.nix
index e553875f756c..8223b2c5ad90 100644
--- a/pkgs/applications/graphics/hoodle/default.nix
+++ b/pkgs/applications/graphics/hoodle/default.nix
@@ -1,15 +1,16 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, cmdargs, configurator, dyre, filepath, hoodleCore, mtl }:
 
 cabal.mkDerivation (self: {
   pname = "hoodle";
-  version = "0.2.2.1";
-  sha256 = "1qkyyzfmprhniwarnq6cdmv1r6605b3h2lsc1rlalxhq6jh5gamd";
+  version = "0.3";
+  sha256 = "01wz7bwdr3i43ikaiaq8vpn6b0clxjnjyaw6nl6zaq489dhj6fv5";
   isLibrary = true;
   isExecutable = true;
   buildDepends = [
     cmdargs configurator dyre filepath hoodleCore mtl
   ];
-  jailbreak = true;
   meta = {
     homepage = "http://ianwookim.org/hoodle";
     description = "Executable for hoodle";
diff --git a/pkgs/applications/misc/arbtt/default.nix b/pkgs/applications/misc/arbtt/default.nix
index 91053e57f12e..0c3939b5c256 100644
--- a/pkgs/applications/misc/arbtt/default.nix
+++ b/pkgs/applications/misc/arbtt/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, aeson, binary, bytestringProgress, deepseq, filepath
 , HUnit, libXScrnSaver, parsec, pcreLight, processExtras, strict
 , tasty, tastyGolden, tastyHunit, terminalProgressBar, time
diff --git a/pkgs/applications/misc/blender/default.nix b/pkgs/applications/misc/blender/default.nix
index 930a48a617fd..c6a6fa7861ca 100644
--- a/pkgs/applications/misc/blender/default.nix
+++ b/pkgs/applications/misc/blender/default.nix
@@ -1,27 +1,35 @@
-{ stdenv, fetchurl, SDL, boost, cmake, ffmpeg, gettext, glew
+{ stdenv, lib, fetchurl, SDL, boost, cmake, ffmpeg, gettext, glew
 , ilmbase, libXi, libjpeg, libpng, libsamplerate, libsndfile
 , libtiff, mesa, openal, opencolorio, openexr, openimageio, openjpeg, python
-, zlib
+, zlib, fftw
 , jackaudioSupport ? false, jackaudio
 }:
 
+with lib;
+
 stdenv.mkDerivation rec {
-  name = "blender-2.70a";
+  name = "blender-2.71";
 
   src = fetchurl {
     url = "http://download.blender.org/source/${name}.tar.gz";
-    sha256 = "1rgkijn1nirj3jwh058zv6piw8q4j5wwjapgbvh2hh6fpbj84bgb";
+    sha256 = "18pzcnrs4rcb6mf6aqr9xj2r05v8aay8daj31395ljfzw667zakx";
   };
 
   buildInputs =
-    [ SDL boost cmake ffmpeg gettext glew ilmbase jackaudio libXi
+    [ SDL boost cmake ffmpeg gettext glew ilmbase libXi
       libjpeg libpng libsamplerate libsndfile libtiff mesa openal
-      opencolorio openexr openimageio openjpeg python zlib
-    ] ++ stdenv.lib.optional jackaudioSupport jackaudio;
+      opencolorio openexr openimageio /* openjpeg */ python zlib fftw
+    ] ++ optional jackaudioSupport jackaudio;
+
+  postUnpack =
+    ''
+      substituteInPlace */doc/manpage/blender.1.py --replace /usr/bin/python ${python}/bin/python3
+    '';
 
   cmakeFlags =
     [ "-DOPENEXR_INC=${openexr}/include/OpenEXR"
       "-DWITH_OPENCOLLADA=OFF"
+      "-DWITH_MOD_OCEANSIM=ON"
       "-DWITH_CODEC_FFMPEG=ON"
       "-DWITH_CODEC_SNDFILE=ON"
       "-DWITH_INSTALL_PORTABLE=OFF"
@@ -29,7 +37,8 @@ stdenv.mkDerivation rec {
       "-DPYTHON_LIBPATH=${python}/lib"
       "-DPYTHON_INCLUDE_DIR=${python}/include/python${python.majorVersion}m"
       "-DPYTHON_VERSION=${python.majorVersion}"
-    ] ++ stdenv.lib.optional jackaudioSupport "-DWITH_JACK=ON";
+    ]
+    ++ optional jackaudioSupport "-DWITH_JACK=ON";
 
   NIX_CFLAGS_COMPILE = "-I${ilmbase}/include/OpenEXR -I${python}/include/${python.libPrefix}m";
 
diff --git a/pkgs/applications/misc/finalterm/default.nix b/pkgs/applications/misc/finalterm/default.nix
new file mode 100644
index 000000000000..0c084f9d018c
--- /dev/null
+++ b/pkgs/applications/misc/finalterm/default.nix
@@ -0,0 +1,60 @@
+{ stdenv, lib, fetchFromGitHub, makeWrapper
+, pkgconfig, cmake, libxml2, vala, intltool, libmx, gnome3, gtk3, gtk_doc
+, keybinder3, clutter_gtk, libnotify
+, libxkbcommon, xlibs, udev
+, bashInteractive
+}:
+
+let rev = "5ccde4e8f2c02a398f9172e07c25262ecf954626";
+in stdenv.mkDerivation {
+  name = "finalterm-git-${builtins.substring 0 8 rev}";
+
+  src = fetchFromGitHub {
+    owner = "p-e-w";
+    repo = "finalterm";
+    inherit rev;
+    sha256 = "1gw6nc19whfjd4xj0lc0fmjypn8d7nasif79671859ymnfizyq4f";
+  };
+
+  buildInputs = [
+    pkgconfig cmake vala intltool gtk3 gnome3.gnome_common gnome3.libgee
+    gtk_doc clutter_gtk libmx keybinder3 libxml2 libnotify makeWrapper
+    xlibs.libpthreadstubs xlibs.libXdmcp xlibs.libxshmfence
+    libxkbcommon
+  ] ++ lib.optionals stdenv.isLinux [
+    udev
+  ];
+
+  preConfigure = ''
+    substituteInPlace data/org.gnome.finalterm.gschema.xml \
+      --replace "/bin/bash" "${bashInteractive}/bin/bash"
+
+    cmakeFlagsArray=(
+      -DMINIMAL_FLAGS=ON
+    )
+  '';
+
+  postFixup = ''
+    wrapProgram "$out/bin/finalterm" \
+      --prefix GI_TYPELIB_PATH : "$GI_TYPELIB_PATH" \
+      --prefix GIO_EXTRA_MODULES : "${gnome3.dconf}/lib/gio/modules" \
+      --prefix XDG_DATA_DIRS : "${gnome3.gnome_icon_theme}/share:${gnome3.gtk}/share:$out/share:$GSETTINGS_SCHEMAS_PATH"
+  '';
+
+  meta = with lib; {
+    homepage = "http://finalterm.org";
+    description = "A new breed of terminal emulator";
+    longDescription = ''
+      Final Term is a new breed of terminal emulator.
+
+      It goes beyond mere emulation and understands what is happening inside the shell it is hosting. This allows it to offer features no other terminal can, including:
+
+      - Semantic text menus
+      - Smart command completion
+      - GUI terminal controls
+    '';
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ cstrahan ];
+    platforms = with platforms; linux;
+  };
+}
diff --git a/pkgs/applications/misc/nc-indicators/default.nix b/pkgs/applications/misc/nc-indicators/default.nix
index e3a1708326cd..026485c771b3 100644
--- a/pkgs/applications/misc/nc-indicators/default.nix
+++ b/pkgs/applications/misc/nc-indicators/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, attoparsec, gtk, hflags, lens, pipes, stm }:
 
 cabal.mkDerivation (self: {
diff --git a/pkgs/applications/misc/taffybar/default.nix b/pkgs/applications/misc/taffybar/default.nix
index a92e7e32f048..d2e7d84e3144 100644
--- a/pkgs/applications/misc/taffybar/default.nix
+++ b/pkgs/applications/misc/taffybar/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, cairo, dbus, dyre, filepath, gtk, gtkTraymanager
 , HStringTemplate, HTTP, mtl, network, parsec, split, stm, text
 , time, transformers, utf8String, X11, xdgBasedir, xmonad
diff --git a/pkgs/applications/misc/xmobar/default.nix b/pkgs/applications/misc/xmobar/default.nix
index 5cb8fc0fd943..7bd405f90a03 100644
--- a/pkgs/applications/misc/xmobar/default.nix
+++ b/pkgs/applications/misc/xmobar/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, alsaCore, alsaMixer, dbus, filepath, hinotify, HTTP
 , libmpd, libXrandr, mtl, parsec, regexCompat, stm, time
 , timezoneOlson, timezoneSeries, utf8String, wirelesstools, X11
diff --git a/pkgs/applications/misc/yeganesh/default.nix b/pkgs/applications/misc/yeganesh/default.nix
index 36a5817772d5..f26d315fce2c 100644
--- a/pkgs/applications/misc/yeganesh/default.nix
+++ b/pkgs/applications/misc/yeganesh/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, filepath, strict, time, xdgBasedir }:
 
 cabal.mkDerivation (self: {
diff --git a/pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-11/default.nix b/pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-11/default.nix
index 438a53b4f8a3..617d307b7835 100644
--- a/pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-11/default.nix
+++ b/pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-11/default.nix
@@ -36,7 +36,7 @@
 
 let
   # -> http://get.adobe.com/flashplayer/
-  version = "11.2.202.378";
+  version = "11.2.202.394";
 
   src =
     if stdenv.system == "x86_64-linux" then
@@ -47,7 +47,7 @@ let
       else rec {
         inherit version;
         url = "http://fpdownload.macromedia.com/get/flashplayer/pdc/${version}/install_flash_player_11_linux.x86_64.tar.gz";
-        sha256 = "08aw532k8y27s64ffdghz2k4zf0jsz65crvn3i9vxan29064la9c";
+        sha256 = "1w82kmda91xdsrqpkrbcbrzswnbfszy0x9hvf9wf2h14isimdknx";
       }
     else if stdenv.system == "i686-linux" then
       if debug then {
@@ -58,7 +58,7 @@ let
       } else rec {
         inherit version;
         url = "http://fpdownload.macromedia.com/get/flashplayer/pdc/${version}/install_flash_player_11_linux.i386.tar.gz";
-        sha256 = "1njy2pnhgr2hjz6kp9vl4cgxxszw2k6gmhjz88hx92aijv7s93wz";
+        sha256 = "0c8wp4qn6k224krihxb08g7727wlklk9bl4h7nqp3cpp85x9hg97";
       }
     else throw "Flash Player is not supported on this platform";
 
diff --git a/pkgs/applications/office/hledger-interest/default.nix b/pkgs/applications/office/hledger-interest/default.nix
index d53a8fe63e29..9c0672e2ee0c 100644
--- a/pkgs/applications/office/hledger-interest/default.nix
+++ b/pkgs/applications/office/hledger-interest/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, Cabal, hledgerLib, mtl, time }:
 
 cabal.mkDerivation (self: {
diff --git a/pkgs/applications/office/hledger-irr/default.nix b/pkgs/applications/office/hledger-irr/default.nix
index 303c64863812..e7ca2a6462b1 100644
--- a/pkgs/applications/office/hledger-irr/default.nix
+++ b/pkgs/applications/office/hledger-irr/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, Cabal, hledgerLib, statistics, time }:
 
 cabal.mkDerivation (self: {
diff --git a/pkgs/applications/science/math/sloane/default.nix b/pkgs/applications/science/math/sloane/default.nix
index bf2cf32d6465..72c2028e63c9 100644
--- a/pkgs/applications/science/math/sloane/default.nix
+++ b/pkgs/applications/science/math/sloane/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, ansiTerminal, filepath, HTTP, network, optparseApplicative
 , terminalSize, text, time, zlib
 }:
diff --git a/pkgs/applications/version-management/darcs/default.nix b/pkgs/applications/version-management/darcs/default.nix
index b564242c9467..d53b38c28c32 100644
--- a/pkgs/applications/version-management/darcs/default.nix
+++ b/pkgs/applications/version-management/darcs/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, curl, extensibleExceptions, filepath, hashedStorage
 , haskeline, html, HTTP, mmap, mtl, network, parsec, random
 , regexCompat, tar, terminfo, text, utf8String, vector, zlib
@@ -15,15 +17,15 @@ cabal.mkDerivation (self: {
     utf8String vector zlib
   ];
   extraLibraries = [ curl ];
+  jailbreak = true;
   doCheck = false;
   postInstall = ''
     mkdir -p $out/etc/bash_completion.d
     mv contrib/darcs_completion $out/etc/bash_completion.d/darcs
   '';
-  jailbreak = true;
   meta = {
-    homepage = http://darcs.net/;
-    description = "A distributed, interactive, smart revision control system";
+    homepage = "http://darcs.net/";
+    description = "a distributed, interactive, smart revision control system";
     license = "GPL";
     platforms = self.ghc.meta.platforms;
     maintainers = [ self.stdenv.lib.maintainers.andres ];
diff --git a/pkgs/applications/version-management/git-and-tools/git-annex/default.nix b/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
index 59bcda0c29ea..0983ca913865 100644
--- a/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, aeson, async, blazeBuilder, bloomfilter, bup, byteable
 , caseInsensitive, clientsession, cryptoApi, cryptohash, curl
 , dataDefault, dataenc, DAV, dbus, dlist, dns, editDistance
@@ -10,13 +12,14 @@
 , SHA, shakespeare, stm, tasty, tastyHunit, tastyQuickcheck
 , tastyRerun, text, time, transformers, unixCompat, utf8String
 , uuid, wai, waiExtra, warp, warpTls, which, xmlTypes, yesod
-, yesodCore, yesodDefault, yesodForm, yesodStatic, fsnotify
+, yesodCore, yesodDefault, yesodForm, yesodStatic
+, fsnotify
 }:
 
 cabal.mkDerivation (self: {
   pname = "git-annex";
-  version = "5.20140707";
-  sha256 = "1m78125w6mq532ngfksrwj3s43qj7wyp756f6qxcqg1cl71xh34k";
+  version = "5.20140709";
+  sha256 = "0n636b52199kj8w3awfvrabg6c76kb133gbfh9r8sp0xrg376z2s";
   isLibrary = false;
   isExecutable = true;
   buildDepends = [
@@ -31,13 +34,14 @@ cabal.mkDerivation (self: {
     tastyRerun text time transformers unixCompat utf8String uuid wai
     waiExtra warp warpTls xmlTypes yesod yesodCore yesodDefault
     yesodForm yesodStatic
-  ] ++ (if (!self.stdenv.isDarwin) then [
-    dbus fdoNotify hinotify
-  ] else [
+  ] ++ (if self.stdenv.isDarwin then [
     fsnotify
+  ] else [
+    dbus fdoNotify hinotify
   ]);
   buildTools = [ bup curl git gnupg1 lsof openssh perl rsync which ];
-  configureFlags = "-fAssistant -fProduction";
+  configureFlags = "-fAssistant
+                    -fProduction";
   preConfigure = ''
     export HOME="$NIX_BUILD_TOP/tmp"
     mkdir "$HOME"
diff --git a/pkgs/applications/version-management/git-and-tools/github-backup/default.nix b/pkgs/applications/version-management/git-and-tools/github-backup/default.nix
index e7501baf9b41..f9d43037f6a1 100644
--- a/pkgs/applications/version-management/git-and-tools/github-backup/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/github-backup/default.nix
@@ -1,16 +1,19 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, extensibleExceptions, filepath, git, github, hslogger
-, IfElse, MissingH, mtl, network, prettyShow, text, unixCompat
+, IfElse, MissingH, mtl, network, optparseApplicative, prettyShow
+, text, unixCompat
 }:
 
 cabal.mkDerivation (self: {
   pname = "github-backup";
-  version = "1.20131203";
-  sha256 = "0156g7zbqsp58g8hniqsilyc79sam7plwhn3w56wbzf8m380mwba";
+  version = "1.20140707";
+  sha256 = "0c15gq91c36xza7yiimqvgk609p9xf9jlzy9683d9p9bx1khpadd";
   isLibrary = false;
   isExecutable = true;
   buildDepends = [
     extensibleExceptions filepath github hslogger IfElse MissingH mtl
-    network prettyShow text unixCompat
+    network optparseApplicative prettyShow text unixCompat
   ];
   buildTools = [ git ];
   meta = {
diff --git a/pkgs/applications/window-managers/xmonad/default.nix b/pkgs/applications/window-managers/xmonad/default.nix
index c80c8f1c9db0..08b85a5530fd 100644
--- a/pkgs/applications/window-managers/xmonad/default.nix
+++ b/pkgs/applications/window-managers/xmonad/default.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, extensibleExceptions, filepath, mtl, utf8String, X11 }:
 
 cabal.mkDerivation (self: {
@@ -14,12 +16,10 @@ cabal.mkDerivation (self: {
     mkdir -p $out/share/man/man1
     mv "$out/"**"/man/"*.1 $out/share/man/man1/
   '';
-
   patches = [
     # Patch to make xmonad use XMONAD_{GHC,XMESSAGE} (if available).
     ./xmonad_ghc_var_0.11.patch
   ];
-
   meta = {
     homepage = "http://xmonad.org";
     description = "A tiling window manager";
diff --git a/pkgs/applications/window-managers/xmonad/xmonad-contrib.nix b/pkgs/applications/window-managers/xmonad/xmonad-contrib.nix
index ca2e9e34e141..48b0cf417f08 100644
--- a/pkgs/applications/window-managers/xmonad/xmonad-contrib.nix
+++ b/pkgs/applications/window-managers/xmonad/xmonad-contrib.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, extensibleExceptions, mtl, random, utf8String, X11, X11Xft
 , xmonad
 }:
diff --git a/pkgs/applications/window-managers/xmonad/xmonad-extras.nix b/pkgs/applications/window-managers/xmonad/xmonad-extras.nix
index 1976e393baad..b64cc244d651 100644
--- a/pkgs/applications/window-managers/xmonad/xmonad-extras.nix
+++ b/pkgs/applications/window-managers/xmonad/xmonad-extras.nix
@@ -1,3 +1,5 @@
+# This file was auto-generated by cabal2nix. Please do NOT edit manually!
+
 { cabal, hint, libmpd, mtl, network, parsec, random, regexPosix
 , split, X11, xmonad, xmonadContrib
 }: