about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2018-02-18 16:25:27 -0500
committerShea Levy <shea@shealevy.com>2018-02-18 16:27:22 -0500
commit32ce7012f0ec479be27c81ab7ce64dca66a2d9e3 (patch)
tree0b69e0bd2d4aad0f3c37d4ba1ec2d67176e35df8 /pkgs/applications
parentba5563b5bc8ef8514a53e73e58ca5b9fd07fdfdf (diff)
parenta96886863a0616f528b4cfe17faf182cb29d3a03 (diff)
downloadnixlib-32ce7012f0ec479be27c81ab7ce64dca66a2d9e3.tar
nixlib-32ce7012f0ec479be27c81ab7ce64dca66a2d9e3.tar.gz
nixlib-32ce7012f0ec479be27c81ab7ce64dca66a2d9e3.tar.bz2
nixlib-32ce7012f0ec479be27c81ab7ce64dca66a2d9e3.tar.lz
nixlib-32ce7012f0ec479be27c81ab7ce64dca66a2d9e3.tar.xz
nixlib-32ce7012f0ec479be27c81ab7ce64dca66a2d9e3.tar.zst
nixlib-32ce7012f0ec479be27c81ab7ce64dca66a2d9e3.zip
Merge branch 'master' into gcc-7
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/octoprint/default.nix7
-rw-r--r--pkgs/applications/misc/redshift/default.nix5
-rw-r--r--pkgs/applications/networking/browsers/palemoon/default.nix18
-rw-r--r--pkgs/applications/networking/newsreaders/liferea/default.nix1
-rw-r--r--pkgs/applications/virtualization/qemu/default.nix6
-rw-r--r--pkgs/applications/virtualization/qemu/riscv.nix20
-rw-r--r--pkgs/applications/virtualization/qemu/statfs-flags.patch200
-rw-r--r--pkgs/applications/virtualization/xen/4.8.nix8
-rw-r--r--pkgs/applications/virtualization/xen/packages.nix4
9 files changed, 246 insertions, 23 deletions
diff --git a/pkgs/applications/misc/octoprint/default.nix b/pkgs/applications/misc/octoprint/default.nix
index 972fbfb7b072..6587305a770f 100644
--- a/pkgs/applications/misc/octoprint/default.nix
+++ b/pkgs/applications/misc/octoprint/default.nix
@@ -54,14 +54,13 @@ let
 
 in pythonPackages.buildPythonApplication rec {
   name = "OctoPrint-${version}";
-  version = "1.3.5";
-  # 1.3.5, 2017-10-16, 77753ca02602d3a798d6b0a22535e6fd69ff448a
+  version = "1.3.6";
 
   src = fetchFromGitHub {
     owner = "foosel";
     repo = "OctoPrint";
     rev = version;
-    sha256 = "13krv9i6gm4jn4cb327q4qma4xwwashjnc0dia8vlnbjbbvkrni4";
+    sha256 = "0pgpkjw5zjnks5bky51gjaksq8mhrzkl52kpgf799hl35pd08xr3";
   };
 
   # We need old Tornado
@@ -70,7 +69,7 @@ in pythonPackages.buildPythonApplication rec {
     semantic-version flask_principal werkzeug flaskbabel tornado
     psutil pyserial flask_login netaddr markdown sockjs-tornado
     pylru pyyaml sarge feedparser netifaces click websocket_client
-    scandir chainmap future dateutil futures wrapt
+    scandir chainmap future dateutil futures wrapt monotonic emoji
   ];
 
   buildInputs = with pythonPackages; [ nose mock ddt ];
diff --git a/pkgs/applications/misc/redshift/default.nix b/pkgs/applications/misc/redshift/default.nix
index 9871c559523c..c0e481ae8788 100644
--- a/pkgs/applications/misc/redshift/default.nix
+++ b/pkgs/applications/misc/redshift/default.nix
@@ -41,7 +41,10 @@ stdenv.mkDerivation rec {
   pythonPath = [ pygobject3 pyxdg ];
 
   preConfigure = "./bootstrap";
-  postFixup = "wrapPythonPrograms";
+  postFixup = ''
+    wrapPythonPrograms
+    rm "$out/share/icons/hicolor/icon-theme.cache"
+  '';
 
   enableParallelBuilding = true;
 
diff --git a/pkgs/applications/networking/browsers/palemoon/default.nix b/pkgs/applications/networking/browsers/palemoon/default.nix
index 006aa88f363c..cd4f95097889 100644
--- a/pkgs/applications/networking/browsers/palemoon/default.nix
+++ b/pkgs/applications/networking/browsers/palemoon/default.nix
@@ -10,14 +10,14 @@
 
 stdenv.mkDerivation rec {
   name = "palemoon-${version}";
-  version = "27.6.2";
+  version = "27.7.2";
 
   src = fetchFromGitHub {
     name   = "palemoon-src";
     owner  = "MoonchildProductions";
     repo   = "Pale-Moon";
     rev    = version + "_Release";
-    sha256 = "0ickxrwl36iyqj3v9qq6hnfl2y652f2ppwi949pfh4f6shm9x0ri";
+    sha256 = "19ki6gp6bhcvhjnclalviiyp93mqsgc22xjl0gm9x5y4sxdb5wlq";
   };
 
   desktopItem = makeDesktopItem {
@@ -101,10 +101,20 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "A web browser";
+    longDescription = ''
+      Pale Moon is an Open Source, Goanna-based web browser focusing on
+      efficiency and customization.
+
+      Pale Moon offers you a browsing experience in a browser completely built
+      from its own, independently developed source that has been forked off from
+      Firefox/Mozilla code a number of years ago, with carefully selected
+      features and optimizations to improve the browser's stability and user
+      experience, while offering full customization and a growing collection of
+      extensions and themes to make the browser truly your own.
+    '';
     homepage    = https://www.palemoon.org/;
     license     = licenses.mpl20;
-    maintainers = with maintainers; [ rnhmjoj ];
+    maintainers = with maintainers; [ rnhmjoj AndersonTorres ];
     platforms   = platforms.linux;
   };
-
 }
diff --git a/pkgs/applications/networking/newsreaders/liferea/default.nix b/pkgs/applications/networking/newsreaders/liferea/default.nix
index 743da7958067..ed6fe17cc7e8 100644
--- a/pkgs/applications/networking/newsreaders/liferea/default.nix
+++ b/pkgs/applications/networking/newsreaders/liferea/default.nix
@@ -28,6 +28,7 @@ in stdenv.mkDerivation rec {
   pythonPath = with python3Packages; [ pygobject3 pycairo ];
 
   preFixup = ''
+    rm "$out/share/icons/hicolor/icon-theme.cache"
     buildPythonPath "$out $pythonPath"
     gappsWrapperArgs+=(--prefix PYTHONPATH : "$program_PYTHONPATH")
   '';
diff --git a/pkgs/applications/virtualization/qemu/default.nix b/pkgs/applications/virtualization/qemu/default.nix
index 68ab979ecfbe..694026d3bac2 100644
--- a/pkgs/applications/virtualization/qemu/default.nix
+++ b/pkgs/applications/virtualization/qemu/default.nix
@@ -18,8 +18,8 @@
 
 with stdenv.lib;
 let
-  version = "2.11.0";
-  sha256 = "1jvzw6rdhimn583dz6an8xiw07n3ycvxmj3jpv1s312scv3k9w64";
+  version = "2.11.1";
+  sha256 = "1jrcff0szyjxc3vywyiclwdzk0xgq4cxvjbvmcfyjcpdrq9j5pyr";
   audio = optionalString (hasSuffix "linux" stdenv.system) "alsa,"
     + optionalString pulseSupport "pa,"
     + optionalString sdlSupport "sdl,";
@@ -61,7 +61,7 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  patches = [ ./no-etc-install.patch ]
+  patches = [ ./no-etc-install.patch ./statfs-flags.patch ]
     ++ optional nixosTestRunner ./force-uid0-on-9p.patch
     ++ optional pulseSupport ./fix-hda-recording.patch;
 
diff --git a/pkgs/applications/virtualization/qemu/riscv.nix b/pkgs/applications/virtualization/qemu/riscv.nix
new file mode 100644
index 000000000000..a900d943dabf
--- /dev/null
+++ b/pkgs/applications/virtualization/qemu/riscv.nix
@@ -0,0 +1,20 @@
+{ qemu, fetchFromGitHub, lib }: let
+  src = fetchFromGitHub {
+    owner = "riscv";
+    repo = "riscv-qemu";
+    rev = "af435b709d4a5de3ec2e59ff4dcd05b0b295a730";
+    sha256 = "1kqcsn8yfdg3zyd991i4v5dxznd1l4a4hjry9304lvsm3sz2wllw";
+    fetchSubmodules = true;
+  };
+  version = "2.11.50";
+  revCount = "58771";
+  shortRev = "af435b709d";
+  targets = [ "riscv32-linux-user" "riscv32-softmmu"
+              "riscv64-linux-user" "riscv64-softmmu"
+            ];
+in lib.overrideDerivation qemu (orig: {
+  name = "${(builtins.parseDrvName qemu.name).name}-${version}pre${revCount}_${shortRev}";
+  inherit src;
+  configureFlags = orig.configureFlags ++ [ "--target-list=${lib.concatStringsSep "," targets}" ];
+  postInstall = null;
+})
diff --git a/pkgs/applications/virtualization/qemu/statfs-flags.patch b/pkgs/applications/virtualization/qemu/statfs-flags.patch
new file mode 100644
index 000000000000..c0f0162aacc9
--- /dev/null
+++ b/pkgs/applications/virtualization/qemu/statfs-flags.patch
@@ -0,0 +1,200 @@
+commit d3282d2512774dc5027c98930a3852b2b6e8407a
+Author: Shea Levy <shea@shealevy.com>
+Date:   Sun Feb 18 13:50:11 2018 -0500
+
+    linux-user: Support f_flags in statfs when available.
+    
+    Signed-off-by: Shea Levy <shea@shealevy.com>
+
+diff --git a/configure b/configure
+index 913e14839d..52fe2bf941 100755
+--- a/configure
++++ b/configure
+@@ -5303,6 +5303,22 @@ if compile_prog "" "" ; then
+     have_utmpx=yes
+ fi
+ 
++##########################################
++# Check for newer fields of struct statfs on Linux
++
++if test "$linux_user" = "yes"; then
++  cat > $TMPC <<EOF
++#include <sys/vfs.h>
++
++int main(void) {
++  struct statfs fs;
++  fs.f_flags = 0;
++}
++EOF
++  if compile_object ; then
++      have_statfs_flags=yes
++  fi
++fi
+ ##########################################
+ # checks for sanitizers
+ 
+@@ -6518,6 +6534,10 @@ if test "$have_utmpx" = "yes" ; then
+   echo "HAVE_UTMPX=y" >> $config_host_mak
+ fi
+ 
++if test "$have_statfs_flags" = "yes" ; then
++  echo "HAVE_STATFS_FLAGS=y" >> $config_host_mak
++fi
++
+ if test "$ivshmem" = "yes" ; then
+   echo "CONFIG_IVSHMEM=y" >> $config_host_mak
+ fi
+diff --git a/linux-user/syscall.c b/linux-user/syscall.c
+index 82b35a6bdf..77481eca2c 100644
+--- a/linux-user/syscall.c
++++ b/linux-user/syscall.c
+@@ -9534,6 +9534,9 @@ abi_long do_syscall(void *cpu_env, int num, abi_long arg1,
+             __put_user(stfs.f_fsid.__val[1], &target_stfs->f_fsid.val[1]);
+             __put_user(stfs.f_namelen, &target_stfs->f_namelen);
+             __put_user(stfs.f_frsize, &target_stfs->f_frsize);
++#ifdef HAVE_STATFS_FLAGS
++            __put_user(stfs.f_flags, &target_stfs->f_flags);
++#endif
+             memset(target_stfs->f_spare, 0, sizeof(target_stfs->f_spare));
+             unlock_user_struct(target_stfs, arg2, 1);
+         }
+diff --git a/linux-user/syscall_defs.h b/linux-user/syscall_defs.h
+index a35c52a60a..9f90451caf 100644
+--- a/linux-user/syscall_defs.h
++++ b/linux-user/syscall_defs.h
+@@ -362,7 +362,14 @@ struct kernel_statfs {
+ 	int f_ffree;
+         kernel_fsid_t f_fsid;
+ 	int f_namelen;
++#ifdef HAVE_STATFS_FLAGS
++	int f_frsize;
++	int f_flags;
++	int f_spare[4];
++#else
+ 	int f_spare[6];
++#endif
++
+ };
+ 
+ struct target_dirent {
+@@ -2223,7 +2230,13 @@ struct target_statfs {
+ 	/* Linux specials */
+ 	target_fsid_t		f_fsid;
+ 	int32_t			f_namelen;
++#ifdef HAVE_STATFS_FLAGS
++	int32_t			f_frsize;
++	int32_t			f_flags;
++	int32_t			f_spare[4];
++#else
+ 	int32_t			f_spare[6];
++#endif
+ };
+ #else
+ struct target_statfs {
+@@ -2239,7 +2252,13 @@ struct target_statfs {
+ 	/* Linux specials */
+ 	target_fsid_t		f_fsid;
+ 	abi_long		f_namelen;
++#ifdef HAVE_STATFS_FLAGS
++	abi_long		f_frsize;
++	abi_long		f_flags;
++	abi_long		f_spare[4];
++#else
+ 	abi_long		f_spare[6];
++#endif
+ };
+ #endif
+ 
+@@ -2255,7 +2274,13 @@ struct target_statfs64 {
+ 	uint64_t	f_bavail;
+ 	target_fsid_t	f_fsid;
+ 	uint32_t	f_namelen;
++#ifdef HAVE_STATFS_FLAGS
++	uint32_t	f_frsize;
++	uint32_t	f_flags;
++	uint32_t	f_spare[4];
++#else
+ 	uint32_t	f_spare[6];
++#endif
+ };
+ #elif (defined(TARGET_PPC64) || defined(TARGET_X86_64) || \
+        defined(TARGET_SPARC64) || defined(TARGET_AARCH64)) && \
+@@ -2271,7 +2296,12 @@ struct target_statfs {
+ 	target_fsid_t f_fsid;
+ 	abi_long f_namelen;
+ 	abi_long f_frsize;
++#ifdef HAVE_STATFS_FLAGS
++	abi_long f_flags;
++	abi_long f_spare[4];
++#else
+ 	abi_long f_spare[5];
++#endif
+ };
+ 
+ struct target_statfs64 {
+@@ -2285,7 +2315,12 @@ struct target_statfs64 {
+ 	target_fsid_t f_fsid;
+ 	abi_long f_namelen;
+ 	abi_long f_frsize;
++#ifdef HAVE_STATFS_FLAGS
++	abi_long f_flags;
++	abi_long f_spare[4];
++#else
+ 	abi_long f_spare[5];
++#endif
+ };
+ #elif defined(TARGET_S390X)
+ struct target_statfs {
+@@ -2299,7 +2334,13 @@ struct target_statfs {
+     kernel_fsid_t f_fsid;
+     int32_t  f_namelen;
+     int32_t  f_frsize;
++#ifdef HAVE_STATFS_FLAGS
++    int32_t  f_flags;
++    int32_t  f_spare[4];
++#else
+     int32_t  f_spare[5];
++#endif
++
+ };
+ 
+ struct target_statfs64 {
+@@ -2313,7 +2354,12 @@ struct target_statfs64 {
+     kernel_fsid_t f_fsid;
+     int32_t  f_namelen;
+     int32_t  f_frsize;
++#ifdef HAVE_STATFS_FLAGS
++    int32_t  f_flags;
++    int32_t  f_spare[4];
++#else
+     int32_t  f_spare[5];
++#endif
+ };
+ #else
+ struct target_statfs {
+@@ -2327,7 +2373,12 @@ struct target_statfs {
+ 	target_fsid_t f_fsid;
+ 	uint32_t f_namelen;
+ 	uint32_t f_frsize;
++#ifdef HAVE_STATFS_FLAGS
++	uint32_t f_flags;
++	uint32_t f_spare[4];
++#else
+ 	uint32_t f_spare[5];
++#endif
+ };
+ 
+ struct target_statfs64 {
+@@ -2341,7 +2392,12 @@ struct target_statfs64 {
+ 	target_fsid_t f_fsid;
+         uint32_t f_namelen;
+ 	uint32_t f_frsize;
++#ifdef HAVE_STATFS_FLAGS
++	uint32_t f_flags;
++	uint32_t f_spare[4];
++#else
+ 	uint32_t f_spare[5];
++#endif
+ };
+ #endif
+ 
diff --git a/pkgs/applications/virtualization/xen/4.8.nix b/pkgs/applications/virtualization/xen/4.8.nix
index 44a52a1026af..b1fcf36a46c1 100644
--- a/pkgs/applications/virtualization/xen/4.8.nix
+++ b/pkgs/applications/virtualization/xen/4.8.nix
@@ -49,15 +49,9 @@ callPackage (import ./generic.nix (rec {
       src = fetchgit {
         url = https://xenbits.xen.org/git-http/qemu-xen.git;
         rev = "refs/tags/qemu-xen-${version}";
-        sha256 = "1v19pp86kcgwvsbkrdrn4rlaj02i4054avw8k70w1m0rnwgcsdbs";
+        sha256 = "1l4sygd8p0mc13bskr4r1m31qh1kr58h195qn1s52869s58jyhvm";
       };
       buildInputs = qemuDeps;
-      patches = [
-        (xsaPatch {
-          name = "216-qemuu";
-          sha256 = "06w2iw1r5gip2bpbg19cziws965h9in0f6np74cr31f76yy30yxn";
-        })
-      ];
       meta.description = "Xen's fork of upstream Qemu";
     };
   } // optionalAttrs withInternalTraditionalQemu {
diff --git a/pkgs/applications/virtualization/xen/packages.nix b/pkgs/applications/virtualization/xen/packages.nix
index 8f5262acb024..4b5f15c8ff42 100644
--- a/pkgs/applications/virtualization/xen/packages.nix
+++ b/pkgs/applications/virtualization/xen/packages.nix
@@ -58,10 +58,6 @@ rec {
   };
 
   xen_4_8-vanilla = callPackage ./4.8.nix {
-    # At the very least included seabios and etherboot need gcc49,
-    # so we have to build all of it with gcc49.
-    stdenv = overrideCC stdenv gcc49;
-
     meta = {
       description = "vanilla";
       longDescription = ''