about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorSimon Lackerbauer <simon@lackerbauer.com>2017-08-06 19:09:33 +0200
committerRobin Gloster <mail@glob.in>2017-08-09 19:53:05 +0200
commit30d76b8ccdf12412df7e00cb619c5fe12a09706a (patch)
treeac8087834f1b6023b11e27b787b246121482ad8d /pkgs/applications
parentc839b6ce0ae75537f557202f941000662c7ac2d7 (diff)
downloadnixlib-30d76b8ccdf12412df7e00cb619c5fe12a09706a.tar
nixlib-30d76b8ccdf12412df7e00cb619c5fe12a09706a.tar.gz
nixlib-30d76b8ccdf12412df7e00cb619c5fe12a09706a.tar.bz2
nixlib-30d76b8ccdf12412df7e00cb619c5fe12a09706a.tar.lz
nixlib-30d76b8ccdf12412df7e00cb619c5fe12a09706a.tar.xz
nixlib-30d76b8ccdf12412df7e00cb619c5fe12a09706a.tar.zst
nixlib-30d76b8ccdf12412df7e00cb619c5fe12a09706a.zip
seafile-client: 5.0.7 -> 6.1.0
bump to qt5
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/seafile-client/default.nix41
1 files changed, 15 insertions, 26 deletions
diff --git a/pkgs/applications/networking/seafile-client/default.nix b/pkgs/applications/networking/seafile-client/default.nix
index 9c6aefd8ced4..d930e24883ea 100644
--- a/pkgs/applications/networking/seafile-client/default.nix
+++ b/pkgs/applications/networking/seafile-client/default.nix
@@ -1,39 +1,28 @@
-{stdenv, fetchurl, writeScript, pkgconfig, cmake, qt4, seafile-shared, ccnet, makeWrapper}:
+{ stdenv, fetchurl, writeScript, pkgconfig, cmake, qtbase, qttools
+, seafile-shared, ccnet, makeWrapper }:
 
-stdenv.mkDerivation rec
-{
-  version = "5.0.7";
+stdenv.mkDerivation rec {
+  version = "6.1.0";
   name = "seafile-client-${version}";
 
-  src = fetchurl
-  {
+  src = fetchurl {
     url = "https://github.com/haiwen/seafile-client/archive/v${version}.tar.gz";
-    sha256 = "ae6975bc1adf45d09cf9f6332ceac7cf285f8191f6cf50c6291ed45f8cf4ffa5";
+    sha256 = "16rn6b9ayaccgwx8hs3yh1wb395pp8ffh8may8a8bpcc4gdry7bd";
   };
 
-  buildInputs = [ pkgconfig cmake qt4 seafile-shared makeWrapper ];
-
-  builder = writeScript "${name}-builder.sh" ''
-    source $stdenv/setup
-
-    tar xvfz $src
-    cd seafile-client-*
-
-    cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_SKIP_BUILD_RPATH=ON -DCMAKE_INSTALL_PREFIX="$out" .
-    make -j1
-
-    make install
+  nativeBuildInputs = [ pkgconfig cmake makeWrapper ];
+  buildInputs = [ qtbase qttools seafile-shared ];
 
+  postInstall = ''
     wrapProgram $out/bin/seafile-applet \
       --suffix PATH : ${stdenv.lib.makeBinPath [ ccnet seafile-shared ]}
-    '';
+  '';
 
-  meta =
-  {
-    homepage = https://github.com/haiwen/seafile-clients;
+  meta = with stdenv.lib; {
+    homepage = https://github.com/haiwen/seafile-client;
     description = "Desktop client for Seafile, the Next-generation Open Source Cloud Storage";
-    license = stdenv.lib.licenses.asl20;
-    platforms = stdenv.lib.platforms.linux;
-    maintainers = [ stdenv.lib.maintainers.calrama ];
+    license = licenses.asl20;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.calrama ];
   };
 }