about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorNiklas Hambüchen <mail@nh2.me>2020-03-18 03:15:16 +0100
committerGitHub <noreply@github.com>2020-03-18 03:15:16 +0100
commit2fb0068b500e5778219fdd24fd9032d13e83a192 (patch)
tree0396909a87398e67b88d1b390f7b585428ecedd2 /pkgs/applications
parent05cf8a7c07bf6a56d9e4b786894389babe85f317 (diff)
parentbd1b24b5b1fa08e824d06e64bc1b7ae14f644ca1 (diff)
downloadnixlib-2fb0068b500e5778219fdd24fd9032d13e83a192.tar
nixlib-2fb0068b500e5778219fdd24fd9032d13e83a192.tar.gz
nixlib-2fb0068b500e5778219fdd24fd9032d13e83a192.tar.bz2
nixlib-2fb0068b500e5778219fdd24fd9032d13e83a192.tar.lz
nixlib-2fb0068b500e5778219fdd24fd9032d13e83a192.tar.xz
nixlib-2fb0068b500e5778219fdd24fd9032d13e83a192.tar.zst
nixlib-2fb0068b500e5778219fdd24fd9032d13e83a192.zip
Merge pull request #81994 from bhipple/u/librustzcash
zcash: 2.1.0-1 -> 2.1.1-1; libzrustzcash: 2018-10-27 -> 0.1.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/blockchains/zcash/default.nix16
-rw-r--r--pkgs/applications/blockchains/zcash/librustzcash/default.nix16
2 files changed, 16 insertions, 16 deletions
diff --git a/pkgs/applications/blockchains/zcash/default.nix b/pkgs/applications/blockchains/zcash/default.nix
index f6114b3c2134..e2c57d514cda 100644
--- a/pkgs/applications/blockchains/zcash/default.nix
+++ b/pkgs/applications/blockchains/zcash/default.nix
@@ -7,15 +7,19 @@ with stdenv.lib;
 stdenv.mkDerivation rec {
 
   pname = "zcash";
-  version = "2.1.0-1";
+  version = "2.1.1-1";
 
   src = fetchFromGitHub {
     owner = "zcash";
     repo  = "zcash";
     rev = "v${version}";
-    sha256 = "05bnn4lxrrcv1ha3jdfrgwg4ar576161n3j9d4gpc14ww3zgf9vz";
+    sha256 = "1g5zlfzfp31my8w8nlg5fncpr2y95iv9fm04x57sjb93rgmjdh5n";
   };
 
+  patchPhase = ''
+    sed -i"" 's,-fvisibility=hidden,,g'            src/Makefile.am
+  '';
+
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
   buildInputs = [ gtest gmock gmp openssl wget db62 boost17x zlib
                   protobuf libevent libsodium librustzcash ]
@@ -23,17 +27,15 @@ stdenv.mkDerivation rec {
 
   configureFlags = [ "--with-boost-libdir=${boost17x.out}/lib" ];
 
-  patchPhase = ''
-    sed -i"" 's,-fvisibility=hidden,,g'            src/Makefile.am
-  '';
-
   postInstall = ''
     cp zcutil/fetch-params.sh $out/bin/zcash-fetch-params
   '';
 
+  enableParallelBuilding = true;
+
   meta = {
     description = "Peer-to-peer, anonymous electronic cash system";
-    homepage = https://z.cash/;
+    homepage = "https://z.cash/";
     maintainers = with maintainers; [ rht tkerber ];
     license = licenses.mit;
     platforms = platforms.linux;
diff --git a/pkgs/applications/blockchains/zcash/librustzcash/default.nix b/pkgs/applications/blockchains/zcash/librustzcash/default.nix
index 5032594468e7..6cd2ae018fb6 100644
--- a/pkgs/applications/blockchains/zcash/librustzcash/default.nix
+++ b/pkgs/applications/blockchains/zcash/librustzcash/default.nix
@@ -1,20 +1,17 @@
 { stdenv, fetchFromGitHub, rustPlatform }:
 
 rustPlatform.buildRustPackage rec {
-  pname = "librustzcash-unstable";
-  version = "2018-10-27";
+  pname = "librustzcash";
+  version = "0.1.0";
 
   src = fetchFromGitHub {
     owner = "zcash";
     repo = "librustzcash";
-    rev = "06da3b9ac8f278e5d4ae13088cf0a4c03d2c13f5";
-    sha256 = "0md0pp3k97iv7kfjpfkg14pjanhrql4vafa8ggbxpkajv1j4xldv";
+    rev = version;
+    sha256 = "0d28k29sgzrg9clynz29kpw50kbkp0a4dfdayqhmpjmsh05y6261";
   };
 
-  # Delete this on next update; see #79975 for details
-  legacyCargoFetcher = true;
-
-  cargoSha256 = "166v8cxlpfslbs5gljbh7wp0lxqakayw47ikxm9r9a39n7j36mq1";
+  cargoSha256 = "1wzyrcmcbrna6rjzw19c4lq30didzk4w6fs6wmvxp0xfg4qqdlax";
 
   installPhase = ''
     mkdir -p $out/lib
@@ -23,11 +20,12 @@ rustPlatform.buildRustPackage rec {
     cp librustzcash/include/librustzcash.h $out/include/
   '';
 
+  # The tests do pass, but they take an extremely long time to run.
   doCheck = false;
 
   meta = with stdenv.lib; {
     description = "Rust-language assets for Zcash";
-    homepage = https://github.com/zcash/librustzcash;
+    homepage = "https://github.com/zcash/librustzcash";
     maintainers = with maintainers; [ rht tkerber ];
     license = with licenses; [ mit asl20 ];
     platforms = platforms.unix;