about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorS-NA <S-NA@users.noreply.github.com>2020-03-16 17:47:30 -0400
committerGitHub <noreply@github.com>2020-03-16 21:47:30 +0000
commit2f5b8d65224090fd9f25d550fdf55db54399362a (patch)
tree18b4be8d3de67b2901270395ae7066d48ff98ad0 /pkgs/applications
parent8be2040cf73f14931a9513674d5a6a561a021595 (diff)
downloadnixlib-2f5b8d65224090fd9f25d550fdf55db54399362a.tar
nixlib-2f5b8d65224090fd9f25d550fdf55db54399362a.tar.gz
nixlib-2f5b8d65224090fd9f25d550fdf55db54399362a.tar.bz2
nixlib-2f5b8d65224090fd9f25d550fdf55db54399362a.tar.lz
nixlib-2f5b8d65224090fd9f25d550fdf55db54399362a.tar.xz
nixlib-2f5b8d65224090fd9f25d550fdf55db54399362a.tar.zst
nixlib-2f5b8d65224090fd9f25d550fdf55db54399362a.zip
aucatctl: init at 0.1
Allows those who use sndiod to adjust the volume of audio programs.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/aucatctl/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/applications/audio/aucatctl/default.nix b/pkgs/applications/audio/aucatctl/default.nix
new file mode 100644
index 000000000000..4aff3e1f7bfb
--- /dev/null
+++ b/pkgs/applications/audio/aucatctl/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchurl, sndio, libbsd }:
+
+stdenv.mkDerivation rec {
+  pname = "aucatctl";
+  version = "0.1";
+
+  src = fetchurl {
+    url = "http://www.sndio.org/${pname}-${version}.tar.gz";
+    sha256 = "524f2fae47db785234f166551520d9605b9a27551ca438bd807e3509ce246cf0";
+  };
+
+  buildInputs = [ sndio ]
+    ++ stdenv.lib.optional (!stdenv.isDarwin && !stdenv.targetPlatform.isBSD)
+    libbsd;
+
+  outputs = [ "out" "man" ];
+
+  preBuild = ''
+    makeFlagsArray+=("PREFIX=$out")
+  '' + stdenv.lib.optionalString
+    (!stdenv.isDarwin && !stdenv.targetPlatform.isBSD) ''
+      makeFlagsArray+=(LDADD="-lsndio -lbsd")
+
+      # Fix warning about implicit declaration of function 'strlcpy'
+      substituteInPlace aucatctl.c \
+        --replace '#include <string.h>' '#include <bsd/string.h>'
+    '';
+
+  meta = with stdenv.lib; {
+    description =
+      "The aucatctl utility sends MIDI messages to control sndiod and/or aucat volumes";
+    homepage = "http://www.sndio.org";
+    license = licenses.isc;
+    maintainers = with maintainers; [ sna ];
+    platforms = platforms.unix;
+  };
+}