about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2019-08-23 02:02:50 +0200
committerRobin Gloster <mail@glob.in>2019-08-23 02:02:50 +0200
commit2cc05be907a44752dfed98a58ee04e6d1caf5ac3 (patch)
tree752bcb0ffeda4edb46a8949d376b20b2f023ac85 /pkgs/applications
parentc7e75df21f4e7640ff857c10b436be0d9e581cb0 (diff)
downloadnixlib-2cc05be907a44752dfed98a58ee04e6d1caf5ac3.tar
nixlib-2cc05be907a44752dfed98a58ee04e6d1caf5ac3.tar.gz
nixlib-2cc05be907a44752dfed98a58ee04e6d1caf5ac3.tar.bz2
nixlib-2cc05be907a44752dfed98a58ee04e6d1caf5ac3.tar.lz
nixlib-2cc05be907a44752dfed98a58ee04e6d1caf5ac3.tar.xz
nixlib-2cc05be907a44752dfed98a58ee04e6d1caf5ac3.tar.zst
nixlib-2cc05be907a44752dfed98a58ee04e6d1caf5ac3.zip
treewide: openssl_1_1 pinning is unnecessary
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/sourcehut/default.nix12
-rw-r--r--pkgs/applications/virtualization/virt-viewer/default.nix5
2 files changed, 4 insertions, 13 deletions
diff --git a/pkgs/applications/version-management/sourcehut/default.nix b/pkgs/applications/version-management/sourcehut/default.nix
index b7c8eaf3820f..00a3cf271113 100644
--- a/pkgs/applications/version-management/sourcehut/default.nix
+++ b/pkgs/applications/version-management/sourcehut/default.nix
@@ -1,4 +1,4 @@
-{ python37, openssl_1_1
+{ python37, openssl
 , callPackage }:
 
 # To expose the *srht modules, they have to be a python module so we use `buildPythonModule`
@@ -23,16 +23,6 @@ let
       todosrht = self.callPackage ./todo.nix { };
 
       scmsrht = self.callPackage ./scm.nix { };
-
-      # OVERRIDES
-
-      cryptography = super.cryptography.override {
-        openssl = openssl_1_1;
-      };
-
-      pyopenssl = super.pyopenssl.override {
-        openssl = openssl_1_1;
-      };
     };
   };
 in with python.pkgs; {
diff --git a/pkgs/applications/virtualization/virt-viewer/default.nix b/pkgs/applications/virtualization/virt-viewer/default.nix
index 9c307d8e9ba4..eb5d53c2b89f 100644
--- a/pkgs/applications/virtualization/virt-viewer/default.nix
+++ b/pkgs/applications/virtualization/virt-viewer/default.nix
@@ -1,9 +1,10 @@
 { stdenv, fetchurl, pkgconfig, intltool, glib, libxml2, gtk3, gtk-vnc, gmp
-, libgcrypt, gnupg, cyrus_sasl, shared-mime-info, libvirt, yajl, xen
+, libgcrypt, gnupg, cyrus_sasl, shared-mime-info, libvirt, yajl
 , gsettings-desktop-schemas, wrapGAppsHook, libvirt-glib, libcap_ng, numactl
 , libapparmor, gst_all_1
 , spiceSupport ? true
 , spice-gtk ? null, spice-protocol ? null, libcap ? null, gdbm ? null
+, xenSupport ? false, xen ? null
 }:
 
 assert spiceSupport ->
@@ -26,7 +27,7 @@ stdenv.mkDerivation rec {
     glib libxml2 gtk3 gtk-vnc gmp libgcrypt gnupg cyrus_sasl shared-mime-info
     libvirt yajl gsettings-desktop-schemas libvirt-glib
     libcap_ng numactl libapparmor
-  ] ++ optionals stdenv.isx86_64 [
+  ] ++ optionals xenSupport [
     xen
   ] ++ optionals spiceSupport [
     spice-gtk spice-protocol libcap gdbm