about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2013-05-27 10:09:24 +0200
committeraszlig <aszlig@redmoonstudios.org>2013-05-27 10:18:01 +0200
commit2ad7c40a6699c7ea611654588f8db9efe9d35937 (patch)
tree150badaacc1516583193dbd9c94c27288c7b35cf /pkgs/applications
parentf4174f7df657800a2c450693f952869d7f58d074 (diff)
downloadnixlib-2ad7c40a6699c7ea611654588f8db9efe9d35937.tar
nixlib-2ad7c40a6699c7ea611654588f8db9efe9d35937.tar.gz
nixlib-2ad7c40a6699c7ea611654588f8db9efe9d35937.tar.bz2
nixlib-2ad7c40a6699c7ea611654588f8db9efe9d35937.tar.lz
nixlib-2ad7c40a6699c7ea611654588f8db9efe9d35937.tar.xz
nixlib-2ad7c40a6699c7ea611654588f8db9efe9d35937.tar.zst
nixlib-2ad7c40a6699c7ea611654588f8db9efe9d35937.zip
gajim: Optional support for notifications.
Actually, Gajim can use notifications through dbus if notification-daemon is
available. Otherwise it falls back to notify-python, which is why I disabled it
by default, especially because upstream support of that Python library isn't
especially awesome ;-)

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/instant-messengers/gajim/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/applications/networking/instant-messengers/gajim/default.nix b/pkgs/applications/networking/instant-messengers/gajim/default.nix
index 3c3cc5ccdfce..d5902d143590 100644
--- a/pkgs/applications/networking/instant-messengers/gajim/default.nix
+++ b/pkgs/applications/networking/instant-messengers/gajim/default.nix
@@ -6,6 +6,7 @@
 , enableE2E ? true
 , enableRST ? true
 , enableSpelling ? true, gtkspell ? null
+, enableNotifications ? false
 , enableLaTeX ? false, texLive ? null
 }:
 
@@ -14,6 +15,7 @@ assert enableJingle -> farstream != null && gst_plugins_bad != null
 assert enableE2E -> pythonPackages.pycrypto != null;
 assert enableRST -> pythonPackages.docutils != null;
 assert enableSpelling -> gtkspell != null;
+assert enableNotifications -> pythonPackages.notify != null;
 assert enableLaTeX -> texLive != null;
 
 with stdenv.lib;
@@ -71,6 +73,7 @@ stdenv.mkDerivation rec {
   ] ++ optionals enableJingle [ farstream gst_plugins_bad libnice ]
     ++ optional enableE2E pythonPackages.pycrypto
     ++ optional enableRST pythonPackages.docutils
+    ++ optional enableNotifications pythonPackages.notify
     ++ optional enableLaTeX texLive;
 
   postInstall = ''