about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-05-12 11:53:50 -0500
committerGitHub <noreply@github.com>2018-05-12 11:53:50 -0500
commit29c2c646e5be50e2f90fc93f58032dc1152947eb (patch)
treed423c6d6572cea3fb03458c535699065f1d791ac /pkgs/applications
parentf245f537a8fcbf73ae959792a552b43fbc1c8d71 (diff)
parent4d0ab5d698fcb198c462adedff47e15c4edea36e (diff)
downloadnixlib-29c2c646e5be50e2f90fc93f58032dc1152947eb.tar
nixlib-29c2c646e5be50e2f90fc93f58032dc1152947eb.tar.gz
nixlib-29c2c646e5be50e2f90fc93f58032dc1152947eb.tar.bz2
nixlib-29c2c646e5be50e2f90fc93f58032dc1152947eb.tar.lz
nixlib-29c2c646e5be50e2f90fc93f58032dc1152947eb.tar.xz
nixlib-29c2c646e5be50e2f90fc93f58032dc1152947eb.tar.zst
nixlib-29c2c646e5be50e2f90fc93f58032dc1152947eb.zip
Merge pull request #39653 from ayyjayess/polybar_pure
Polybar: make call to i3 pure
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/polybar/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/applications/misc/polybar/default.nix b/pkgs/applications/misc/polybar/default.nix
index a3b87fd34f68..05ad3e2a9066 100644
--- a/pkgs/applications/misc/polybar/default.nix
+++ b/pkgs/applications/misc/polybar/default.nix
@@ -1,6 +1,6 @@
 { cairo, cmake, fetchgit, libXdmcp, libpthreadstubs, libxcb, pcre, pkgconfig
 , python2 , stdenv, xcbproto, xcbutil, xcbutilimage, xcbutilrenderutil
-, xcbutilwm, xcbutilxrm, fetchpatch
+, xcbutilwm, xcbutilxrm, fetchpatch, makeWrapper
 
 # optional packages-- override the variables ending in 'Support' to enable or
 # disable modules
@@ -52,8 +52,15 @@ stdenv.mkDerivation rec {
       (if i3Support || i3GapsSupport then jsoncpp else null)
       (if i3Support then i3 else null)
       (if i3GapsSupport then i3-gaps else null)
+
+      (if i3Support || i3GapsSupport then makeWrapper else null)
     ];
 
+    fixupPhase = if (i3Support || i3GapsSupport) then ''
+    wrapProgram $out/bin/polybar \
+      --prefix PATH : "${if i3Support then i3 else i3-gaps}/bin"
+  '' else null;
+
     nativeBuildInputs = [
       cmake pkgconfig
     ];