about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAndres Löh <mail@andres-loeh.de>2008-06-04 14:24:28 +0000
committerAndres Löh <mail@andres-loeh.de>2008-06-04 14:24:28 +0000
commit2991f9adefa06bf59a0e84a04ab363a4a2154d52 (patch)
treeade2facbf03781626cd7173372d5db8dd4d22542 /pkgs/applications
parentd025d671182c31a04abceb98bded10f9e0864651 (diff)
downloadnixlib-2991f9adefa06bf59a0e84a04ab363a4a2154d52.tar
nixlib-2991f9adefa06bf59a0e84a04ab363a4a2154d52.tar.gz
nixlib-2991f9adefa06bf59a0e84a04ab363a4a2154d52.tar.bz2
nixlib-2991f9adefa06bf59a0e84a04ab363a4a2154d52.tar.lz
nixlib-2991f9adefa06bf59a0e84a04ab363a4a2154d52.tar.xz
nixlib-2991f9adefa06bf59a0e84a04ab363a4a2154d52.tar.zst
nixlib-2991f9adefa06bf59a0e84a04ab363a4a2154d52.zip
* layout changes
svn path=/nixpkgs/trunk/; revision=11981
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/sync/unison/default.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/pkgs/applications/networking/sync/unison/default.nix b/pkgs/applications/networking/sync/unison/default.nix
index 0883c236d010..7c735b8954c5 100644
--- a/pkgs/applications/networking/sync/unison/default.nix
+++ b/pkgs/applications/networking/sync/unison/default.nix
@@ -1,15 +1,18 @@
 {stdenv, fetchurl, ocaml, lablgtk, fontschumachermisc, xset, makeWrapper}:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation (rec {
+
   name = "unison-2.13.16";
   src = fetchurl {
-    url = http://www.seas.upenn.edu/~bcpierce/unison//download/releases/stable/unison-2.13.16.tar.gz;
+    url = "http://www.seas.upenn.edu/~bcpierce/unison//download/releases/stable/${name}.tar.gz";
     sha256 = "808400a933aeb67654edc770822cd186d1b2adc92e7cb5836996c71c69ffe656";
   };
 
   buildInputs = [ocaml makeWrapper];
 
-  preBuild = "sed -i \"s|\\(OCAMLOPT=.*\\)$|\\1 -I ${lablgtk}/lib/ocaml/lablgtk2|\" Makefile.OCaml";
+  preBuild = ''
+    sed -i "s|\(OCAMLOPT=.*\)$|\1 -I ${lablgtk}/lib/ocaml/lablgtk2|" Makefile.OCaml
+  '';
   makeFlags = "UISTYLE=gtk2 INSTALLDIR=$(out)/bin/";
   preInstall = "ensureDir $out/bin";
   postInstall = ''
@@ -18,4 +21,5 @@ stdenv.mkDerivation {
         --run "${xset}/bin/xset q | grep -q \"${fontschumachermisc}\" || ${xset}/bin/xset +fp \"${fontschumachermisc}/lib/X11/fonts/misc\""
     done
   '';
-}
+
+})