about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2015-07-26 21:04:32 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2015-08-10 23:12:02 +0200
commit28bb4e4018115b6e35801876de135e526db663b3 (patch)
tree2be30470717dc9ea71aa01bf70b298e515982adf /pkgs/applications
parent543da4e00fb379d2b2bbd0c58cd7d5b3f736a16f (diff)
downloadnixlib-28bb4e4018115b6e35801876de135e526db663b3.tar
nixlib-28bb4e4018115b6e35801876de135e526db663b3.tar.gz
nixlib-28bb4e4018115b6e35801876de135e526db663b3.tar.bz2
nixlib-28bb4e4018115b6e35801876de135e526db663b3.tar.lz
nixlib-28bb4e4018115b6e35801876de135e526db663b3.tar.xz
nixlib-28bb4e4018115b6e35801876de135e526db663b3.tar.zst
nixlib-28bb4e4018115b6e35801876de135e526db663b3.zip
eclipse-color-theme: init at 1.0.0.201410260308
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/eclipse/plugins.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/applications/editors/eclipse/plugins.nix b/pkgs/applications/editors/eclipse/plugins.nix
index 5d912803792c..1f851815858d 100644
--- a/pkgs/applications/editors/eclipse/plugins.nix
+++ b/pkgs/applications/editors/eclipse/plugins.nix
@@ -51,6 +51,30 @@ in {
     };
   };
 
+  color-theme = buildEclipsePlugin rec {
+    name = "color-theme-${version}";
+    version = "1.0.0.201410260308";
+    javaName = "com.github.eclipsecolortheme";
+
+    srcFeature = fetchurl {
+      url = "https://eclipse-color-theme.github.io/update/features/${javaName}.feature_${version}.jar";
+      sha256 = "128b9b1cib5ff0w1114ns5mrbrhj2kcm358l4dpnma1s8gklm8g2";
+    };
+
+    srcPlugin = fetchurl {
+      url = "https://eclipse-color-theme.github.io/update/plugins/${javaName}_${version}.jar";
+      sha256 = "0wz61909bhqwzpqwll27ia0cn3anyp81haqx3rj1iq42cbl42h0y";
+    };
+
+    meta = with stdenv.lib; {
+      homepage = http://eclipsecolorthemes.org/;
+      description = "Plugin to switch color themes conveniently and without side effects";
+      license = licenses.epl10;
+      platforms = platforms.all;
+      maintainers = [ maintainers.rycee ];
+    };
+  };
+
   emacsplus = buildEclipsePlugin rec {
     name = "emacsplus-${version}";
     version = "4.2.0";