about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@users.noreply.github.com>2019-02-05 15:34:54 -0500
committerworldofpeace <worldofpeace@users.noreply.github.com>2019-02-22 17:52:26 -0500
commit276077a42f9686945585dba351ad1f54fd8bc003 (patch)
treeade54977ee164aad6f7bab0ccb2e9d2abd9a4a83 /pkgs/applications
parent6e6962668042d838f80002d239bc91b5da3c5a91 (diff)
downloadnixlib-276077a42f9686945585dba351ad1f54fd8bc003.tar
nixlib-276077a42f9686945585dba351ad1f54fd8bc003.tar.gz
nixlib-276077a42f9686945585dba351ad1f54fd8bc003.tar.bz2
nixlib-276077a42f9686945585dba351ad1f54fd8bc003.tar.lz
nixlib-276077a42f9686945585dba351ad1f54fd8bc003.tar.xz
nixlib-276077a42f9686945585dba351ad1f54fd8bc003.tar.zst
nixlib-276077a42f9686945585dba351ad1f54fd8bc003.zip
notes-up: init at 1.6.3
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/office/notes-up/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/applications/office/notes-up/default.nix b/pkgs/applications/office/notes-up/default.nix
new file mode 100644
index 000000000000..79a0c0207029
--- /dev/null
+++ b/pkgs/applications/office/notes-up/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, fetchFromGitHub, pantheon, pkgconfig, cmake, ninja, gtk3, gtksourceview3, webkitgtk, gtkspell3, glib, libgee, sqlite, discount, wrapGAppsHook }:
+
+stdenv.mkDerivation rec {
+  pname = "notes-up";
+  version = "1.6.3";
+
+  src = fetchFromGitHub {
+    owner = "Philip-Scott";
+    repo = "Notes-up";
+    rev = version;
+    sha256 = "06fzdb823kkami0jch9ccblsvw3x7zd1d4xz8fv3giscl3f36x4q";
+  };
+
+  nativeBuildInputs = [
+    cmake
+    ninja
+    pantheon.vala
+    pkgconfig
+    wrapGAppsHook
+  ];
+
+  buildInputs = [
+    discount
+    glib
+    gtk3
+    gtksourceview3
+    gtkspell3
+    libgee
+    pantheon.granite
+    sqlite
+    webkitgtk
+  ];
+
+  meta = with stdenv.lib; {
+    description = "Markdown notes editor and manager designed for elementary OS";
+    homepage = https://github.com/Philip-Scott/Notes-up;
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ davidak worldofpeace ];
+    platforms = platforms.linux;
+  };
+}