about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJean Potier <jpotier@users.noreply.github.com>2018-11-25 15:38:18 +0200
committerRenaud <c0bw3b@users.noreply.github.com>2018-11-25 14:38:18 +0100
commit233a4ed5739c4790efc155a703b86fe23f08e4b9 (patch)
tree8d0139a0d85ad9e978df0ed7c1595c549b8d2f1c /pkgs/applications
parentc1d760f0bf7f6bbc095852ad01d3b329772a9875 (diff)
downloadnixlib-233a4ed5739c4790efc155a703b86fe23f08e4b9.tar
nixlib-233a4ed5739c4790efc155a703b86fe23f08e4b9.tar.gz
nixlib-233a4ed5739c4790efc155a703b86fe23f08e4b9.tar.bz2
nixlib-233a4ed5739c4790efc155a703b86fe23f08e4b9.tar.lz
nixlib-233a4ed5739c4790efc155a703b86fe23f08e4b9.tar.xz
nixlib-233a4ed5739c4790efc155a703b86fe23f08e4b9.tar.zst
nixlib-233a4ed5739c4790efc155a703b86fe23f08e4b9.zip
renoise: add mpg123 to runtime deps
* renoise: add mpg123 to runtime deps (#47435)

* renoise: split native build inputs
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/renoise/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/applications/audio/renoise/default.nix b/pkgs/applications/audio/renoise/default.nix
index cd06fa80f5aa..c3474b60348e 100644
--- a/pkgs/applications/audio/renoise/default.nix
+++ b/pkgs/applications/audio/renoise/default.nix
@@ -1,4 +1,5 @@
-{ stdenv, fetchurl, libX11, libXext, libXcursor, libXrandr, libjack2, alsaLib, releasePath ? null }:
+{ stdenv, fetchurl, libX11, libXext, libXcursor, libXrandr, libjack2, alsaLib,
+  mpg123, makeWrapper, releasePath ? null }:
 
 with stdenv.lib;
 
@@ -35,6 +36,7 @@ stdenv.mkDerivation rec {
         releasePath
     else throw "Platform is not supported by Renoise";
 
+  nativeBuildInputs = [ makeWrapper ];
   buildInputs = [ libX11 libXext libXcursor libXrandr alsaLib libjack2 ];
 
   installPhase = ''
@@ -56,11 +58,12 @@ stdenv.mkDerivation rec {
     ln -s $out/renoise $out/bin/renoise
 
     patchelf --set-interpreter $(cat $NIX_CC/nix-support/dynamic-linker) --set-rpath $out/lib $out/renoise
+    wrapProgram "$out/renoise" --prefix LD_LIBRARY_PATH : "${mpg123}/lib"
   '';
 
   meta = {
     description = "Modern tracker-based DAW";
-    homepage = http://www.renoise.com/;
+    homepage = https://www.renoise.com/;
     license = licenses.unfree;
     maintainers = [];
     platforms = [ "i686-linux" "x86_64-linux" ];