about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAntoine Eiche <lewo@abesis.fr>2019-09-10 22:16:33 +0200
committerAntoine Eiche <lewo@abesis.fr>2019-09-19 22:28:36 +0200
commit1c7d3389e43b2836a8f5de10f648833d610e86b2 (patch)
treeb1e0bf5990e49473dced34e46af68e97164e26a6 /pkgs/applications
parent6309561d397076b0cabd8ef5ae8045c9e29b2241 (diff)
downloadnixlib-1c7d3389e43b2836a8f5de10f648833d610e86b2.tar
nixlib-1c7d3389e43b2836a8f5de10f648833d610e86b2.tar.gz
nixlib-1c7d3389e43b2836a8f5de10f648833d610e86b2.tar.bz2
nixlib-1c7d3389e43b2836a8f5de10f648833d610e86b2.tar.lz
nixlib-1c7d3389e43b2836a8f5de10f648833d610e86b2.tar.xz
nixlib-1c7d3389e43b2836a8f5de10f648833d610e86b2.tar.zst
nixlib-1c7d3389e43b2836a8f5de10f648833d610e86b2.zip
next: init at 1.3.1
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/next-gtk-webkit/default.nix25
-rw-r--r--pkgs/applications/networking/browsers/next/default.nix80
2 files changed, 105 insertions, 0 deletions
diff --git a/pkgs/applications/networking/browsers/next-gtk-webkit/default.nix b/pkgs/applications/networking/browsers/next-gtk-webkit/default.nix
new file mode 100644
index 000000000000..6ab533763109
--- /dev/null
+++ b/pkgs/applications/networking/browsers/next-gtk-webkit/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, gcc7, pkg-config
+, next
+, webkitgtk, gsettings-desktop-schemas
+}:
+
+stdenv.mkDerivation rec {
+  pname = "next-gtk-webkit";
+  inherit (next) src version;
+
+  makeFlags = [ "gtk-webkit" "PREFIX=$(out)" ];
+  installTargets = "install-gtk-webkit";
+
+  nativeBuildInputs = [ gcc7 pkg-config ];
+  buildInputs = [
+    webkitgtk
+    gsettings-desktop-schemas
+  ];
+  meta = with stdenv.lib; {
+    description = "Infinitely extensible web-browser (user interface only)";
+    homepage = https://next.atlas.engineer;
+    license = licenses.bsd3;
+    maintainers = [ maintainers.lewo ];
+    platforms = [ "x86_64-linux" ];
+  };
+}
diff --git a/pkgs/applications/networking/browsers/next/default.nix b/pkgs/applications/networking/browsers/next/default.nix
new file mode 100644
index 000000000000..2b2e173342c5
--- /dev/null
+++ b/pkgs/applications/networking/browsers/next/default.nix
@@ -0,0 +1,80 @@
+{ pkgs, stdenv, fetchFromGitHub
+, gcc7, pkg-config, makeWrapper
+, glib-networking
+, next-gtk-webkit
+, lispPackages
+, sbcl
+}:
+
+stdenv.mkDerivation rec {
+    pname = "next";
+    version = "1.3.1";
+
+    src = fetchFromGitHub {
+      owner = "atlas-engineer";
+      repo = "next";
+      rev = version;
+      sha256 = "01fn1f080ydk0wj1bwkyakqz93bdq9xb5x8qz820jpl9id17bqgj";
+    };
+
+    # Stripping destroys the generated SBCL image
+    dontStrip = true;
+
+    prePatch = ''
+      substituteInPlace source/ports/gtk-webkit.lisp \
+        --replace "next-gtk-webkit" "${next-gtk-webkit}/bin/next-gtk-webkit"
+    '';
+
+    nativeBuildInputs = [ sbcl makeWrapper ];
+    buildInputs = with lispPackages; [
+      trivial-features
+      trivial-garbage
+      alexandria
+      bordeaux-threads
+      cl-json
+      cl-markup
+      cl-ppcre
+      cl-ppcre-unicode
+      closer-mop
+      dexador
+      ironclad
+      lparallel
+      parenscript
+      quri
+      cl-css
+      log4cl
+      mk-string-metrics
+      sqlite
+      str
+      swank
+      trivia
+      trivial-clipboard
+      unix-opts
+      dbus
+    ];
+    propagatedBuildInputs = [ next-gtk-webkit ];
+
+    buildPhase = ''
+      common-lisp.sh --eval "(require :asdf)" \
+                     --eval "(asdf:load-asd (truename \"next.asd\") :name \"next\")" \
+                     --eval '(asdf:make :next)' \
+                     --quit
+    '';
+
+    installPhase = ''
+      install -D -m0755 next $out/bin/next
+    '';
+
+    preFixup = ''
+      wrapProgram $out/bin/next \
+        --prefix GIO_EXTRA_MODULES : "${glib-networking.out}/lib/gio/modules"
+    '';
+
+    meta = with stdenv.lib; {
+      description = "Infinitely extensible web-browser (with Lisp development files)";
+      homepage = https://next.atlas.engineer;
+      license = licenses.bsd3;
+      maintainers = [ maintainers.lewo ];
+      platforms = [ "x86_64-linux" ];
+    };
+  }