about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoruHOOCCOOHu <hooccooh1896@gmail.com>2019-07-11 00:15:44 +0800
committeruHOOCCOOHu <hooccooh1896@gmail.com>2019-07-11 00:15:44 +0800
commit1bc8cd8ff5fb4b6756bf23289693d8e24f7fa07f (patch)
tree892be2333b13d81c05be2b477df3649e2d98e8a4 /pkgs/applications
parent11b8159328358cc90165017a0cc9de3fc18c99d0 (diff)
downloadnixlib-1bc8cd8ff5fb4b6756bf23289693d8e24f7fa07f.tar
nixlib-1bc8cd8ff5fb4b6756bf23289693d8e24f7fa07f.tar.gz
nixlib-1bc8cd8ff5fb4b6756bf23289693d8e24f7fa07f.tar.bz2
nixlib-1bc8cd8ff5fb4b6756bf23289693d8e24f7fa07f.tar.lz
nixlib-1bc8cd8ff5fb4b6756bf23289693d8e24f7fa07f.tar.xz
nixlib-1bc8cd8ff5fb4b6756bf23289693d8e24f7fa07f.tar.zst
nixlib-1bc8cd8ff5fb4b6756bf23289693d8e24f7fa07f.zip
tdesktop: 1.7.10 -> 1.7.14
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix8
-rw-r--r--pkgs/applications/networking/instant-messengers/telegram/tdesktop/generic.nix22
2 files changed, 19 insertions, 11 deletions
diff --git a/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix b/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
index 14289a66e259..3e5294815084 100644
--- a/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
+++ b/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
@@ -4,11 +4,11 @@ let
   mkTelegram = args: qt5.callPackage (import ./generic.nix args) { };
   stableVersion = {
     stable = true;
-    version = "1.7.10";
-    sha256Hash = "04if7siv0ib5sbdkdc7vwmxyjy3fnijrshgc8i8m79marfkn3wac";
+    version = "1.7.14";
+    sha256Hash = "1bw804a9kffmn23wv0570wihbvfm7jy9cqmxlv196f4j7bw7zkv3";
     # svn log svn://svn.archlinux.org/community/telegram-desktop/trunk
-    archPatchesRevision = "480743";
-    archPatchesHash = "0jfyp642l2850yzgrw3irq8bn6vl44rx2693c5cshwbihd212af7";
+    archPatchesRevision = "487779";
+    archPatchesHash = "0f09hvimb66xqksb2v0zc4ryshx7y7z0rafzjd99x37rpib9f3kq";
   };
 in {
   stable = mkTelegram stableVersion;
diff --git a/pkgs/applications/networking/instant-messengers/telegram/tdesktop/generic.nix b/pkgs/applications/networking/instant-messengers/telegram/tdesktop/generic.nix
index ef9367553ff3..df06dc49eef4 100644
--- a/pkgs/applications/networking/instant-messengers/telegram/tdesktop/generic.nix
+++ b/pkgs/applications/networking/instant-messengers/telegram/tdesktop/generic.nix
@@ -28,13 +28,17 @@ mkDerivation rec {
     sha256 = archPatchesHash;
   };
 
-  # TODO: libtgvoip.patch no-gtk2.patch
-  # TODO: Avoid tdesktop_lottie_animation_qtdebug.patch and tdesktop_qtlottie_qtdebug.patch
-  patches = [ "${archPatches}/tdesktop.patch" "${archPatches}/tdesktop_lottie_animation_qtdebug.patch" ];
+  patches = [
+    "${archPatches}/tdesktop.patch"
+    "${archPatches}/no-gtk2.patch"
+    # "${archPatches}/Use-system-wide-font.patch"
+    "${archPatches}/tdesktop_lottie_animation_qtdebug.patch"
+    "${archPatches}/issue6219.patch"
+  ];
 
   postPatch = ''
     substituteInPlace Telegram/SourceFiles/platform/linux/linux_libs.cpp \
-      --replace '"appindicator"' '"${libappindicator-gtk3}/lib/libappindicator3.so"'
+      --replace '"appindicator3"' '"${libappindicator-gtk3}/lib/libappindicator3.so"'
     substituteInPlace Telegram/SourceFiles/platform/linux/linux_libnotify.cpp \
       --replace '"notify"' '"${libnotify}/lib/libnotify.so"'
   '';
@@ -75,12 +79,14 @@ mkDerivation rec {
   CPPFLAGS = NIX_CFLAGS_COMPILE;
 
   preConfigure = ''
+    patch -R -Np1 -i "${archPatches}/demibold.patch"
+
     pushd "Telegram/ThirdParty/libtgvoip"
     patch -Np1 -i "${archPatches}/libtgvoip.patch"
     popd
-    pushd "Telegram/ThirdParty/qtlottie"
-    patch -Np1 -i "${archPatches}/tdesktop_qtlottie_qtdebug.patch"
-    popd
+
+    # disable static-qt for rlottie
+    sed "/RLOTTIE_WITH_STATIC_QT/d" -i "Telegram/gyp/lib_rlottie.gyp"
 
     sed -i Telegram/gyp/telegram_linux.gypi \
       -e 's,/usr,/does-not-exist,g' \
@@ -118,6 +124,8 @@ mkDerivation rec {
     export ASM=$(type -p gcc)
   '';
 
+  cmakeFlags = [ "-UTDESKTOP_OFFICIAL_TARGET" ];
+
   installPhase = ''
     install -Dm755 Telegram $out/bin/telegram-desktop