about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRam Kromberg <ramkromberg@mail.com>2016-07-01 18:40:21 +0300
committerRam Kromberg <ramkromberg@mail.com>2016-07-03 01:43:34 +0300
commit1bbcd91b2ef0738709f7d955760a6624a9745fc2 (patch)
tree8e6e065a17e9d6f0972d69dd68fa032a0a9cbc7f /pkgs/applications
parent1c0af40757c6bf9c15bd50888c79ff27682df7e1 (diff)
downloadnixlib-1bbcd91b2ef0738709f7d955760a6624a9745fc2.tar
nixlib-1bbcd91b2ef0738709f7d955760a6624a9745fc2.tar.gz
nixlib-1bbcd91b2ef0738709f7d955760a6624a9745fc2.tar.bz2
nixlib-1bbcd91b2ef0738709f7d955760a6624a9745fc2.tar.lz
nixlib-1bbcd91b2ef0738709f7d955760a6624a9745fc2.tar.xz
nixlib-1bbcd91b2ef0738709f7d955760a6624a9745fc2.tar.zst
nixlib-1bbcd91b2ef0738709f7d955760a6624a9745fc2.zip
spacefm: sudo and gksu fixes #15758 and license update
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/spacefm/default.nix19
1 files changed, 13 insertions, 6 deletions
diff --git a/pkgs/applications/misc/spacefm/default.nix b/pkgs/applications/misc/spacefm/default.nix
index f0c244af05e7..74466d667b3c 100644
--- a/pkgs/applications/misc/spacefm/default.nix
+++ b/pkgs/applications/misc/spacefm/default.nix
@@ -1,6 +1,6 @@
-{ pkgs, fetchFromGitHub, stdenv, gtk3, udev, desktop_file_utils, shared_mime_info
-, intltool, pkgconfig, wrapGAppsHook, ffmpegthumbnailer, jmtpfs, ifuse, lsof, udisks
-, hicolor_icon_theme, adwaita-icon-theme }:
+{ pkgs, fetchFromGitHub, stdenv, gtk3, udev, desktop_file_utils
+, shared_mime_info, intltool, pkgconfig, wrapGAppsHook, ffmpegthumbnailer
+, jmtpfs, ifuse, lsof, udisks, hicolor_icon_theme, adwaita-icon-theme }:
 
 stdenv.mkDerivation rec {
   name = "spacefm-${version}";
@@ -15,14 +15,21 @@ stdenv.mkDerivation rec {
 
   configureFlags = [
     "--with-bash-path=${pkgs.bash}/bin/bash"
-    "--with-preferable-sudo=${pkgs.sudo}/bin/sudo"
   ];
 
   preConfigure = ''
     configureFlags="$configureFlags --sysconfdir=$out/etc"
   '';
 
-  buildInputs = [ gtk3 udev desktop_file_utils shared_mime_info intltool pkgconfig wrapGAppsHook ffmpegthumbnailer jmtpfs ifuse lsof udisks ];
+  postInstall = ''
+    rm -f $out/etc/spacefm/spacefm.conf
+    ln -s /etc/spacefm/spacefm.conf $out/etc/spacefm/spacefm.conf 
+  '';
+
+  buildInputs = [
+    gtk3 udev desktop_file_utils shared_mime_info intltool pkgconfig
+    wrapGAppsHook ffmpegthumbnailer jmtpfs ifuse lsof udisks
+  ];
 
   meta = with stdenv.lib;  {
     description = "A multi-panel tabbed file manager";
@@ -33,7 +40,7 @@ stdenv.mkDerivation rec {
     '';
     homepage = http://ignorantguru.github.io/spacefm/;
     platforms = platforms.linux;
-    license = licenses.gpl3;
+    license = licenses.gpl3Plus;
     maintainers = with maintainers; [ jagajaga obadz ];
   };
 }