about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorBryan Lai <bryanlais@gmail.com>2024-03-11 22:42:11 +0800
committerBryan Lai <bryanlais@gmail.com>2024-03-11 22:42:34 +0800
commit18e2854db00c9cd7c6c9a3c98e77af556e1f7519 (patch)
tree3cdc22c3f1d382eeb68cddd622f5b4ad16c8d779 /pkgs/applications
parenta343533bccc62400e8a9560423486a3b6c11a23b (diff)
downloadnixlib-18e2854db00c9cd7c6c9a3c98e77af556e1f7519.tar
nixlib-18e2854db00c9cd7c6c9a3c98e77af556e1f7519.tar.gz
nixlib-18e2854db00c9cd7c6c9a3c98e77af556e1f7519.tar.bz2
nixlib-18e2854db00c9cd7c6c9a3c98e77af556e1f7519.tar.lz
nixlib-18e2854db00c9cd7c6c9a3c98e77af556e1f7519.tar.xz
nixlib-18e2854db00c9cd7c6c9a3c98e77af556e1f7519.tar.zst
nixlib-18e2854db00c9cd7c6c9a3c98e77af556e1f7519.zip
pulsar: 1.109.0 -> 1.114.0
Release notes: https://github.com/pulsar-edit/pulsar/releases/tag/v1.114.0

pulsar has been marked insecure so this change would not be verified by
ofborg. Still, it is very actively developed and quite enjoyable to use.
As an atom veteran, I would like to help keep it usable; thus adding
myself to the maintainers.

A patchelf fixup for `ctags-linux` is adjusted according to the new
location of the binary.

Co-authored-by: Peder Bergebakken Sundt <pbsds@hotmail.com>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/pulsar/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/applications/editors/pulsar/default.nix b/pkgs/applications/editors/pulsar/default.nix
index ef08ac9352dd..b1af335ec1d4 100644
--- a/pkgs/applications/editors/pulsar/default.nix
+++ b/pkgs/applications/editors/pulsar/default.nix
@@ -33,13 +33,13 @@
 
 let
   pname = "pulsar";
-  version = "1.109.0";
+  version = "1.114.0";
 
   sourcesPath = {
     x86_64-linux.tarname = "Linux.${pname}-${version}.tar.gz";
-    x86_64-linux.hash = "sha256-pIm3mI1YdfapxXgIciSHtI4LeqMw5RdYTnH+eHUQ4Yo=";
+    x86_64-linux.hash = "sha256-O//dowoMgQfS3hq088IKr5aJd5St9zpT/ypfuswnyv0=";
     aarch64-linux.tarname = "ARM.Linux.${pname}-${version}-arm64.tar.gz";
-    aarch64-linux.hash = "sha256-KIY/qzfl7CU0YwIgQlNHoAMhLfrTbQe7ZZvzdkUVw+M=";
+    aarch64-linux.hash = "sha256-EzCTB1Ib9cTbslEdXPsS5gehHr1qd5v4iZgOqpxhUmA=";
   }.${stdenv.hostPlatform.system} or (throw "Unsupported system: ${stdenv.hostPlatform.system}");
 
   newLibpath = lib.makeLibraryPath [
@@ -137,7 +137,7 @@ stdenv.mkDerivation rec {
       --set-rpath "${newLibpath}" \
       $opt/resources/app/ppm/bin/node
     patchelf --set-interpreter "$(cat $NIX_CC/nix-support/dynamic-linker)" \
-      $opt/resources/app.asar.unpacked/node_modules/symbols-view/vendor/ctags-linux
+      $opt/resources/app.asar.unpacked/node_modules/symbol-provider-ctags/vendor/ctags-linux
 
   '' + lib.optionalString (stdenv.hostPlatform.system == "x86_64-linux") ''
     # Replace the bundled git with the one from nixpkgs
@@ -208,7 +208,7 @@ stdenv.mkDerivation rec {
     sourceProvenance = with sourceTypes; [ binaryNativeCode ];
     license = licenses.mit;
     platforms = platforms.linux;
-    maintainers = with maintainers; [ colamaroro ];
+    maintainers = with maintainers; [ colamaroro bryango ];
     knownVulnerabilities = [
       "CVE-2023-5217"
       "CVE-2022-21718"