about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMarek Mahut <marek.mahut@gmail.com>2019-08-25 19:54:03 +0200
committerGitHub <noreply@github.com>2019-08-25 19:54:03 +0200
commit18dfe1a3f5114872e00a019e2a339286ed649f82 (patch)
tree926e19b9ce92cf12afc674c0a445dda344bb4a40 /pkgs/applications
parentbba3f5f14464628b50fa582705f7d394b3c40f97 (diff)
parent1a6d3f5bc25a1cd8879f25d1086aa63eb810d4ff (diff)
downloadnixlib-18dfe1a3f5114872e00a019e2a339286ed649f82.tar
nixlib-18dfe1a3f5114872e00a019e2a339286ed649f82.tar.gz
nixlib-18dfe1a3f5114872e00a019e2a339286ed649f82.tar.bz2
nixlib-18dfe1a3f5114872e00a019e2a339286ed649f82.tar.lz
nixlib-18dfe1a3f5114872e00a019e2a339286ed649f82.tar.xz
nixlib-18dfe1a3f5114872e00a019e2a339286ed649f82.tar.zst
nixlib-18dfe1a3f5114872e00a019e2a339286ed649f82.zip
Merge pull request #67449 from mmahut/jormungandr
nixos/jormungandr: adding genesis tests
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/jormungandr/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/applications/altcoins/jormungandr/default.nix b/pkgs/applications/altcoins/jormungandr/default.nix
index abfd3fa51718..8c276d6bb805 100644
--- a/pkgs/applications/altcoins/jormungandr/default.nix
+++ b/pkgs/applications/altcoins/jormungandr/default.nix
@@ -24,6 +24,22 @@ rustPlatform.buildRustPackage rec {
   nativeBuildInputs = [ pkgconfig protobuf ];
   buildInputs = [ openssl ] ++ lib.optionals stdenv.isDarwin [ darwin.apple_sdk.frameworks.Security ];
 
+  patchPhase = ''
+    sed -i "s~SCRIPTPATH=.*~SCRIPTPATH=$out/templates/~g" scripts/bootstrap
+  '';
+
+  installPhase = ''
+    install -d $out/bin $out/templates
+    install -m755 target/*/release/jormungandr $out/bin/
+    install -m755 target/*/release/jcli $out/bin/
+    install -m755 scripts/send-transaction $out/templates
+    install -m755 scripts/jcli-helpers $out/bin/
+    install -m755 scripts/bootstrap $out/bin/jormungandr-bootstrap
+    install -m644 scripts/faucet-send-money.shtempl $out/templates/
+    install -m644 scripts/create-account-and-delegate.shtempl $out/templates/
+    install -m644 scripts/faucet-send-certificate.shtempl $out/templates/
+  '';
+
   PROTOC = "${protobuf}/bin/protoc";
 
   # Disabling integration tests