about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDoron Behar <doron.behar@gmail.com>2019-08-25 17:42:41 +0300
committerTimo Kaufmann <timokau@zoho.com>2019-08-25 16:42:41 +0200
commit1859271a4b8dc0e7be43a9f61c6dae3ccae2a3b9 (patch)
treebe6ad9cda84285fe682040e351bde1c70e97fc9a /pkgs/applications
parente19411ecc0b0e8ba74e253c3e516520eb92a5c75 (diff)
downloadnixlib-1859271a4b8dc0e7be43a9f61c6dae3ccae2a3b9.tar
nixlib-1859271a4b8dc0e7be43a9f61c6dae3ccae2a3b9.tar.gz
nixlib-1859271a4b8dc0e7be43a9f61c6dae3ccae2a3b9.tar.bz2
nixlib-1859271a4b8dc0e7be43a9f61c6dae3ccae2a3b9.tar.lz
nixlib-1859271a4b8dc0e7be43a9f61c6dae3ccae2a3b9.tar.xz
nixlib-1859271a4b8dc0e7be43a9f61c6dae3ccae2a3b9.tar.zst
nixlib-1859271a4b8dc0e7be43a9f61c6dae3ccae2a3b9.zip
stig: init at 0.10.1a0 (#67233)
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/p2p/stig/default.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/pkgs/applications/networking/p2p/stig/default.nix b/pkgs/applications/networking/p2p/stig/default.nix
new file mode 100644
index 000000000000..80b8251f2a3f
--- /dev/null
+++ b/pkgs/applications/networking/p2p/stig/default.nix
@@ -0,0 +1,56 @@
+{ lib
+, fetchFromGitHub
+, python3
+}:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "stig";
+  # This project has a different concept for pre release / alpha,
+  # Read the project's README for details: https://github.com/rndusr/stig#stig
+  version = "0.10.1a";
+
+  src = fetchFromGitHub {
+    owner = "rndusr";
+    repo = "stig";
+    rev = "v${version}";
+    sha256 = "076rlial6h1nhwdxf1mx5nf2zld5ci43cadj9wf8xms7zn8s6c8v";
+  };
+
+  # urwidtrees 1.0.3 is requested by the developer because 1.0.2 (which is packaged
+  # in nixpkgs) is not uploaded to pypi and 1.0.1 has a problematic `setup.py`.
+  # As long as we don't have any problems installing it, no special features / specific bugs
+  # were fixed in 1.0.3 that aren't available in 1.0.2 are used by stig.
+  # See https://github.com/rndusr/stig/issues/120
+  postPatch = ''
+    substituteInPlace setup.py \
+      --replace "urwidtrees>=1.0.3dev0" "urwidtrees"
+  '';
+
+  buildInputs = with python3.pkgs; [
+    urwid
+    urwidtrees
+    aiohttp
+    async-timeout
+    pyxdg
+    blinker
+    natsort
+    maxminddb
+    setproctitle
+  ];
+
+  checkInputs = with python3.pkgs; [
+    asynctest
+    pytest
+  ];
+
+  checkPhase = ''
+    pytest tests
+  '';
+
+  meta = with lib; {
+    description = "TUI and CLI for the BitTorrent client Transmission";
+    homepage = "https://github.com/rndusr/stig";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ doronbehar ];
+  };
+}