about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDamien Cassou <damien@cassou.me>2016-07-01 11:06:37 +0200
committerGitHub <noreply@github.com>2016-07-01 11:06:37 +0200
commit17f822a456fa3f119154e9ce8f916ccdbeca6b36 (patch)
treee8f7d1c8e31d56ff002f2e423a53f4e586c14c57 /pkgs/applications
parenta441a7c2579a8310296bb85ee863fb12216a3b26 (diff)
parent44f885a0a389f6a8cfc38a578318140f8f1fa311 (diff)
downloadnixlib-17f822a456fa3f119154e9ce8f916ccdbeca6b36.tar
nixlib-17f822a456fa3f119154e9ce8f916ccdbeca6b36.tar.gz
nixlib-17f822a456fa3f119154e9ce8f916ccdbeca6b36.tar.bz2
nixlib-17f822a456fa3f119154e9ce8f916ccdbeca6b36.tar.lz
nixlib-17f822a456fa3f119154e9ce8f916ccdbeca6b36.tar.xz
nixlib-17f822a456fa3f119154e9ce8f916ccdbeca6b36.tar.zst
nixlib-17f822a456fa3f119154e9ce8f916ccdbeca6b36.zip
Merge pull request #16637 from DamienCassou/tnef-1.4.12
tnef: init at 1.4.12
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/tnef/default.nix32
-rw-r--r--pkgs/applications/misc/tnef/tnef/default.nix30
2 files changed, 62 insertions, 0 deletions
diff --git a/pkgs/applications/misc/tnef/default.nix b/pkgs/applications/misc/tnef/default.nix
new file mode 100644
index 000000000000..b59f1a437106
--- /dev/null
+++ b/pkgs/applications/misc/tnef/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchFromGitHub, lib, autoreconfHook }:
+
+stdenv.mkDerivation rec {
+  version = "1.4.12";
+  name = "tnef-${version}";
+
+  src = fetchFromGitHub {
+    owner = "verdammelt";
+    repo = "tnef";
+    rev = "${version}";
+    sha256 = "02hwdaaa3yk0lbzb40fgxlkyhc1wicl6ncajpvfcz888z6yxps2c";
+  };
+
+  doCheck = true;
+
+  nativeBuildInputs = [ autoreconfHook ];
+
+  meta = with lib; {
+    description = "Unpacks MIME attachments of type application/ms-tnef";
+    longDescription = ''
+      TNEF is a program for unpacking MIME attachments of type "application/ms-tnef". This is a Microsoft only attachment.
+
+      Due to the proliferation of Microsoft Outlook and Exchange mail servers, more and more mail is encapsulated into this format.
+
+      The TNEF program allows one to unpack the attachments which were encapsulated into the TNEF attachment. Thus alleviating the need to use Microsoft Outlook to view the attachment.
+    '';
+    homepage = https://github.com/verdammelt/tnef;
+    license = licenses.gpl2;
+    maintainers = [ maintainers.DamienCassou ];
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/applications/misc/tnef/tnef/default.nix b/pkgs/applications/misc/tnef/tnef/default.nix
new file mode 100644
index 000000000000..3256ed1a5706
--- /dev/null
+++ b/pkgs/applications/misc/tnef/tnef/default.nix
@@ -0,0 +1,30 @@
+{ fetchurl, lib }:
+
+stdenv.mkDerivation rec {
+  version = "1.4.12";
+  name = "tnef-${version}";
+
+  src = fetchFromGitHub {
+    owner = "verdammelt";
+    repo = "tnef";
+    rev = "${version}";
+    sha256 = "0ssi2wpaf7plaswqqjwigppsg5fyh99vdlb9kzl7c9lng89ndq1i";
+  };
+
+  doCheck = true;
+
+  meta = with lib; {
+    description = "Unpacks MIME attachments of type application/ms-tnef";
+    longDescription = ''
+      TNEF is a program for unpacking MIME attachments of type "application/ms-tnef". This is a Microsoft only attachment.
+
+      Due to the proliferation of Microsoft Outlook and Exchange mail servers, more and more mail is encapsulated into this format.
+
+      The TNEF program allows one to unpack the attachments which were encapsulated into the TNEF attachment. Thus alleviating the need to use Microsoft Outlook to view the attachment.
+    '';
+    homepage = https://github.com/verdammelt/tnef;
+    license = licenses.gpl2;
+    maintainers = [ maintainers.DamienCassou ];
+    platforms = platforms.all;
+  };
+}