about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRyan Mulligan <ryan@ryantm.com>2019-02-17 19:00:35 -0800
committerGitHub <noreply@github.com>2019-02-17 19:00:35 -0800
commit174b9386a14763e2b2fe6de9b3b91df58008fc3a (patch)
treec357bef221616e8d4e986f145cd4e4d850503eff /pkgs/applications
parenta3f85f0dc099a53e4e059a73605f09e10605c2c0 (diff)
parent96ac29b2e097be8e3dbcbb27d5bee72d7ceffb83 (diff)
downloadnixlib-174b9386a14763e2b2fe6de9b3b91df58008fc3a.tar
nixlib-174b9386a14763e2b2fe6de9b3b91df58008fc3a.tar.gz
nixlib-174b9386a14763e2b2fe6de9b3b91df58008fc3a.tar.bz2
nixlib-174b9386a14763e2b2fe6de9b3b91df58008fc3a.tar.lz
nixlib-174b9386a14763e2b2fe6de9b3b91df58008fc3a.tar.xz
nixlib-174b9386a14763e2b2fe6de9b3b91df58008fc3a.tar.zst
nixlib-174b9386a14763e2b2fe6de9b3b91df58008fc3a.zip
Merge pull request #55954 from worldofpeace/bump-hub
gitAndTools.hub: 2.7.0 -> 2.9.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/git-and-tools/hub/default.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/pkgs/applications/version-management/git-and-tools/hub/default.nix b/pkgs/applications/version-management/git-and-tools/hub/default.nix
index c6e62265b95b..8ae600ed3605 100644
--- a/pkgs/applications/version-management/git-and-tools/hub/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/hub/default.nix
@@ -1,25 +1,26 @@
-{ stdenv, buildGoPackage, fetchFromGitHub, ronn, ruby, groff, Security, utillinux }:
+{ stdenv, buildGoPackage, fetchFromGitHub, ronn, ruby, groff, Security, utillinux, git, glibcLocales }:
 
 buildGoPackage rec {
-  name = "hub-${version}";
-  version = "2.7.0";
+  pname = "hub";
+  version = "2.9.0";
 
   goPackagePath = "github.com/github/hub";
 
+  # Only needed to build the man-pages
+  excludedPackages = [ "github.com/github/hub/md2roff-bin" ];
+
   src = fetchFromGitHub {
     owner = "github";
-    repo = "hub";
+    repo = pname;
     rev = "v${version}";
-    sha256 = "1p90m1xp3jahs5y0lp0qfmfa7wqn7gxyygn7x45a6cbf2zzlb86l";
+    sha256 = "0yxpr606xx23l8823hjqj16cvjjrwb28c7z08ml1pkfvaf7w4n81";
   };
 
-  nativeBuildInputs = [ groff ronn utillinux ];
+  nativeBuildInputs = [ groff ronn utillinux glibcLocales ];
   buildInputs = [ ruby ] ++
     stdenv.lib.optional stdenv.isDarwin Security;
 
   postPatch = ''
-    mkdir bin
-    ln -s ${ronn}/bin/ronn bin/ronn
     patchShebangs .
   '';
 
@@ -29,13 +30,12 @@ buildGoPackage rec {
     install -D etc/hub.bash_completion.sh "$bin/share/bash-completion/completions/hub"
     install -D etc/hub.fish_completion  "$bin/share/fish/vendor_completions.d/hub.fish"
 
-    make man-pages
+    PATH=$PATH:${git}/bin LC_ALL=en_US.utf-8 make man-pages
     cp -vr --parents share/man/man[1-9]/*.[1-9] $bin/
   '';
 
   meta = with stdenv.lib; {
     description = "Command-line wrapper for git that makes you better at GitHub";
-
     license = licenses.mit;
     homepage = https://hub.github.com/;
     maintainers = with maintainers; [ the-kenny ];