about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFabian Affolter <mail@fabian-affolter.ch>2024-03-19 10:02:26 +0100
committerFabian Affolter <mail@fabian-affolter.ch>2024-03-20 14:30:54 +0100
commit155be2eb13821dddd9099cc78c9adbe3b26d664d (patch)
treec208dd09895537f020c596883d0ba09fd91cf1b2 /pkgs/applications
parent65c8c9eb41d9de63d12684247a3faee1e9a278ae (diff)
downloadnixlib-155be2eb13821dddd9099cc78c9adbe3b26d664d.tar
nixlib-155be2eb13821dddd9099cc78c9adbe3b26d664d.tar.gz
nixlib-155be2eb13821dddd9099cc78c9adbe3b26d664d.tar.bz2
nixlib-155be2eb13821dddd9099cc78c9adbe3b26d664d.tar.lz
nixlib-155be2eb13821dddd9099cc78c9adbe3b26d664d.tar.xz
nixlib-155be2eb13821dddd9099cc78c9adbe3b26d664d.tar.zst
nixlib-155be2eb13821dddd9099cc78c9adbe3b26d664d.zip
tftui: 0.12.4 -> 0.12.6
Changelog: https://github.com/idoavrah/terraform-tui/releases/tag/v0.12.6
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/cluster/tftui/default.nix41
1 files changed, 21 insertions, 20 deletions
diff --git a/pkgs/applications/networking/cluster/tftui/default.nix b/pkgs/applications/networking/cluster/tftui/default.nix
index 3a9d657dbdd2..5ef3142ee69d 100644
--- a/pkgs/applications/networking/cluster/tftui/default.nix
+++ b/pkgs/applications/networking/cluster/tftui/default.nix
@@ -1,27 +1,33 @@
 { lib
-, buildPythonApplication
-, fetchPypi
+, fetchFromGitHub
 , makeWrapper
-, poetry-core
-, posthog
-, pyperclip
-, requests
-, rich
-, textual
+, python3
 , enableUsageTracking ? false
 }:
 
-buildPythonApplication rec {
+python3.pkgs.buildPythonApplication rec {
   pname = "tftui";
-  version = "0.12.4";
+  version = "0.12.6";
   pyproject = true;
 
-  src = fetchPypi {
-    inherit pname version;
-    hash = "sha256-E4Y0qA7SooMlHh+oSFUl1hfblpirr/Jdb1C2fqU43t0=";
+  src = fetchFromGitHub {
+    owner = "idoavrah";
+    repo = "terraform-tui";
+    rev = "refs/tags/v${version}";
+    hash = "sha256-vK1qKf8+RxwHUpuEQ97PcwGvObNVpd88kAb3DFRoRG0=";
   };
 
-  propagatedBuildInputs = [
+  pythonRelaxDeps = [
+    "textual"
+  ];
+
+  nativeBuildInputs = with python3.pkgs; [
+    makeWrapper
+    poetry-core
+    pythonRelaxDepsHook
+  ];
+
+  propagatedBuildInputs = with python3.pkgs; [
     posthog
     pyperclip
     requests
@@ -29,11 +35,6 @@ buildPythonApplication rec {
     textual
   ];
 
-  nativeBuildInputs = [
-    makeWrapper
-    poetry-core
-  ];
-
   pythonImportsCheck = [
     "tftui"
   ];
@@ -46,7 +47,7 @@ buildPythonApplication rec {
   meta = with lib; {
     description = "Textual UI to view and interact with Terraform state";
     homepage = "https://github.com/idoavrah/terraform-tui";
-    changelog = "https://github.com/idoavrah/terraform-tui/releases";
+    changelog = "https://github.com/idoavrah/terraform-tui/releases/tag/v${version}";
     license = licenses.asl20;
     maintainers = with maintainers; teams.bitnomial.members;
     mainProgram = "tftui";