about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-07-15 21:41:28 +0200
committerGitHub <noreply@github.com>2021-07-15 21:41:28 +0200
commit14804e2ff46e80561e5036ec5fd50f24442d6090 (patch)
tree929a5ec83416059956cf032054e439123690f171 /pkgs/applications
parente3e5a9178fc8f8be3c41d83cfa0a687a6dd277ac (diff)
parent74af8f2d6b62bf4fa504189f68a24b3cb4a361a3 (diff)
downloadnixlib-14804e2ff46e80561e5036ec5fd50f24442d6090.tar
nixlib-14804e2ff46e80561e5036ec5fd50f24442d6090.tar.gz
nixlib-14804e2ff46e80561e5036ec5fd50f24442d6090.tar.bz2
nixlib-14804e2ff46e80561e5036ec5fd50f24442d6090.tar.lz
nixlib-14804e2ff46e80561e5036ec5fd50f24442d6090.tar.xz
nixlib-14804e2ff46e80561e5036ec5fd50f24442d6090.tar.zst
nixlib-14804e2ff46e80561e5036ec5fd50f24442d6090.zip
Merge pull request #130226 from Artturin/spotify-fix
spotify-unwrapped: add wrapGAppsHook to fix #120070
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/spotify/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/applications/audio/spotify/default.nix b/pkgs/applications/audio/spotify/default.nix
index db0f69c80abe..d81ab4b3ac72 100644
--- a/pkgs/applications/audio/spotify/default.nix
+++ b/pkgs/applications/audio/spotify/default.nix
@@ -1,4 +1,4 @@
-{ fetchurl, lib, stdenv, squashfsTools, xorg, alsa-lib, makeWrapper, openssl, freetype
+{ fetchurl, lib, stdenv, squashfsTools, xorg, alsa-lib, makeWrapper, wrapGAppsHook, openssl, freetype
 , glib, pango, cairo, atk, gdk-pixbuf, gtk3, cups, nspr, nss, libpng, libnotify
 , libgcrypt, systemd, fontconfig, dbus, expat, ffmpeg, curl, zlib, gnome
 , at-spi2-atk, at-spi2-core, libpulseaudio, libdrm, mesa, libxkbcommon
@@ -82,7 +82,7 @@ stdenv.mkDerivation {
     sha512 = "dabb55d2ba41f977b6d3f03bfcf147d11785136dd1277efc62011c8371ef25cc04531266bd16608639b9b6a500c1a18a45f44ba7a43e17ab5ac139e36eff7149";
   };
 
-  nativeBuildInputs = [ makeWrapper squashfsTools ];
+  nativeBuildInputs = [ makeWrapper wrapGAppsHook squashfsTools ];
 
   dontStrip = true;
   dontPatchELF = true;
@@ -109,6 +109,9 @@ stdenv.mkDerivation {
     runHook postUnpack
   '';
 
+  # Prevent double wrapping
+  dontWrapGApps = true;
+
   installPhase =
     ''
       runHook preInstall
@@ -138,6 +141,7 @@ stdenv.mkDerivation {
 
       librarypath="${lib.makeLibraryPath deps}:$libdir"
       wrapProgram $out/share/spotify/spotify \
+        ''${gappsWrapperArgs[@]} \
         --prefix LD_LIBRARY_PATH : "$librarypath" \
         --prefix PATH : "${gnome.zenity}/bin"