about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAlexey Shmalko <rasen.dubi@gmail.com>2019-10-26 15:15:50 +0300
committerGitHub <noreply@github.com>2019-10-26 15:15:50 +0300
commit140d402cb5f098f1a67ff757a0be41b349078c00 (patch)
tree5b725965f1e5fdb9c8118acc11a207e8387d57be /pkgs/applications
parentec53f1d0846208891338bd6c890423cc0f99cbad (diff)
parent905245b32ce8d3901f730c72854734a7e75e5347 (diff)
downloadnixlib-140d402cb5f098f1a67ff757a0be41b349078c00.tar
nixlib-140d402cb5f098f1a67ff757a0be41b349078c00.tar.gz
nixlib-140d402cb5f098f1a67ff757a0be41b349078c00.tar.bz2
nixlib-140d402cb5f098f1a67ff757a0be41b349078c00.tar.lz
nixlib-140d402cb5f098f1a67ff757a0be41b349078c00.tar.xz
nixlib-140d402cb5f098f1a67ff757a0be41b349078c00.tar.zst
nixlib-140d402cb5f098f1a67ff757a0be41b349078c00.zip
Merge pull request #71991 from iimog/dcmtk
DCMTK: init at 3.6.4
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/medicine/dcmtk/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/applications/science/medicine/dcmtk/default.nix b/pkgs/applications/science/medicine/dcmtk/default.nix
new file mode 100644
index 000000000000..7c269063b917
--- /dev/null
+++ b/pkgs/applications/science/medicine/dcmtk/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchFromGitHub, zlib, libtiff, libxml2, openssl, libiconv, libpng, cmake }:
+
+with stdenv.lib;
+stdenv.mkDerivation rec {
+  pname = "dcmtk";
+  version = "3.6.4";
+  src = fetchFromGitHub {
+    owner = "DCMTK";
+    repo = pname;
+    rev = "DCMTK-${version}";
+    sha256 = "0fbx35zax8n4gayaac5bankqwzg2y2adggykbbf8lpd773jfxsp6";
+  };
+
+  nativeBuildInputs = [ cmake ];
+  buildInputs = [ libpng zlib libtiff libxml2 openssl libiconv ];
+
+  meta = {
+    description = "Collection of libraries and applications implementing large parts of the DICOM standard";
+    longDescription = ''
+      DCMTK is a collection of libraries and applications implementing large parts of the DICOM standard.
+      It includes software for examining, constructing and converting DICOM image files, handling offline media,
+      sending and receiving images over a network connection, as well as demonstrative image storage and worklist servers.
+      DCMTK is is written in a mixture of ANSI C and C++.
+      It comes in complete source code and is made available as "open source" software.
+    '';
+    homepage = "https://dicom.offis.de/dcmtk";
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ iimog ];
+    platforms = platforms.linux;
+  };
+}