about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-05 15:43:06 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-05 15:43:06 +0000
commit125c7ea4e36d2563550dae8c228607c9888d76fc (patch)
tree58c32e2da52f16b461864f184a400bdd6f7f3d0e /pkgs/applications
parent13463a6f0171da354ad056ffd7aca4cc002c0f0f (diff)
downloadnixlib-125c7ea4e36d2563550dae8c228607c9888d76fc.tar
nixlib-125c7ea4e36d2563550dae8c228607c9888d76fc.tar.gz
nixlib-125c7ea4e36d2563550dae8c228607c9888d76fc.tar.bz2
nixlib-125c7ea4e36d2563550dae8c228607c9888d76fc.tar.lz
nixlib-125c7ea4e36d2563550dae8c228607c9888d76fc.tar.xz
nixlib-125c7ea4e36d2563550dae8c228607c9888d76fc.tar.zst
nixlib-125c7ea4e36d2563550dae8c228607c9888d76fc.zip
* Qemu: apply the Samba patch from KVM.
svn path=/nixpkgs/trunk/; revision=11991
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/qemu/0.9.0.nix28
-rw-r--r--pkgs/applications/virtualization/qemu/0.9.1.nix44
2 files changed, 18 insertions, 54 deletions
diff --git a/pkgs/applications/virtualization/qemu/0.9.0.nix b/pkgs/applications/virtualization/qemu/0.9.0.nix
deleted file mode 100644
index db49632f9041..000000000000
--- a/pkgs/applications/virtualization/qemu/0.9.0.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-args : with args;
-	let localDefs = builderDefs {
-		src = /* put a fetchurl here */
-		fetchurl {
-			url = http://fabrice.bellard.free.fr/qemu/qemu-0.9.0.tar.gz;
-			sha256 = "1h85njd8xvn472yhcm92rjyzqjr719ab73rxwmz9cm2n6gwsq7s9";
-		};
-
-		buildInputs = [ SDL zlib which ];
-		configureFlags = [];
-	} null; /* null is a terminator for sumArgs */
-	in with localDefs;
-let 
-preConfigure = FullDepEntry ("
-  gcc --version
-") [minInit];
-in
-stdenv.mkDerivation rec {
-	name = "qemu-"+version;
-	builder = writeScript (name + "-builder")
-		(textClosure localDefs [ preConfigure doConfigure doMakeInstall doForceShare doPropagate]);
-	meta = {
-		description = "
-		QEmu processor emulator.
-";
-		inherit src;
-	};
-}
diff --git a/pkgs/applications/virtualization/qemu/0.9.1.nix b/pkgs/applications/virtualization/qemu/0.9.1.nix
index 1d1774a5c7bd..bb5ad173c0a1 100644
--- a/pkgs/applications/virtualization/qemu/0.9.1.nix
+++ b/pkgs/applications/virtualization/qemu/0.9.1.nix
@@ -1,28 +1,20 @@
-args : with args;
-	let localDefs = builderDefs {
-		src = /* put a fetchurl here */
-		fetchurl {
-			url = http://fabrice.bellard.free.fr/qemu/qemu-0.9.1.tar.gz;
-			sha256 = "199mb12w141yh2afzznh539jsip4h79kfsxwaj1xhzfwljsd0mj7";
-		};
+{stdenv, fetchurl, SDL, zlib, which}:
 
-		buildInputs = [ SDL zlib which ];
-		configureFlags = [ ];
-	} null; /* null is a terminator for sumArgs */
-	in with localDefs;
-let 
-preConfigure = FullDepEntry ("
-  gcc --version
-") [minInit];
-in
-stdenv.mkDerivation rec {
-	name = "qemu-"+version;
-	builder = writeScript (name + "-builder")
-		(textClosure localDefs [ preConfigure doConfigure doMakeInstall doForceShare doPropagate]);
-	meta = {
-		description = "
-		QEmu processor emulator.
-";
-		inherit src;
-	};
+stdenv.mkDerivation {
+  name = "qemu-0.9.1";
+
+  src = fetchurl {
+    url = http://bellard.org/qemu/qemu-0.9.1.tar.gz;
+    sha256 = "199mb12w141yh2afzznh539jsip4h79kfsxwaj1xhzfwljsd0mj7";
+  };
+
+  patches = [../../../os-specific/linux/kvm/smbd-path.patch];
+
+  patchFlags = "-p2";
+  
+  buildInputs = [SDL zlib which];
+  
+  meta = {
+    description = "QEmu processor emulator";
+  };
 }