about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-06-25 13:17:48 +0200
committerGitHub <noreply@github.com>2018-06-25 13:17:48 +0200
commit104194f641abcf3087a1c8800ec261d361e8b8ca (patch)
tree5b42f9d5c191a64f6401e250cea023e3e0523479 /pkgs/applications
parent2cd0c2e2df0075b9ea88b8b98db39cd71f214456 (diff)
parent0dfc32989118c5441df52676de90a865e6e0abf9 (diff)
downloadnixlib-104194f641abcf3087a1c8800ec261d361e8b8ca.tar
nixlib-104194f641abcf3087a1c8800ec261d361e8b8ca.tar.gz
nixlib-104194f641abcf3087a1c8800ec261d361e8b8ca.tar.bz2
nixlib-104194f641abcf3087a1c8800ec261d361e8b8ca.tar.lz
nixlib-104194f641abcf3087a1c8800ec261d361e8b8ca.tar.xz
nixlib-104194f641abcf3087a1c8800ec261d361e8b8ca.tar.zst
nixlib-104194f641abcf3087a1c8800ec261d361e8b8ca.zip
Merge pull request #42541 from flokli/casync
casync: init at 2-152-ge4a3c5e
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/sync/casync/default.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/pkgs/applications/networking/sync/casync/default.nix b/pkgs/applications/networking/sync/casync/default.nix
new file mode 100644
index 000000000000..82dd3a506dee
--- /dev/null
+++ b/pkgs/applications/networking/sync/casync/default.nix
@@ -0,0 +1,52 @@
+{ stdenv, fetchFromGitHub, fetchpatch
+, meson, ninja, pkgconfig, sphinx
+, acl, curl, fuse, libselinux, udev, xz, zstd
+, fuseSupport ? true
+, selinuxSupport ? true
+, udevSupport ? true
+, glibcLocales, rsync
+}:
+
+stdenv.mkDerivation rec {
+  name = "casync-${version}";
+  version = "2-152-ge4a3c5e";
+
+  src = fetchFromGitHub {
+    owner  = "systemd";
+    repo   = "casync";
+    rev    = "e4a3c5efc8f11e0e99f8cc97bd417665d92b40a9";
+    sha256 = "0zx6zvj5a6rr3w9s207rvpfw7gwssiqmp1p3c75bsirmz4nmsdf0";
+  };
+
+  buildInputs = [ acl curl xz zstd ]
+                ++ stdenv.lib.optionals (fuseSupport) [ fuse ]
+                ++ stdenv.lib.optionals (selinuxSupport) [ libselinux ]
+                ++ stdenv.lib.optionals (udevSupport) [ udev ];
+  nativeBuildInputs = [ meson ninja pkgconfig sphinx ];
+  checkInputs = [ glibcLocales rsync ];
+
+  postPatch = ''
+    for f in test/test-*.sh.in; do
+      patchShebangs $f
+    done
+    patchShebangs test/http-server.py
+  '';
+
+  PKG_CONFIG_UDEV_UDEVDIR = "lib/udev";
+  mesonFlags = stdenv.lib.optionals (!fuseSupport) [ "-Dfuse=false" ]
+               ++ stdenv.lib.optionals (!udevSupport) [ "-Dudev=false" ]
+               ++ stdenv.lib.optionals (!selinuxSupport) [ "-Dselinux=false" ];
+
+  doCheck = true;
+  preCheck = ''
+    export LC_ALL="en_US.utf-8"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Content-Addressable Data Synchronizer";
+    homepage    = https://github.com/systemd/casync;
+    license     = licenses.lgpl21;
+    platforms   = platforms.linux;
+    maintainers = with maintainers; [ flokli ];
+  };
+}