about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJaakko Luttinen <jaakko.luttinen@iki.fi>2020-04-01 09:42:37 +0300
committerJaakko Luttinen <jaakko.luttinen@iki.fi>2020-04-01 12:48:42 +0300
commit0f93c20c149ca6e78e34ce3b82d925c170e89007 (patch)
treecbd983aaca654a6e4460d86575c182d9a51996c8 /pkgs/applications
parent3320a06049fc259e87a2bd98f4cd42f15f746b96 (diff)
downloadnixlib-0f93c20c149ca6e78e34ce3b82d925c170e89007.tar
nixlib-0f93c20c149ca6e78e34ce3b82d925c170e89007.tar.gz
nixlib-0f93c20c149ca6e78e34ce3b82d925c170e89007.tar.bz2
nixlib-0f93c20c149ca6e78e34ce3b82d925c170e89007.tar.lz
nixlib-0f93c20c149ca6e78e34ce3b82d925c170e89007.tar.xz
nixlib-0f93c20c149ca6e78e34ce3b82d925c170e89007.tar.zst
nixlib-0f93c20c149ca6e78e34ce3b82d925c170e89007.zip
kdenlive: set run-time dep paths (fix #83885)
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/kde/ffmpeg-path.patch25
-rw-r--r--pkgs/applications/kde/kdenlive.nix12
2 files changed, 36 insertions, 1 deletions
diff --git a/pkgs/applications/kde/ffmpeg-path.patch b/pkgs/applications/kde/ffmpeg-path.patch
new file mode 100644
index 000000000000..a0cef882f596
--- /dev/null
+++ b/pkgs/applications/kde/ffmpeg-path.patch
@@ -0,0 +1,25 @@
+diff --git a/src/kdenlivesettings.kcfg b/src/kdenlivesettings.kcfg
+index 5edad5ae7..d35347a40 100644
+--- a/src/kdenlivesettings.kcfg
++++ b/src/kdenlivesettings.kcfg
+@@ -403,17 +403,17 @@
+ 
+     <entry name="ffmpegpath" type="Path">
+       <label>FFmpeg / Libav binary path.</label>
+-      <default></default>
++      <default>@ffmpeg@/bin/ffmpeg</default>
+     </entry>
+ 
+     <entry name="ffplaypath" type="Path">
+       <label>FFplay / avplay binary path.</label>
+-      <default></default>
++      <default>@ffmpeg@/bin/ffplay</default>
+     </entry>
+ 
+     <entry name="ffprobepath" type="Path">
+       <label>FFprobe / avprobe binary path.</label>
+-      <default></default>
++      <default>@ffmpeg@/bin/ffprobe</default>
+     </entry>
+ 
+     <entry name="mltthreads" type="Int">
diff --git a/pkgs/applications/kde/kdenlive.nix b/pkgs/applications/kde/kdenlive.nix
index b7c691e9594b..95496f90e043 100644
--- a/pkgs/applications/kde/kdenlive.nix
+++ b/pkgs/applications/kde/kdenlive.nix
@@ -70,14 +70,24 @@ mkDerivation {
     kpurpose
     kdeclarative
   ];
-  patches = [ ./mlt-path.patch ];
+  # Both MLT and FFMpeg paths must be set or Kdenlive will complain that it
+  # doesn't find them. See:
+  # https://github.com/NixOS/nixpkgs/issues/83885
+  patches = [ ./mlt-path.patch ./ffmpeg-path.patch ];
   inherit mlt;
+  ffmpeg = ffmpeg-full;
   postPatch =
     # Module Qt5::Concurrent must be included in `find_package` before it is used.
     ''
       sed -i CMakeLists.txt -e '/find_package(Qt5 REQUIRED/ s|)| Concurrent)|'
       substituteAllInPlace src/kdenlivesettings.kcfg
     '';
+  # Frei0r path needs to be set too or Kdenlive will complain. See:
+  # https://github.com/NixOS/nixpkgs/issues/83885
+  # https://github.com/NixOS/nixpkgs/issues/29614#issuecomment-488849325
+  qtWrapperArgs = [
+    "--set FREI0R_PATH ${frei0r}/lib/frei0r-1"
+  ];
   meta = {
     license = with lib.licenses; [ gpl2Plus ];
   };