about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <v@cunat.cz>2019-06-23 10:37:54 +0200
committerVladimír Čunát <v@cunat.cz>2019-06-23 10:37:54 +0200
commit0e405474d13102a5b29ac69e9437607f29ea6a42 (patch)
tree3da970ca1574b69ef1820bb900a55f90bae21a74 /pkgs/applications
parentbd286ce6e534ec3c6c75c55984eb36d75c4ab828 (diff)
parentbc4e718db6b1d2d3b76d23e9106427d9198e5542 (diff)
downloadnixlib-0e405474d13102a5b29ac69e9437607f29ea6a42.tar
nixlib-0e405474d13102a5b29ac69e9437607f29ea6a42.tar.gz
nixlib-0e405474d13102a5b29ac69e9437607f29ea6a42.tar.bz2
nixlib-0e405474d13102a5b29ac69e9437607f29ea6a42.tar.lz
nixlib-0e405474d13102a5b29ac69e9437607f29ea6a42.tar.xz
nixlib-0e405474d13102a5b29ac69e9437607f29ea6a42.tar.zst
nixlib-0e405474d13102a5b29ac69e9437607f29ea6a42.zip
Merge #62280: xournalpp: 1.0.8 -> 1.0.12
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/xournalpp/default.nix27
1 files changed, 8 insertions, 19 deletions
diff --git a/pkgs/applications/graphics/xournalpp/default.nix b/pkgs/applications/graphics/xournalpp/default.nix
index 30a8907275b0..2487b093148a 100644
--- a/pkgs/applications/graphics/xournalpp/default.nix
+++ b/pkgs/applications/graphics/xournalpp/default.nix
@@ -1,7 +1,6 @@
 { stdenv
 , lib
 , fetchFromGitHub
-, fetchpatch
 
 , cmake
 , gettext
@@ -14,39 +13,26 @@
 , hicolor-icon-theme
 , libsndfile
 , libxml2
+, libzip
 , pcre
 , poppler
 , portaudio
 , zlib
-
-# Plugins don't appear to be working in this version, so disable them by not
-# building with Lua support by default. In a future version, try switching this
-# to 'true' and seeing if the top-level Plugin menu appears.
-, withLua ? false, lua
+# plugins
+, withLua ? true, lua
 }:
 
 stdenv.mkDerivation rec {
   name = "xournalpp-${version}";
-  version = "1.0.8";
+  version = "1.0.12";
 
   src = fetchFromGitHub {
     owner = "xournalpp";
     repo = "xournalpp";
     rev = version;
-    sha256 = "01q84xjp9z1krna10gjj562km6i3wdq8cg7paxax1k6bh52ryvf6";
+    sha256 = "0yg70hsx58s3wb5kzccivrqa7kvmdapygxmif1j64hddah2rqcn9";
   };
 
-  patches = [
-    # This patch removes the unused 'xopp-recording.sh' file which breaks the
-    # cmake build; this patch isn't in a release yet, and should be removed at
-    # or after 1.0.9 is released.
-    (fetchpatch {
-      name = "remove-xopp-recording.sh.patch";
-      url = "https://github.com/xournalpp/xournalpp/commit/a17a3f2c80c607a22d0fdeb66d38358bea7e4d85.patch";
-      sha256 = "10pcpvklm6kr0lv2xrsbpg2037ni9j6dmxgjf56p466l3gz60iwy";
-    })
-  ];
-
   nativeBuildInputs = [ cmake gettext pkgconfig wrapGAppsHook ];
   buildInputs =
     [ glib
@@ -55,6 +41,7 @@ stdenv.mkDerivation rec {
       hicolor-icon-theme
       libsndfile
       libxml2
+      libzip
       pcre
       poppler
       portaudio
@@ -62,6 +49,8 @@ stdenv.mkDerivation rec {
     ]
     ++ lib.optional withLua lua;
 
+  hardeningDisable = [ "format" ];
+
   enableParallelBuilding = true;
 
   meta = with stdenv.lib; {