about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2016-05-30 17:01:21 -0500
committerThomas Tuegel <ttuegel@gmail.com>2016-05-30 17:01:21 -0500
commit0d11f9beb5c04257af5224b5ffb8ce4d729b9a02 (patch)
treeef330d3fd7a815b12ca429c8d8935b7b49bd476c /pkgs/applications
parent5086a9c41eb96858cbd9df7d0ea4f5565d49f5b6 (diff)
parenta1facf33625de78723352ee36f9d18dfab9f5993 (diff)
downloadnixlib-0d11f9beb5c04257af5224b5ffb8ce4d729b9a02.tar
nixlib-0d11f9beb5c04257af5224b5ffb8ce4d729b9a02.tar.gz
nixlib-0d11f9beb5c04257af5224b5ffb8ce4d729b9a02.tar.bz2
nixlib-0d11f9beb5c04257af5224b5ffb8ce4d729b9a02.tar.lz
nixlib-0d11f9beb5c04257af5224b5ffb8ce4d729b9a02.tar.xz
nixlib-0d11f9beb5c04257af5224b5ffb8ce4d729b9a02.tar.zst
nixlib-0d11f9beb5c04257af5224b5ffb8ce4d729b9a02.zip
Merge branch 'qt-cmake-paths'
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/instant-messengers/qtox/default.nix4
-rw-r--r--pkgs/applications/networking/p2p/qbittorrent/default.nix6
2 files changed, 6 insertions, 4 deletions
diff --git a/pkgs/applications/networking/instant-messengers/qtox/default.nix b/pkgs/applications/networking/instant-messengers/qtox/default.nix
index d244c4d11c41..50017de132c9 100644
--- a/pkgs/applications/networking/instant-messengers/qtox/default.nix
+++ b/pkgs/applications/networking/instant-messengers/qtox/default.nix
@@ -43,9 +43,13 @@ stdenv.mkDerivation rec {
   '';
 
   installPhase = ''
+    runHook preInstall
+
     mkdir -p $out/bin
     cp qtox $out/bin
     wrapQtProgram $out/bin/qtox
+
+    runHook postInstall
   '';
 
   enableParallelBuilding = true;
diff --git a/pkgs/applications/networking/p2p/qbittorrent/default.nix b/pkgs/applications/networking/p2p/qbittorrent/default.nix
index 77624c0d9383..78f2c79923a4 100644
--- a/pkgs/applications/networking/p2p/qbittorrent/default.nix
+++ b/pkgs/applications/networking/p2p/qbittorrent/default.nix
@@ -17,15 +17,13 @@ stdenv.mkDerivation rec {
     sha256 = "1f4impsjck8anl39pwypsck7j6xw0dl18qd0b4xi23r45jvx9l60";
   };
 
-  nativeBuildInputs = [ pkgconfig which qmakeHook ];
+  nativeBuildInputs = [ pkgconfig which ];
 
   buildInputs = [ boost libtorrentRasterbar qt5.qtbase qt5.qttools ]
     ++ optional guiSupport dbus_libs;
 
-  dontUseQmakeConfigure = true;
-
   preConfigure = ''
-    export QT_QMAKE="$qtOut/bin"
+    export QT_QMAKE=$(dirname "$QMAKE")
   '';
 
   configureFlags = [