about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPavel Sobolev <paveloom@riseup.net>2023-08-05 13:24:23 +0300
committerPavel Sobolev <paveloom@riseup.net>2023-08-05 13:25:22 +0300
commit0ba388c9676bdbfd62bc5bc59055bc3e197365e7 (patch)
treec7511114382583efa5cf7e5c8270b3d84dd91937 /pkgs/applications
parent82326d676dcb51f262ee7e17b241385c97c646f9 (diff)
downloadnixlib-0ba388c9676bdbfd62bc5bc59055bc3e197365e7.tar
nixlib-0ba388c9676bdbfd62bc5bc59055bc3e197365e7.tar.gz
nixlib-0ba388c9676bdbfd62bc5bc59055bc3e197365e7.tar.bz2
nixlib-0ba388c9676bdbfd62bc5bc59055bc3e197365e7.tar.lz
nixlib-0ba388c9676bdbfd62bc5bc59055bc3e197365e7.tar.xz
nixlib-0ba388c9676bdbfd62bc5bc59055bc3e197365e7.tar.zst
nixlib-0ba388c9676bdbfd62bc5bc59055bc3e197365e7.zip
picard: 2.8.5 -> 2.9
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/picard/default.nix25
1 files changed, 15 insertions, 10 deletions
diff --git a/pkgs/applications/audio/picard/default.nix b/pkgs/applications/audio/picard/default.nix
index 983457530ad1..76a719c5ba1c 100644
--- a/pkgs/applications/audio/picard/default.nix
+++ b/pkgs/applications/audio/picard/default.nix
@@ -10,21 +10,22 @@
 
 let
   pythonPackages = python3Packages;
-  pyqt5 = if enablePlayback then
-    pythonPackages.pyqt5_with_qtmultimedia
-  else
-    pythonPackages.pyqt5
+  pyqt5 =
+    if enablePlayback then
+      pythonPackages.pyqt5_with_qtmultimedia
+    else
+      pythonPackages.pyqt5
   ;
 in
 pythonPackages.buildPythonApplication rec {
   pname = "picard";
-  version = "2.8.5";
+  version = "2.9";
 
   src = fetchFromGitHub {
     owner = "metabrainz";
-    repo = pname;
+    repo = "picard";
     rev = "refs/tags/release-${version}";
-    sha256 = "sha256-ukqlAXGaqX89U77cM9Ux0RYquT31Ho8ri1Ue7S3+MwQ=";
+    hash = "sha256-ultpLz4u2wBxoL4YbNeZ4Z4NEXBvqpxJ8mzFeGQTt4A=";
   };
 
   nativeBuildInputs = [
@@ -37,6 +38,7 @@ pythonPackages.buildPythonApplication rec {
     gst_all_1.gst-vaapi
     gst_all_1.gstreamer
   ];
+
   buildInputs = [
     qt5.qtbase
     qt5.qtwayland
@@ -56,20 +58,23 @@ pythonPackages.buildPythonApplication rec {
     pyyaml
   ];
 
+  preCheck = ''
+    export HOME=$(mktemp -d)
+  '';
+
   # In order to spare double wrapping, we use:
   preFixup = ''
     makeWrapperArgs+=("''${qtWrapperArgs[@]}")
   ''
   + lib.optionalString (pyqt5.multimediaEnabled) ''
     makeWrapperArgs+=(--prefix GST_PLUGIN_SYSTEM_PATH_1_0 : "$GST_PLUGIN_SYSTEM_PATH_1_0")
-  ''
-  ;
+  '';
 
   meta = with lib; {
     homepage = "https://picard.musicbrainz.org/";
     changelog = "https://picard.musicbrainz.org/changelog/";
     description = "The official MusicBrainz tagger";
-    maintainers = with maintainers; [ ehmry ];
+    maintainers = with maintainers; [ ehmry paveloom ];
     license = licenses.gpl2Plus;
     platforms = platforms.all;
   };